summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/autoproject
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/autoproject')
-rw-r--r--dev-util/autoproject/Manifest3
-rw-r--r--dev-util/autoproject/autoproject-0.20.ebuild31
-rw-r--r--dev-util/autoproject/autoproject-0.20_p5.ebuild34
-rw-r--r--dev-util/autoproject/metadata.xml5
4 files changed, 73 insertions, 0 deletions
diff --git a/dev-util/autoproject/Manifest b/dev-util/autoproject/Manifest
new file mode 100644
index 000000000000..a92f53a0959f
--- /dev/null
+++ b/dev-util/autoproject/Manifest
@@ -0,0 +1,3 @@
+DIST autoproject_0.20-3.diff.gz 4704 SHA256 f201fc7431d189c80297fba31867013e9efe6dec2c19399d52e9ceb4356ee562 SHA512 8058fb2430010ddc8613c9e310c262b28379eb3d38b7e9badca7e3adb3560e5965bbe6612a0211d38920094a4851502471f9e1670e694ea3ef7d29bbfde340e9 WHIRLPOOL ad827a1424856f6dc3ddf91f5209414c77a4bccab7b969429a9c9c44bf75146e4c7139268d76f274fa72639a72e7ee7ef4ba32ec7ece5260e29617b134b2fc7d
+DIST autoproject_0.20-5.diff.gz 5287 SHA256 b7ece8099d19453cb6eff78b2ce6b8fc4f1cfb72e8bdfe4cbd6d7eb7f277b59b SHA512 156f8feff53936c3113bda9d8a3f2e19679f249656ace69aacb1f0a13ae93066eef49de3e5a268c47ed3e440144de629f6b84a477ecfc6a3f793c41412cc9b5a WHIRLPOOL eaf1aff7d4e2f8a3b49d2ad7c41e1115c57c076aa5dc441562546d352387a30b996cbe8079ca3193c57ae6bad3a12bed4b13c6562a51e24b48ba08f0af22ecfc
+DIST autoproject_0.20.orig.tar.gz 151101 SHA256 850ff70e250fbd34c1193461b0fc8e1254803ee22a9d116cdbcc822b551766cc SHA512 eb6ba12af96e03f4da51b6b9fc0db618180d92b8a363f30182013a003bb13f5b66ee12b28531a234f6035b64bda29bb0f838466ccbeaddbce06a437a18c05288 WHIRLPOOL 83616aca1fe8ce08b509058585f740ace8121544910846a137940965f5ee8e904fd2f04ee158ea5e312a2a8a2cf9c7be1ee6a02430bb1f58cb1ccbf9abc6e335
diff --git a/dev-util/autoproject/autoproject-0.20.ebuild b/dev-util/autoproject/autoproject-0.20.ebuild
new file mode 100644
index 000000000000..9286454a1d88
--- /dev/null
+++ b/dev-util/autoproject/autoproject-0.20.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DEB_VER=3
+DESCRIPTION="Used to start a programming project using autotools and a command line parser generator"
+HOMEPAGE="http://packages.debian.org/unstable/devel/autoproject"
+SRC_URI="mirror://debian/pool/main/a/autoproject/${PN}_${PV}.orig.tar.gz
+ mirror://debian/pool/main/a/autoproject/${PN}_${PV}-${DEB_VER}.diff.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc x86"
+IUSE="test"
+
+RDEPEND="sys-devel/automake
+ sys-devel/autoconf"
+DEPEND="${RDEPEND}
+ test? ( sys-apps/texinfo )"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${PN}_${PV}-${DEB_VER}.diff
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+ dodoc AUTHORS NEWS README TODO ChangeLog
+}
diff --git a/dev-util/autoproject/autoproject-0.20_p5.ebuild b/dev-util/autoproject/autoproject-0.20_p5.ebuild
new file mode 100644
index 000000000000..0df09eb4c481
--- /dev/null
+++ b/dev-util/autoproject/autoproject-0.20_p5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+MY_PV=${PV%_p*}
+DEB_VER=${PV#*_p}
+DESCRIPTION="Used to start a programming project using autotools and a command line parser generator"
+HOMEPAGE="http://packages.debian.org/unstable/devel/autoproject"
+SRC_URI="mirror://debian/pool/main/a/autoproject/${PN}_${MY_PV}.orig.tar.gz
+ mirror://debian/pool/main/a/autoproject/${PN}_${MY_PV}-${DEB_VER}.diff.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="test"
+
+RDEPEND="sys-devel/automake
+ sys-devel/autoconf"
+DEPEND="${RDEPEND}
+ test? ( sys-apps/texinfo )"
+
+S=${WORKDIR}/${PN}-${MY_PV}
+
+src_unpack() {
+ unpack ${A}
+ epatch ${PN}_${MY_PV}-${DEB_VER}.diff
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc AUTHORS NEWS README TODO ChangeLog
+}
diff --git a/dev-util/autoproject/metadata.xml b/dev-util/autoproject/metadata.xml
new file mode 100644
index 000000000000..96a2d586367d
--- /dev/null
+++ b/dev-util/autoproject/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>base-system</herd>
+</pkgmetadata>