summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuke Dashjr <luke-jr+git@utopios.org>2016-03-19 23:18:05 +0000
committerAnthony G. Basile <blueness@gentoo.org>2016-03-20 11:42:55 -0400
commitd5fb469859f75c12eb5874dedcd0be3026179a1c (patch)
treee0a48073381b9d276c7cb7b36fcc857bc953d8d8 /dev-util/bitcoin-tx/bitcoin-tx-0.12.0.ebuild
parentdev-libs/univalue: initial commit, version 1.0.2 (diff)
downloadgentoo-d5fb469859f75c12eb5874dedcd0be3026179a1c.tar.gz
gentoo-d5fb469859f75c12eb5874dedcd0be3026179a1c.tar.bz2
gentoo-d5fb469859f75c12eb5874dedcd0be3026179a1c.zip
net-p2p/bitcoin*: bump all pkgs to 0.12.0 and update 9999
Diffstat (limited to 'dev-util/bitcoin-tx/bitcoin-tx-0.12.0.ebuild')
-rw-r--r--dev-util/bitcoin-tx/bitcoin-tx-0.12.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-util/bitcoin-tx/bitcoin-tx-0.12.0.ebuild b/dev-util/bitcoin-tx/bitcoin-tx-0.12.0.ebuild
new file mode 100644
index 000000000000..63f25e2d7c52
--- /dev/null
+++ b/dev-util/bitcoin-tx/bitcoin-tx-0.12.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2010-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+BITCOINCORE_COMMITHASH="188ca9c305d3dd0fb462b9d6a44048b1d99a05f3"
+BITCOINCORE_LJR_DATE="20160226"
+BITCOINCORE_LJR_PREV="rc1"
+BITCOINCORE_IUSE="ljr"
+BITCOINCORE_NEED_LIBSECP256K1=1
+BITCOINCORE_NO_DEPEND="libevent"
+inherit bitcoincore
+
+DESCRIPTION="Command-line Bitcoin transaction tool"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+src_configure() {
+ bitcoincore_conf \
+ --enable-util-tx
+}