summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-01-15 13:28:46 +0100
committerDavid Seifert <soap@gentoo.org>2022-01-15 13:28:46 +0100
commita105303e1edf2afd91440ff0e6598b68b48d946f (patch)
tree369d5b6eac9b2274dcfbe719c58789fe8affec8a /dev-util/boost-build
parentdev-libs/boost: drop 1.76.0-r1 (diff)
downloadgentoo-a105303e1edf2afd91440ff0e6598b68b48d946f.tar.gz
gentoo-a105303e1edf2afd91440ff0e6598b68b48d946f.tar.bz2
gentoo-a105303e1edf2afd91440ff0e6598b68b48d946f.zip
dev-util/boost-build: drop 1.76.0-r2
Closes: https://github.com/gentoo/gentoo/pull/23805 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-util/boost-build')
-rw-r--r--dev-util/boost-build/Manifest1
-rw-r--r--dev-util/boost-build/boost-build-1.76.0-r2.ebuild74
-rw-r--r--dev-util/boost-build/files/boost-build-1.71.0-darwin-gentoo-toolchain.patch26
-rw-r--r--dev-util/boost-build/files/boost-build-1.76.0-python-numpy.patch24
4 files changed, 0 insertions, 125 deletions
diff --git a/dev-util/boost-build/Manifest b/dev-util/boost-build/Manifest
index 220b981ce1dc..f311fa642643 100644
--- a/dev-util/boost-build/Manifest
+++ b/dev-util/boost-build/Manifest
@@ -1,3 +1,2 @@
-DIST boost_1_76_0.tar.bz2 110073117 BLAKE2B 45445e6a9725cb99131e0b831b2fac0840d083692c13887b41adeac5cb8b3732026db3641d6be20591a676b78a87fcf363eb9b1508f87ed26039bba6a1ced533 SHA512 5d68bed98c57e03b4cb2420d9b856e5f0669561a6142a4b0c9c8a58dc5b6b28e16ccbb16ac559c3a3198c45769a246bf996b96cb7b6a019dd15f05c2270e9429
DIST boost_1_77_0.tar.bz2 110361537 BLAKE2B 106aeb09ec7705b595f2ca966a76c53c649eac6fac50d88c156862e0991c33c89a2f3a09edcbcb453fa44bf71cdde030b35d0a0889ad97b65f3a868cb877a532 SHA512 39b45c9b60bc5a2a4c669a4463d1272c1e093376b2fb374d7f20a84ea10a3e23bb04b335a735a83a04575731f874d9bff77e89acd947524b3fbbae1b26ae1f2f
DIST boost_1_78_0.tar.bz2 110675550 BLAKE2B ed7da98862ec1e0a28472544400e6f44ffadbc967eed969ce6cb62b1c4f0b7a4b98a395269eb374b57326eff9cdb1dd6e47df9d1a9730aff7c926cc44388fb2d SHA512 9c34a387a203b99aa773eb0c59f5abac7a99ba10e4623653e793c1d5b29b99b88e0e4e0d4e2e4ca5d497c42f2e46e23bab66417722433a457dc818d7670bcbbf
diff --git a/dev-util/boost-build/boost-build-1.76.0-r2.ebuild b/dev-util/boost-build/boost-build-1.76.0-r2.ebuild
deleted file mode 100644
index 1e0b91062eb0..000000000000
--- a/dev-util/boost-build/boost-build-1.76.0-r2.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit flag-o-matic toolchain-funcs
-
-MY_PV="$(ver_rs 1- _)"
-
-DESCRIPTION="A system for large project software construction, simple to use and powerful"
-HOMEPAGE="https://www.boost.org/build/"
-SRC_URI="https://boostorg.jfrog.io/artifactory/main/release/${PV}/source/boost_${MY_PV}.tar.bz2"
-S="${WORKDIR}/boost_${MY_PV}/tools/build/src"
-
-LICENSE="Boost-1.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="examples"
-RESTRICT="test"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.71.0-disable_python_rpath.patch
- "${FILESDIR}"/${PN}-1.71.0-darwin-gentoo-toolchain.patch
- "${FILESDIR}"/${PN}-1.73.0-add-none-feature-options.patch
- "${FILESDIR}"/${PN}-1.76.0-respect-user-flags.patch
- "${FILESDIR}"/${PN}-1.74.0-no-implicit-march-flags.patch
- "${FILESDIR}"/${PN}-1.76.0-python-numpy.patch
-)
-
-src_unpack() {
- tar xojf "${DISTDIR}/${A}" boost_${MY_PV}/tools/build || die "unpacking tar failed"
-}
-
-src_prepare() {
- default
-
- pushd .. >/dev/null || die
- eapply "${FILESDIR}"/${PN}-1.71.0-fix-test.patch
- popd >/dev/null || die
-}
-
-src_configure() {
- # need to enable LFS explicitly for 64-bit offsets on 32-bit hosts (#761100)
- append-lfs-flags
-}
-
-src_compile() {
- cd engine || die
- ${CONFIG_SHELL:-${BASH}} ./build.sh cxx --cxx="$(tc-getCXX)" --cxxflags="${CXXFLAGS}" -d+2 --without-python || die "building bjam failed"
-}
-
-src_test() {
- # Forget tests, bjam is a lost cause
- :
-}
-
-src_install() {
- dobin engine/{bjam,b2}
-
- insinto /usr/share/boost-build/src
- doins -r "${FILESDIR}/site-config.jam" \
- ../boost-build.jam bootstrap.jam build-system.jam ../example/user-config.jam *.py \
- build kernel options tools util
-
- find "${ED}"/usr/share/boost-build/src -iname '*.py' -delete || die
-
- dodoc ../notes/{changes,release_procedure,build_dir_option,relative_source_paths}.txt
-
- if use examples; then
- docinto examples
- dodoc -r ../example/.
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}
diff --git a/dev-util/boost-build/files/boost-build-1.71.0-darwin-gentoo-toolchain.patch b/dev-util/boost-build/files/boost-build-1.71.0-darwin-gentoo-toolchain.patch
deleted file mode 100644
index 3693677540a4..000000000000
--- a/dev-util/boost-build/files/boost-build-1.71.0-darwin-gentoo-toolchain.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-Avoid adding all kinds of things to the toolchain's flags that within
-Gentoo (Prefix) we really shouldn't, such as sysroot, deployment target,
-arch, etc.
-
---- a/tools/darwin.jam
-+++ b/tools/darwin.jam
-@@ -239,6 +239,9 @@
- }
- }
-
-+ # leave compiler flags etc. up to the toolchain
-+ return $(version-feature) ;
-+
- if $(version-feature)
- {
- if $(.debug-configuration)
-@@ -447,7 +450,8 @@
- support-ppc64 = ;
- }
- }
-- switch $(arch)
-+ # Gentoo Prefix toolchain doesn't do multi-arch, so don't try either
-+ switch $(donotaddarchpleaseXXXarch)
- {
- case combined :
- {
diff --git a/dev-util/boost-build/files/boost-build-1.76.0-python-numpy.patch b/dev-util/boost-build/files/boost-build-1.76.0-python-numpy.patch
deleted file mode 100644
index ed04d5426341..000000000000
--- a/dev-util/boost-build/files/boost-build-1.76.0-python-numpy.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-From 61adb508853be1fa2c01a0c3a0c55fbd16cb9a52 Mon Sep 17 00:00:00 2001
-From: Peter Dimov <pdimov@gmail.com>
-Date: Mon, 24 May 2021 22:11:23 +0300
-Subject: [PATCH] Declare the /python//numpy target to hold the include path
- (fixes #725)
-
----
- tools/python.jam | 3 +++
- 1 file changed, 3 insertions(+)
-
-diff --git a/tools/python.jam b/tools/python.jam
-index 00706932d2..0dfc750a22 100644
---- a/tools/python.jam
-+++ b/tools/python.jam
-@@ -1052,6 +1052,9 @@ local rule configure ( version ? : cmd-or-prefix ? : includes * : libraries ? :
- ;
- }
-
-+ # Declare the numpy target, which contains the NumPy include directory
-+
-+ alias numpy : : $(target-requirements) : : <include>$(.numpy-include) ;
- }
-
- # Conditional rule specification that will prevent building of a target