summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2017-08-10 21:57:18 +0000
committerBrian Dolbec <dolsen@gentoo.org>2017-08-10 22:00:07 +0000
commitab91d842ebc652ce9df4dde9c3ac0b36c8599533 (patch)
tree769d926696af3cfa480e9b27a5ddf1198c4f9fa4 /dev-util/buildbot-console-view
parentdev-util/buildbot-waterfall-view: Version bump (diff)
downloadgentoo-ab91d842ebc652ce9df4dde9c3ac0b36c8599533.tar.gz
gentoo-ab91d842ebc652ce9df4dde9c3ac0b36c8599533.tar.bz2
gentoo-ab91d842ebc652ce9df4dde9c3ac0b36c8599533.zip
dev-util/buildbot-console-view: Version bump
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'dev-util/buildbot-console-view')
-rw-r--r--dev-util/buildbot-console-view/Manifest1
-rw-r--r--dev-util/buildbot-console-view/buildbot-console-view-0.9.10.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-util/buildbot-console-view/Manifest b/dev-util/buildbot-console-view/Manifest
index ffdef94d3d07..cb987b2da145 100644
--- a/dev-util/buildbot-console-view/Manifest
+++ b/dev-util/buildbot-console-view/Manifest
@@ -1,3 +1,4 @@
+DIST buildbot-console-view-0.9.10.tar.gz 640908 SHA256 ca62780a7405df761fa2d80019890c8b25d79f6b716df26fbc4ce257a21f762e SHA512 a7ad6289a314f096e6375646d17e2f6b595ecae040e9d135334ac46e810d24f6903318e5ef34f015d923b795d01d8e4011dca00b9b6adeb8c91734350f5d1982 WHIRLPOOL fb60315596c0f0d1ef1a07bd9f40a6f194430e5b825979c5e80616fb96c185a3fee126c42634ab7183c1bdb60ff53f058e8ef6085271c29007a468788117deaa
DIST buildbot-console-view-0.9.4.tar.gz 631510 SHA256 16d1ab8801439d50d712883ab155530840588d4d77ab600299ead0ef23da5bf0 SHA512 f2e99e58acea3eebec7600a23597c6235fe93532653352c8e427d4b55a14066534dbc046de02856d738a5943ccdaed0ac14643a830d9d11acf76f6d1760def03 WHIRLPOOL 1d3ec1476d69e68f9bd752f5ff88796b504b997373e82f3428e5ead44f7c19c66278448e61aa1a36bd1d3e2bc7e55e21877537b8d02f9add0d12c5dd7c0e24b7
DIST buildbot-console-view-0.9.7.tar.gz 632458 SHA256 757ee80e5c4b698e6bac7b409c63af7ebd8c00c31117fa290776ad6c103a67c7 SHA512 e07c032e17ce9faa9d71b71c5c48fde9ebde4995dec408781b6bb2ed77edcbe320b8d825a9a4bd76d9f3c48dd445560ec55867639c454591c5b7095e4142c4f2 WHIRLPOOL 58a534d641d3f28272f074998231b4873086cc1c8cc081463545e0d6b49145299e2496974ba6d51150cab505b67c5bd81d56fa9747271b64ed8b487d1409a5ae
DIST buildbot-console-view-0.9.8.tar.gz 632459 SHA256 573b03db8c102114b12bcc29c3224653bbc4a08cce25b91725b4bcee2abd7020 SHA512 f6419fd47b70369866440437521a10a2e4062466878979b0c65594c7d74095c89c01c65cc0641f8faf7dee163347426e50a272f93dfe45ee91d072360e249674 WHIRLPOOL 5bfe80b6f148603f98ff684b1b317e059587d37baf88c04e2f4f6f1eb4f4026d92df57463365f4bf460743c2bc4ce5407cce2df74ff2623f95d09d5b6230d7fa
diff --git a/dev-util/buildbot-console-view/buildbot-console-view-0.9.10.ebuild b/dev-util/buildbot-console-view/buildbot-console-view-0.9.10.ebuild
new file mode 100644
index 000000000000..e40d00b64c60
--- /dev/null
+++ b/dev-util/buildbot-console-view/buildbot-console-view-0.9.10.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python2_7 python3_5 )
+
+EGIT_REPO_URI="https://github.com/buildbot/buildbot.git"
+
+[[ ${PV} == *9999 ]] && inherit git-r3
+inherit distutils-r1
+
+DESCRIPTION="Buildbot console-view plugin"
+HOMEPAGE="https://buildbot.net/ https://github.com/buildbot/buildbot https://pypi.python.org/pypi/buildbot-console-view"
+
+MY_PV="${PV/_p/.post}"
+MY_P="${PN}-${MY_PV}"
+[[ ${PV} == *9999 ]] || SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+if [[ ${PV} == *9999 ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+fi
+
+IUSE="test"
+
+RDEPEND="
+ ~dev-util/buildbot-${PV}[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ ~dev-util/buildbot-www-${PV}[${PYTHON_USEDEP}]
+"
+
+DEPEND="${RDEPEND}
+ >=dev-python/setuptools-21.2.1[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/${MY_P}"
+#[[ ${PV} == *9999 ]] && S=${S}/www/base
+
+python_test() {
+ distutils_install_for_testing
+
+ esetup.py test || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+}