summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2021-01-17 12:38:25 -0500
committerBrian Dolbec <dolsen@gentoo.org>2021-01-17 13:45:29 -0500
commit62fbaaebcc4837780dfb6e223dba17c7a3ed9121 (patch)
tree11ac3846142d48e970d25b19567ffd0a20a6020b /dev-util/buildbot-grid-view
parentdev-util/buildbot-console-view: Version bump to 2.10.0 fix setuptools ?depend (diff)
downloadgentoo-62fbaaebcc4837780dfb6e223dba17c7a3ed9121.tar.gz
gentoo-62fbaaebcc4837780dfb6e223dba17c7a3ed9121.tar.bz2
gentoo-62fbaaebcc4837780dfb6e223dba17c7a3ed9121.zip
dev-util/buildbot-grid-view: Version bump to 2.10.0 fix setuptools ?depend
Closes: https://bugs.gentoo.org/747736 Package-Manager: Portage-3.0.10, Repoman-3.0.2 Signed-off-by: Brian Dolbec <dolsen@gentoo.org>
Diffstat (limited to 'dev-util/buildbot-grid-view')
-rw-r--r--dev-util/buildbot-grid-view/Manifest1
-rw-r--r--dev-util/buildbot-grid-view/buildbot-grid-view-2.10.0.ebuild37
-rw-r--r--dev-util/buildbot-grid-view/buildbot-grid-view-2.8.2.ebuild4
-rw-r--r--dev-util/buildbot-grid-view/buildbot-grid-view-2.8.4.ebuild4
4 files changed, 42 insertions, 4 deletions
diff --git a/dev-util/buildbot-grid-view/Manifest b/dev-util/buildbot-grid-view/Manifest
index 91d0f666e38b..9ab810f7ceb2 100644
--- a/dev-util/buildbot-grid-view/Manifest
+++ b/dev-util/buildbot-grid-view/Manifest
@@ -1,2 +1,3 @@
+DIST buildbot-grid-view-2.10.0.tar.gz 13685 BLAKE2B 56c871b24c48ce6723e8fba803f82b1c751b7a3ca61b8d7ec8adc50aa87f9d64d04ff6551b0a99535c04cbaf9b18763cf6469eadbd115d2f20c060cb97a3a27c SHA512 4e5099922e3e08f18a77aede09b25ee60ee629c7c94d76149164d3e1e4ea1cdb0bd1cb6689bad060c55f55f9a3527d3f49e9a99b963479e39c076e62c5ade085
DIST buildbot-grid-view-2.8.2.tar.gz 13373 BLAKE2B 0a7a73011655e9a57574575943a3560c395ca4358c0f2169def8413a60f8381644512a227b54f016b23e6dcd18641d1ea7a3295f6c0a983c6f3caa9ab1dda60d SHA512 9b136d96f5a38f0d28f6c37db6269e039eca0cff5bbc7d75d43346566ba2e9f7924e453098f4777792429a7a9bbbb5e02c34a9b81e131d40dc3e339f4dd377f1
DIST buildbot-grid-view-2.8.4.tar.gz 13510 BLAKE2B 97816ae90c06cbc3ac63920da4dd2e1152750181a5c23c59d3f227f46131228140e676328aa80741626ff071679dd8c9385f3895ce92d27ce6d0264afe299872 SHA512 dfeb454f9d9162e30e0ea8555a0978ecfad2266e1a9412e0633924ad44ae404144ae4a51b58fdca31fa54b67fe53bab57cac1f54926fee346decf90623f91f89
diff --git a/dev-util/buildbot-grid-view/buildbot-grid-view-2.10.0.ebuild b/dev-util/buildbot-grid-view/buildbot-grid-view-2.10.0.ebuild
new file mode 100644
index 000000000000..3e0ec624a814
--- /dev/null
+++ b/dev-util/buildbot-grid-view/buildbot-grid-view-2.10.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+DISTUTILS_USE_SETUPTOOLS="bdepend"
+
+inherit distutils-r1
+
+DESCRIPTION="BuildBot grid view web interface"
+HOMEPAGE="https://buildbot.net/ https://github.com/buildbot/buildbot https://pypi.org/project/buildbot-grid-view/"
+
+MY_PV="${PV/_p/.post}"
+MY_P="${PN}-${MY_PV}"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64"
+
+IUSE=""
+
+RDEPEND=""
+
+DEPEND="${RDEPEND}
+ ~dev-util/buildbot-${PV}[${PYTHON_USEDEP}]
+ ~dev-util/buildbot-www-${PV}[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/${MY_P}"
+
+python_install_all() {
+ distutils-r1_python_install_all
+}
diff --git a/dev-util/buildbot-grid-view/buildbot-grid-view-2.8.2.ebuild b/dev-util/buildbot-grid-view/buildbot-grid-view-2.8.2.ebuild
index d598731012b9..3e0ec624a814 100644
--- a/dev-util/buildbot-grid-view/buildbot-grid-view-2.8.2.ebuild
+++ b/dev-util/buildbot-grid-view/buildbot-grid-view-2.8.2.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
PYTHON_REQ_USE="sqlite"
PYTHON_COMPAT=( python3_{6,7,8} )
-DISTUTILS_USE_SETUPTOOLS="rdepend"
+DISTUTILS_USE_SETUPTOOLS="bdepend"
inherit distutils-r1
diff --git a/dev-util/buildbot-grid-view/buildbot-grid-view-2.8.4.ebuild b/dev-util/buildbot-grid-view/buildbot-grid-view-2.8.4.ebuild
index d598731012b9..3e0ec624a814 100644
--- a/dev-util/buildbot-grid-view/buildbot-grid-view-2.8.4.ebuild
+++ b/dev-util/buildbot-grid-view/buildbot-grid-view-2.8.4.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
PYTHON_REQ_USE="sqlite"
PYTHON_COMPAT=( python3_{6,7,8} )
-DISTUTILS_USE_SETUPTOOLS="rdepend"
+DISTUTILS_USE_SETUPTOOLS="bdepend"
inherit distutils-r1