summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2017-01-04 16:40:01 -0800
committerBrian Dolbec <dolsen@gentoo.org>2017-01-05 16:48:14 -0800
commit0f494b7b6f7ba03c6e20de27140a4b1f70a3e495 (patch)
treecc89bc0802dfd67f588095437ac21d47df4caa0d /dev-util/buildbot-www/buildbot-www-0.9.2.ebuild
parentdev-util/buildbot: Version bump (diff)
downloadgentoo-0f494b7b6f7ba03c6e20de27140a4b1f70a3e495.tar.gz
gentoo-0f494b7b6f7ba03c6e20de27140a4b1f70a3e495.tar.bz2
gentoo-0f494b7b6f7ba03c6e20de27140a4b1f70a3e495.zip
dev-util/buildbot-www: Version bump
Package-Manager: Portage-2.3.3_p7, Repoman-2.3.1
Diffstat (limited to 'dev-util/buildbot-www/buildbot-www-0.9.2.ebuild')
-rw-r--r--dev-util/buildbot-www/buildbot-www-0.9.2.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/dev-util/buildbot-www/buildbot-www-0.9.2.ebuild b/dev-util/buildbot-www/buildbot-www-0.9.2.ebuild
new file mode 100644
index 000000000000..602ba2877233
--- /dev/null
+++ b/dev-util/buildbot-www/buildbot-www-0.9.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python2_7 )
+
+EGIT_REPO_URI="git://github.com/buildbot/buildbot.git"
+
+[[ ${PV} == *9999 ]] && inherit git-r3
+inherit distutils-r1
+
+DESCRIPTION="BuildBot base web interface, use with buildbot-{console-view,waterfall-view}..."
+HOMEPAGE="http://trac.buildbot.net/ https://github.com/buildbot/buildbot http://pypi.python.org/pypi/buildbot"
+
+MY_V="${PV/_p/p}"
+MY_P="${PN}-${MY_V}"
+[[ ${PV} == *9999 ]] || SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+if [[ ${PV} == *9999 ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+fi
+
+IUSE="test"
+
+RDEPEND=""
+
+DEPEND="${RDEPEND}
+ >=dev-python/setuptools-21.2.1[${PYTHON_USEDEP}]
+ ~dev-util/buildbot-${PV}[${PYTHON_USEDEP}]
+ ~dev-util/buildbot-pkg-${PV}[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/${MY_P}"
+#[[ ${PV} == *9999 ]] && S=${S}/www/base
+
+python_test() {
+ distutils_install_for_testing
+
+ esetup.py test || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+}