summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-08-11 20:49:38 +0200
committerMichał Górny <mgorny@gentoo.org>2019-08-11 21:02:25 +0200
commit76726d3efbf58a4a9b9b78c4f70d0369d7550788 (patch)
treecccf6784480b51456454d2df49741e2eb10d721d /dev-util/catfish
parentdev-vcs/git: Bump to version 2.23.0_rc2. Removed old. (diff)
downloadgentoo-76726d3efbf58a4a9b9b78c4f70d0369d7550788.tar.gz
gentoo-76726d3efbf58a4a9b9b78c4f70d0369d7550788.tar.bz2
gentoo-76726d3efbf58a4a9b9b78c4f70d0369d7550788.zip
dev-util/catfish: Bump to 1.4.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-util/catfish')
-rw-r--r--dev-util/catfish/Manifest1
-rw-r--r--dev-util/catfish/catfish-1.4.9.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-util/catfish/Manifest b/dev-util/catfish/Manifest
index 72a62f6ab4cb..eeb6e43f8a14 100644
--- a/dev-util/catfish/Manifest
+++ b/dev-util/catfish/Manifest
@@ -1,2 +1,3 @@
DIST catfish-1.4.7.tar.bz2 162289 BLAKE2B 2f24485f0f059a177a8544632ab583acad1149f96921f8b10027e5788adb2eaf4da0911f3363174feef570c8f75615ec1f943a2d5d2e8622efd4be9892a0fcd2 SHA512 cafa8eaaa40522f50111b3bb9c09a116ebad827532b0cfc88bc643fb2e2d89edee53057fbbed23719f4091ca384d7ea025633e571e160d7dfced008f788a3ffd
DIST catfish-1.4.8.tar.bz2 181027 BLAKE2B c03270832cb2e6bdc39528801d257d37c52f0c6f361c9225002c31a258a18a1c98cf7af640ca15a4f6e32ac4ac802bda84327123a7bf13d47a1410e67988bfab SHA512 46c9e9112116e0f8ee7957c5a71d16ecdde8c16a60a030f3339933a6f9e73d61d360fed52d5904b0fff21448050cc17df5af63f6254476404760fe9166dfad00
+DIST catfish-1.4.9.tar.bz2 182247 BLAKE2B 343a9a83bed73a5f0416fa2ec61869dd3fdb13b8bc45a46dba7d4901c36d97b17e9f32f616baae8cceece566f4e529d34e55f81cb071504b750f4edda048185b SHA512 c62596a09ed481eac5a4544dcfcc71c02177c115b6bf050b1f2421a575ef589c0c1569ef26d6864e472f2331f0561c7f1146c58bc7873af8036d6e7350465c3d
diff --git a/dev-util/catfish/catfish-1.4.9.ebuild b/dev-util/catfish/catfish-1.4.9.ebuild
new file mode 100644
index 000000000000..8833b3e29740
--- /dev/null
+++ b/dev-util/catfish/catfish-1.4.9.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+
+inherit distutils-r1 xdg-utils
+
+DESCRIPTION="A frontend for find, (s)locate, doodle, tracker, beagle, strigi and pinot"
+HOMEPAGE="https://docs.xfce.org/apps/catfish/start"
+SRC_URI="https://archive.xfce.org/src/apps/catfish/${PV%.*}/${P}.tar.bz2"
+
+# yep, GPL-2 only
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="
+ dev-libs/gobject-introspection
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ x11-libs/gdk-pixbuf[introspection]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/pango[introspection]
+ virtual/freedesktop-icon-theme
+"
+DEPEND="
+ dev-python/python-distutils-extra[${PYTHON_USEDEP}]
+ sys-devel/gettext
+"
+
+python_install() {
+ distutils-r1_python_install
+ rm -r "${ED%/}"/usr/share/doc/catfish || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}