summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-08-04 12:49:15 +0200
committerMichał Górny <mgorny@gentoo.org>2019-08-04 12:59:01 +0200
commit81c64fe1607c06efaa43eff2819eb0de4ba40087 (patch)
tree12e83b6cd7dc61d7f80e850a5a488706b78fdcd3 /dev-util/catfish
parentdev-python/gnome-python*-base: Fix python eclass usage (diff)
downloadgentoo-81c64fe1607c06efaa43eff2819eb0de4ba40087.tar.gz
gentoo-81c64fe1607c06efaa43eff2819eb0de4ba40087.tar.bz2
gentoo-81c64fe1607c06efaa43eff2819eb0de4ba40087.zip
dev-util/catfish: Bump to EAPI 7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-util/catfish')
-rw-r--r--dev-util/catfish/catfish-1.4.8-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-util/catfish/catfish-1.4.8-r1.ebuild b/dev-util/catfish/catfish-1.4.8-r1.ebuild
new file mode 100644
index 000000000000..523cc993a833
--- /dev/null
+++ b/dev-util/catfish/catfish-1.4.8-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+
+inherit distutils-r1 xdg-utils
+
+DESCRIPTION="A frontend for find, (s)locate, doodle, tracker, beagle, strigi and pinot"
+HOMEPAGE="https://docs.xfce.org/apps/catfish/start"
+SRC_URI="https://archive.xfce.org/src/apps/catfish/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ x11-libs/gtk+:3[introspection]
+ virtual/freedesktop-icon-theme
+"
+DEPEND="
+ dev-python/python-distutils-extra[${PYTHON_USEDEP}]
+ sys-devel/gettext
+"
+
+python_install() {
+ distutils-r1_python_install
+ rm -r "${ED%/}"/usr/share/doc/catfish || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}