summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-06-04 19:23:30 +0000
committerPatrice Clement <monsieurp@gentoo.org>2016-06-04 19:23:59 +0000
commit5746529f65101744d9dba9141cdffd398361c1ae (patch)
tree469e92f5db628a48a71364ae66072d567dec5162 /dev-util/cgdb/cgdb-0.6.8.ebuild
parentapp-text/mupdf: Version bump (thanks johncarmack@cock.li for the hint, bug 58... (diff)
downloadgentoo-5746529f65101744d9dba9141cdffd398361c1ae.tar.gz
gentoo-5746529f65101744d9dba9141cdffd398361c1ae.tar.bz2
gentoo-5746529f65101744d9dba9141cdffd398361c1ae.zip
dev-util/cgdb: EAPI 6 bump.
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-util/cgdb/cgdb-0.6.8.ebuild')
-rw-r--r--dev-util/cgdb/cgdb-0.6.8.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-util/cgdb/cgdb-0.6.8.ebuild b/dev-util/cgdb/cgdb-0.6.8.ebuild
new file mode 100644
index 000000000000..8f5ebe82f698
--- /dev/null
+++ b/dev-util/cgdb/cgdb-0.6.8.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit multilib-minimal
+
+DESCRIPTION="A curses front-end for GDB, the GNU debugger"
+HOMEPAGE="http://cgdb.github.io/"
+SRC_URI="https://github.com/cgdb/cgdb/archive/v${PV}.zip -> ${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE=""
+
+S="${WORKDIR}/${P}"
+
+DEPEND="
+ sys-libs/ncurses:0=
+ sys-libs/readline:0="
+
+RDEPEND="
+ ${DEPEND}
+ sys-devel/gdb"
+
+src_prepare() {
+ default
+ ./autogen.sh || die
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf
+}
+
+src_compile() {
+ multilib-minimal_src_compile
+}
+
+src_install() {
+ multilib-minimal_src_install
+ dodoc AUTHORS ChangeLog INSTALL NEWS README.md TODO
+}