summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/checkbashisms
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/checkbashisms')
-rw-r--r--dev-util/checkbashisms/Manifest1
-rw-r--r--dev-util/checkbashisms/checkbashisms-2.0.0.2-r2.ebuild37
-rw-r--r--dev-util/checkbashisms/checkbashisms-2.0.0.2.ebuild25
-rw-r--r--dev-util/checkbashisms/files/checkbashisms-2.0.0.2-export.patch16
-rw-r--r--dev-util/checkbashisms/files/checkbashisms-2.0.0.2-kill.patch20
-rw-r--r--dev-util/checkbashisms/files/checkbashisms-2.0.0.2-version.patch13
-rw-r--r--dev-util/checkbashisms/metadata.xml10
7 files changed, 122 insertions, 0 deletions
diff --git a/dev-util/checkbashisms/Manifest b/dev-util/checkbashisms/Manifest
new file mode 100644
index 000000000000..53a626e8bf5c
--- /dev/null
+++ b/dev-util/checkbashisms/Manifest
@@ -0,0 +1 @@
+DIST checkbashisms-2.0.0.2 21258 SHA256 4da61b7f08b55609e80c648d215f0201aa9b5f1df53aab6252129537a7f7a0ee SHA512 cd9376f4c34773aba79f81b8bb129d912844102e91e363480b9983092efd36c4827e0447242aecfcdb3cfd4cc50e19e105cc645368e8c9735f49c8e381964dd4 WHIRLPOOL 94adf80badc7b484119df3723968965057ddfc365b59e52a7444e4476396f3c82d72aa43f049a397f5e762948dad0f4e3b679a547682401a469c7b8b587a9db5
diff --git a/dev-util/checkbashisms/checkbashisms-2.0.0.2-r2.ebuild b/dev-util/checkbashisms/checkbashisms-2.0.0.2-r2.ebuild
new file mode 100644
index 000000000000..c8b092327af3
--- /dev/null
+++ b/dev-util/checkbashisms/checkbashisms-2.0.0.2-r2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Perl script to check for commonly used bash features not defined by POSIX"
+# "checkbaskisms" is not a typo, it's the actual upstream SF project name.
+HOMEPAGE="http://sourceforge.net/projects/checkbaskisms/"
+SRC_URI="mirror://sourceforge/checkbaskisms/${PV}/${PN} -> ${P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/perl
+ virtual/perl-Getopt-Long
+ !<dev-util/rpmdevtools-8.3-r1"
+
+S=${WORKDIR}
+
+src_unpack() {
+ cp "${DISTDIR}"/${P} ${PN}
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-export.patch #458392
+ epatch "${FILESDIR}"/${P}-kill.patch #458392
+ epatch "${FILESDIR}"/${P}-version.patch
+}
+
+src_install() {
+ dobin ${PN}
+}
diff --git a/dev-util/checkbashisms/checkbashisms-2.0.0.2.ebuild b/dev-util/checkbashisms/checkbashisms-2.0.0.2.ebuild
new file mode 100644
index 000000000000..a578750fa0c9
--- /dev/null
+++ b/dev-util/checkbashisms/checkbashisms-2.0.0.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+DESCRIPTION="Perl script to check for commonly used bash features not defined by POSIX"
+# "checkbaskisms" is not a typo, it's the actual upstream SF project name.
+HOMEPAGE="http://sourceforge.net/projects/checkbaskisms/"
+SRC_URI="mirror://sourceforge/checkbaskisms/${PV}/${PN} -> ${P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/perl
+ virtual/perl-Getopt-Long
+ !<dev-util/rpmdevtools-8.3-r1"
+
+S=${WORKDIR}
+
+src_install() {
+ newbin "${DISTDIR}"/${P} ${PN}
+}
diff --git a/dev-util/checkbashisms/files/checkbashisms-2.0.0.2-export.patch b/dev-util/checkbashisms/files/checkbashisms-2.0.0.2-export.patch
new file mode 100644
index 000000000000..2ce8a183c8f9
--- /dev/null
+++ b/dev-util/checkbashisms/files/checkbashisms-2.0.0.2-export.patch
@@ -0,0 +1,16 @@
+`export foor=bar` is valid in POSIX
+
+https://sourceforge.net/p/checkbaskisms/checkbashisms/9/
+http://pubs.opengroup.org/onlinepubs/9699919799/utilities/V3_chap02.html#export
+https://bugs.gentoo.org/458392
+
+--- a/checkbashisms
++++ b/checkbashisms
+@@ -512,7 +512,6 @@
+ $LEADIN . qr'disown\s' => q<disown>,
+ $LEADIN . qr'enable\s' => q<enable>,
+ $LEADIN . qr'export\s+-[^p]' => q<export only takes -p as an option>,
+- $LEADIN . qr'export\s+.+=' => q<export foo=bar should be foo=bar; export foo>,
+ $LEADIN . qr'mapfile\s' => q<mapfile>,
+ $LEADIN . qr'readarray\s' => q<readarray>,
+ $LEADIN . qr'readonly\s+-[af]' => q<readonly -[af]>,
diff --git a/dev-util/checkbashisms/files/checkbashisms-2.0.0.2-kill.patch b/dev-util/checkbashisms/files/checkbashisms-2.0.0.2-kill.patch
new file mode 100644
index 000000000000..7ddb94a5ae1a
--- /dev/null
+++ b/dev-util/checkbashisms/files/checkbashisms-2.0.0.2-kill.patch
@@ -0,0 +1,20 @@
+`kill -HUP` is valid in POSIX
+
+we could extend the check to look for valid signal names, but that seems like
+it's not worth the effort (when the # of signals is >30). if the code uses a
+wrong signal name, then it'll hit a runtime error regardless of shell.
+
+https://sourceforge.net/p/checkbaskisms/checkbashisms/5/
+http://pubs.opengroup.org/onlinepubs/9699919799/utilities/kill.html
+https://bugs.gentoo.org/458392
+
+--- a/checkbashisms
++++ b/checkbashisms
+@@ -496,7 +496,6 @@
+ qr'\&>' => q<should be \>word 2\>&1>,
+ qr'(<\&|>\&)\s*((-|\d+)[^\s;|)}`&\\\\]|[^-\d\s]+(?<!\$)(?!\d))' =>
+ q<should be \>word 2\>&1>,
+- $LEADIN . qr'kill\s+-[^sl]\w*' => q<kill -[0-9] or -[A-Z]>,
+ $LEADIN . qr'trap\s+["\']?.*["\']?\s+.*[1-9]' => q<trap with signal numbers>,
+ $LEADIN . qr'trap\s+["\']?.*["\']?\s+.*ERR' => q<trap ERR>,
+ qr'\[\[(?!:)' => q<alternative test command ([[ foo ]] should be [ foo ])>,
diff --git a/dev-util/checkbashisms/files/checkbashisms-2.0.0.2-version.patch b/dev-util/checkbashisms/files/checkbashisms-2.0.0.2-version.patch
new file mode 100644
index 000000000000..14dc79e06b96
--- /dev/null
+++ b/dev-util/checkbashisms/files/checkbashisms-2.0.0.2-version.patch
@@ -0,0 +1,13 @@
+https://sourceforge.net/p/checkbaskisms/checkbashisms/1/
+
+--- a/checkbashisms
++++ b/checkbashisms
+@@ -30,7 +30,7 @@
+ EOF
+
+ my $version = <<"EOF";
+-This is $progname version 2.0.0.1
++This is $progname version 2.0.0.2
+ (C) Copyright 1998-2003 Richard Braakman, Josip Rodin and Julian Gilbey
+ Additional programming by Mark Hobley
+ EOF
diff --git a/dev-util/checkbashisms/metadata.xml b/dev-util/checkbashisms/metadata.xml
new file mode 100644
index 000000000000..72d3cb691534
--- /dev/null
+++ b/dev-util/checkbashisms/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>robbat2@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">checkbaskisms</remote-id>
+ </upstream>
+</pkgmetadata>