summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-11-10 19:51:36 -0500
committerMike Frysinger <vapier@gentoo.org>2015-11-10 19:52:31 -0500
commit5bd43e9ac265acdd453bf060cd2ee40cb946674d (patch)
treee3114bd2a3a2b7dc1eb7d9c96777a7e73d9daa32 /dev-util/checkbashisms
parentdev-util/checkbashisms: add base-system herd (diff)
downloadgentoo-5bd43e9ac265acdd453bf060cd2ee40cb946674d.tar.gz
gentoo-5bd43e9ac265acdd453bf060cd2ee40cb946674d.tar.bz2
gentoo-5bd43e9ac265acdd453bf060cd2ee40cb946674d.zip
dev-util/checkbashisms: switch to Debian as upsream
They're the original upstream and they've made more updates since (like flagging bash-4 features). Switch over to it!
Diffstat (limited to 'dev-util/checkbashisms')
-rw-r--r--dev-util/checkbashisms/Manifest1
-rw-r--r--dev-util/checkbashisms/checkbashisms-2.15.9.ebuild37
-rw-r--r--dev-util/checkbashisms/files/checkbashisms-2.15.9-command-vV.patch30
-rw-r--r--dev-util/checkbashisms/files/checkbashisms-2.15.9-printf-b.patch30
4 files changed, 98 insertions, 0 deletions
diff --git a/dev-util/checkbashisms/Manifest b/dev-util/checkbashisms/Manifest
index 53a626e8bf5c..7e90ef92498a 100644
--- a/dev-util/checkbashisms/Manifest
+++ b/dev-util/checkbashisms/Manifest
@@ -1 +1,2 @@
DIST checkbashisms-2.0.0.2 21258 SHA256 4da61b7f08b55609e80c648d215f0201aa9b5f1df53aab6252129537a7f7a0ee SHA512 cd9376f4c34773aba79f81b8bb129d912844102e91e363480b9983092efd36c4827e0447242aecfcdb3cfd4cc50e19e105cc645368e8c9735f49c8e381964dd4 WHIRLPOOL 94adf80badc7b484119df3723968965057ddfc365b59e52a7444e4476396f3c82d72aa43f049a397f5e762948dad0f4e3b679a547682401a469c7b8b587a9db5
+DIST devscripts_2.15.9.tar.xz 627784 SHA256 409c7527ea91dda844688707b365485a9f5cc2e733e93f996fb597c64c78589d SHA512 24ed788730a1df4250706261fe89b836dac63b955060943797f29c02b3a3833b346b4524dbe1fd0a9a0999382577cd4e6f85b0710a91f75755a770fa03c62538 WHIRLPOOL 6feab0f3c6db74fe6b54f02033a0f4d1b33f0774cfeb0cb28f7fa8ce4e9d4867e4d33fa22b1cf34f0e8e4dce7eeaa01809521d5a2a31d84dc8cd7bf85dc8b702
diff --git a/dev-util/checkbashisms/checkbashisms-2.15.9.ebuild b/dev-util/checkbashisms/checkbashisms-2.15.9.ebuild
new file mode 100644
index 000000000000..4e7240076b36
--- /dev/null
+++ b/dev-util/checkbashisms/checkbashisms-2.15.9.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+MY_PN="devscripts"
+MY_P="${MY_PN}-${PV}"
+
+inherit eutils
+
+DESCRIPTION="Perl script to check for commonly used bash features not defined by POSIX"
+HOMEPAGE="https://packages.debian.org/devscripts https://anonscm.debian.org/cgit/collab-maint/devscripts.git"
+SRC_URI="mirror://debian/pool/main/d/${MY_PN}/${MY_P/-/_}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/perl
+ virtual/perl-Getopt-Long
+ !<dev-util/rpmdevtools-8.3-r1"
+
+S="${WORKDIR}/${MY_P}/scripts"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-printf-b.patch
+ epatch "${FILESDIR}"/${P}-command-vV.patch
+}
+
+src_compile() { :; }
+
+src_install() {
+ newbin ${PN}.pl ${PN}
+ doman ${PN}.1
+}
diff --git a/dev-util/checkbashisms/files/checkbashisms-2.15.9-command-vV.patch b/dev-util/checkbashisms/files/checkbashisms-2.15.9-command-vV.patch
new file mode 100644
index 000000000000..662ccdfd2bea
--- /dev/null
+++ b/dev-util/checkbashisms/files/checkbashisms-2.15.9-command-vV.patch
@@ -0,0 +1,30 @@
+https://bugs.debian.org/733511
+
+From 50dac50bdfa7ab482bf2277cc1a620a62629c80c Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Tue, 10 Nov 2015 19:39:19 -0500
+Subject: [PATCH] checkbashisms: allow `command` to use -v/-V
+
+POSIX permits the -v/-V options:
+http://pubs.opengroup.org/onlinepubs/9699919799/utilities/command.html
+command [-p][-v|-V] command_name
+---
+ scripts/checkbashisms.pl | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/scripts/checkbashisms.pl b/scripts/checkbashisms.pl
+index 045328c..fe64a6b 100755
+--- a/scripts/checkbashisms.pl
++++ b/scripts/checkbashisms.pl
+@@ -644,7 +644,7 @@ sub init_hashes {
+ qr';;?&' => q<;;& and ;& special case operators>,
+ $LEADIN . qr'jobs\s' => q<jobs>,
+ # $LEADIN . qr'jobs\s+-[^lp]\s' => q<'jobs' with option other than -l or -p>,
+- $LEADIN . qr'command\s+-[^p]\s' => q<'command' with option other than -p>,
++ $LEADIN . qr'command\s+-[^pvV]\s' => q<'command' with option other than -p/-v/-V>,
+ $LEADIN . qr'setvar\s' => q<setvar 'foo' 'bar' should be eval 'foo="'"$bar"'"'>,
+ $LEADIN . qr'trap\s+["\']?.*["\']?\s+.*(?:ERR|DEBUG|RETURN)' => q<trap with ERR|DEBUG|RETURN>,
+ $LEADIN . qr'(?:exit|return)\s+-\d' => q<exit|return with negative status code>,
+--
+2.6.2
+
diff --git a/dev-util/checkbashisms/files/checkbashisms-2.15.9-printf-b.patch b/dev-util/checkbashisms/files/checkbashisms-2.15.9-printf-b.patch
new file mode 100644
index 000000000000..6a53e02ad6d8
--- /dev/null
+++ b/dev-util/checkbashisms/files/checkbashisms-2.15.9-printf-b.patch
@@ -0,0 +1,30 @@
+From 18cd946c5d43d010c3821a4620cf97dbc0406ed8 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Tue, 10 Nov 2015 19:40:24 -0500
+Subject: [PATCH] checkbashisms: allow `printf` to use %b
+
+POSIX permits the b conversion specifier character:
+http://pubs.opengroup.org/onlinepubs/9699919799/utilities/printf.html
+
+EXTENDED DESCRIPTION
+7. An additional conversion specifier character, b, shall be supported as follows.
+---
+ scripts/checkbashisms.pl | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/scripts/checkbashisms.pl b/scripts/checkbashisms.pl
+index fe64a6b..0229752 100755
+--- a/scripts/checkbashisms.pl
++++ b/scripts/checkbashisms.pl
+@@ -689,7 +689,7 @@ sub init_hashes {
+ qr'\$\(\([\s\w$*/+-]*\w\-\-.*?\)\)' => q<'$((n--))' should be '$n; $((n=n-1))'>,
+ qr'\$\(\([\s\w$*/+-]*\-\-\w.*?\)\)' => q<'$((--n))' should be '$((n=n-1))'>,
+ qr'\$\(\([\s\w$*/+-]*\*\*.*?\)\)' => q<exponentiation is not POSIX>,
+- $LEADIN . qr'printf\s["\'][^"\']*?%[qb].+?["\']' => q<printf %q|%b>,
++ $LEADIN . qr'printf\s["\'][^"\']*?%q.+?["\']' => q<printf %q>,
+ );
+
+ %singlequote_bashisms = (
+--
+2.6.2
+