summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-10 23:24:37 +0000
committerSam James <sam@gentoo.org>2021-12-11 01:16:16 +0000
commit15d1e9c51bee91279e79fad16777338e6aff1b8b (patch)
treef37a4ed7632f89ac7829e8dee6166d3e67854238 /dev-util/clazy
parentdev-ml/reason: upstream moved repository - facebook -> reasonml (diff)
downloadgentoo-15d1e9c51bee91279e79fad16777338e6aff1b8b.tar.gz
gentoo-15d1e9c51bee91279e79fad16777338e6aff1b8b.tar.bz2
gentoo-15d1e9c51bee91279e79fad16777338e6aff1b8b.zip
dev-util/clazy: use llvm.eclass to declare compatibility
We need to use llvm.eclass to ensure we don't use too new of a version of LLVM and Clang. Closes: https://bugs.gentoo.org/823726 Bug: https://bugs.gentoo.org/823726 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/clazy')
-rw-r--r--dev-util/clazy/clazy-1.10-r1.ebuild (renamed from dev-util/clazy/clazy-1.10.ebuild)12
1 files changed, 7 insertions, 5 deletions
diff --git a/dev-util/clazy/clazy-1.10.ebuild b/dev-util/clazy/clazy-1.10-r1.ebuild
index 160c50c5c641..d8be54c089d8 100644
--- a/dev-util/clazy/clazy-1.10.ebuild
+++ b/dev-util/clazy/clazy-1.10-r1.ebuild
@@ -3,7 +3,8 @@
EAPI=7
-inherit cmake
+LLVM_MAX_SLOT=12
+inherit cmake llvm
DESCRIPTION="Compiler plugin which allows clang to understand Qt semantics"
HOMEPAGE="https://apps.kde.org/clazy"
@@ -14,12 +15,13 @@ SLOT="0"
KEYWORDS="~amd64 arm64 ~x86"
IUSE=""
-RDEPEND="
- >=sys-devel/clang-8.0:=
- >=sys-devel/llvm-8.0:=
-"
+RDEPEND=">=sys-devel/clang-$((${LLVM_MAX_SLOT} + 1)):="
DEPEND="${RDEPEND}"
+llvm_check_deps() {
+ has_version "sys-devel/clang:${LLVM_SLOT}" && has_version "sys-devel/llvm:${LLVM_SLOT}"
+}
+
src_prepare() {
cmake_src_prepare