summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-04-22 19:06:54 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-04-22 19:07:35 +0200
commit51456fcc31f95f5cced748ae8031c21c73c7cde0 (patch)
tree80f38816c209545a1c0d24caff688fd0f79204dd /dev-util/clazy
parentkde-misc/krusader: drop 2.8.0-r1 (diff)
downloadgentoo-51456fcc31f95f5cced748ae8031c21c73c7cde0.tar.gz
gentoo-51456fcc31f95f5cced748ae8031c21c73c7cde0.tar.bz2
gentoo-51456fcc31f95f5cced748ae8031c21c73c7cde0.zip
dev-util/clazy: drop 1.11-r3
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-util/clazy')
-rw-r--r--dev-util/clazy/clazy-1.11-r3.ebuild56
1 files changed, 0 insertions, 56 deletions
diff --git a/dev-util/clazy/clazy-1.11-r3.ebuild b/dev-util/clazy/clazy-1.11-r3.ebuild
deleted file mode 100644
index f496c456100f..000000000000
--- a/dev-util/clazy/clazy-1.11-r3.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-LLVM_MAX_SLOT=16
-PYTHON_COMPAT=( python3_{10..12} )
-inherit cmake llvm python-any-r1
-
-DESCRIPTION="Compiler plugin which allows clang to understand Qt semantics"
-HOMEPAGE="https://apps.kde.org/clazy"
-SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.xz"
-
-LICENSE="LGPL-2+"
-SLOT="0"
-KEYWORDS="amd64 arm64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="<sys-devel/clang-$((${LLVM_MAX_SLOT} + 1)):="
-DEPEND="${RDEPEND}"
-BDEPEND="test? ( ${PYTHON_DEPS} )"
-
-PATCHES=(
- "${FILESDIR}"/${P}-fix-regex-detect.patch
- "${FILESDIR}"/${P}-fix-llvm-{15,16}.patch
-)
-
-llvm_check_deps() {
- has_version "sys-devel/clang:${LLVM_SLOT}" && has_version "sys-devel/llvm:${LLVM_SLOT}"
-}
-
-pkg_setup() {
- use test && python-any-r1_pkg_setup
-
- llvm_pkg_setup
-}
-
-src_prepare() {
- cmake_src_prepare
-
- sed -e '/install(FILES README.md COPYING-LGPL2.txt checks.json DESTINATION/d' \
- -i CMakeLists.txt || die
-}
-
-src_configure() {
- export LLVM_ROOT="$(get_llvm_prefix -d ${LLVM_MAX_SLOT})"
-
- cmake_src_configure
-}
-
-src_test() {
- # Run tests against built copy, not installed
- # bug #811723
- PATH="${BUILD_DIR}/bin:${PATH}" LD_LIBRARY_PATH="${BUILD_DIR}/lib" cmake_src_test
-}