summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2017-10-25 15:01:05 -0400
committerCraig Andrews <candrews@gentoo.org>2017-10-25 16:08:50 -0400
commit59ab7c36ff6cf4a97bef1e5996b05a3682648d56 (patch)
tree9906c065d1c72f99d5093bc8f84191940f211761 /dev-util/clinfo/clinfo-9999.ebuild
parentapp-editors/vim: do not install ex and view manual pages. (diff)
downloadgentoo-59ab7c36ff6cf4a97bef1e5996b05a3682648d56.tar.gz
gentoo-59ab7c36ff6cf4a97bef1e5996b05a3682648d56.tar.bz2
gentoo-59ab7c36ff6cf4a97bef1e5996b05a3682648d56.zip
dev-util/clinfo: A tool to display info about the system's OpenCL capabilities
Package-Manager: Portage-2.3.12, Repoman-2.3.3 Closes: https://github.com/gentoo/gentoo/pull/6054
Diffstat (limited to 'dev-util/clinfo/clinfo-9999.ebuild')
-rw-r--r--dev-util/clinfo/clinfo-9999.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-util/clinfo/clinfo-9999.ebuild b/dev-util/clinfo/clinfo-9999.ebuild
new file mode 100644
index 000000000000..a3dd2fa351bc
--- /dev/null
+++ b/dev-util/clinfo/clinfo-9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/Oblomov/clinfo.git"
+ inherit git-r3
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/Oblomov/clinfo/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="A tool to display info about the system's OpenCL capabilities"
+HOMEPAGE="https://github.com/Oblomov/clinfo"
+LICENSE="CC0-1.0"
+SLOT="0"
+
+DEPEND="virtual/opencl"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ emake MANDIR="${ED}"/usr/share/man PREFIX="${ED}"/usr install
+}