summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Strahl <c.a.strahl@gmail.com>2018-03-30 19:58:09 +0200
committerMichał Górny <mgorny@gentoo.org>2018-03-30 23:27:04 +0200
commitf2ff6f8f979d27cd7e5ea67621c981d5c7389c01 (patch)
treea55b8310458cb22ec1b0cee746edb396f819dd2f /dev-util/clion
parentapp-text/calibre: use HTTPS (diff)
downloadgentoo-f2ff6f8f979d27cd7e5ea67621c981d5c7389c01.tar.gz
gentoo-f2ff6f8f979d27cd7e5ea67621c981d5c7389c01.tar.bz2
gentoo-f2ff6f8f979d27cd7e5ea67621c981d5c7389c01.zip
dev-util/clion: version bump to 2018.1
Package-Manager: 2.3.24-r1, Repoman-2.3.6
Diffstat (limited to 'dev-util/clion')
-rw-r--r--dev-util/clion/Manifest1
-rw-r--r--dev-util/clion/clion-2018.1.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-util/clion/Manifest b/dev-util/clion/Manifest
index fac8d8e48c21..6a2fd5107c95 100644
--- a/dev-util/clion/Manifest
+++ b/dev-util/clion/Manifest
@@ -1,3 +1,4 @@
DIST clion-143.1186.tar.gz 220702330 BLAKE2B 05799e66aff500adbb66f553f6fc00c58d1ea5e352b0f3d2e50897fbaa48c0977438027ec6282133502c0ce29d2392c49b2c000eae35407d8c3947b7e2d5ebe7 SHA512 d4ea1bad5f3da3bab569380114011798c29e633009867c8020363c9af72326ebaa3232dff9c931a67dd0a0195bf4903647e250963c7aeebe9ad83340c988cbad
DIST clion-2016.2.1.tar.gz 287103613 BLAKE2B a3b31d5a5de5a9640cc7298ee6431030ed3e5954455a34845ee525b0edd73a265d0ac38df50094564f68f9f7c17883571c61c2e5dadcdfe504f7320492d7380c SHA512 a4734c1b5d544cb7f6bd4752f5853d3c44e123e8ad8584b76098ef51a00261350d49bdd628d08c171f7c04b77862e8f28b5d8f16813c282542f83a16100c7415
DIST clion-2017.3.4.tar.gz 331195446 BLAKE2B 5d868de5b1d97a80dd2d63977dfda8d3ab56840c95e4cdba5b8e55cf626dbd68e1015fd8dae664dbdf8161853a96a492ce43a78e0e6bd13138144d28e1146f78 SHA512 044e713e2ab3724b891b48a1d75936dce1580be0fded174101f768f6976f76f2557768128fd596cc8855c15f27dbd9a1e9d4299b947ad00ca458c537d81fd0b8
+DIST clion-2018.1.tar.gz 333789580 BLAKE2B 026ebe63049f3b80c2924079092707379d07fa838b532b7e191ee5fbc66dfa50dbc97ad78cbafd6794f99bc29ce66f4d54882d0bbc1339e08a2f35bd5f195bc5 SHA512 ac95b5d346f077ab26882ff4c0f71420c6fcd0a929aa33c60b427d0a10839bec3a2e5363d8cd18d9e2d6988da17dd0deacd9fd3b3c5f0619c9925acf263f56bd
diff --git a/dev-util/clion/clion-2018.1.ebuild b/dev-util/clion/clion-2018.1.ebuild
new file mode 100644
index 000000000000..376319ea602b
--- /dev/null
+++ b/dev-util/clion/clion-2018.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit desktop eutils
+
+DESCRIPTION="A complete toolset for C and C++ development"
+HOMEPAGE="http://www.jetbrains.com/clion"
+SRC_URI="http://download.jetbrains.com/cpp/CLion-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="IDEA
+ || ( IDEA_Academic IDEA_Classroom IDEA_OpenSource IDEA_Personal )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# RDEPENDS may cause false positives in repoman.
+# clion requires cmake and gdb at runtime to build and debug C/C++ projects
+RDEPEND="
+ sys-devel/gdb
+ dev-util/cmake"
+
+QA_PREBUILT="opt/${P}/*"
+
+src_prepare() {
+ default
+
+ local remove_me=(
+ bin/gdb/bin
+ bin/gdb/lib
+ bin/gdb/share
+ bin/cmake
+ license/CMake*
+ plugins/tfsIntegration/lib/native/hpux
+ plugins/tfsIntegration/lib/native/solaris
+ )
+
+ use amd64 || remove_me+=( plugins/tfsIntegration/lib/native/linux/x86_64 )
+ use arm || remove_me+=( bin/fsnotifier-arm plugins/tfsIntegration/lib/native/linux/arm )
+ use ppc || remove_me+=( plugins/tfsIntegration/lib/native/linux/ppc )
+ use x86 || remove_me+=( plugins/tfsIntegration/lib/native/linux/x86 )
+
+ rm -rv "${remove_me[@]}" || die
+}
+
+src_install() {
+ local dir="/opt/${P}"
+
+ insinto "${dir}"
+ doins -r *
+ fperms 755 "${dir}"/bin/{clion.sh,fsnotifier{,64}}
+
+ make_wrapper "${PN}" "${dir}/bin/${PN}.sh"
+ newicon "bin/${PN}.svg" "${PN}.svg"
+ make_desktop_entry "${PN}" "clion" "${PN}" "Development;IDE;"
+
+ # recommended by: https://confluence.jetbrains.com/display/IDEADEV/Inotify+Watches+Limit
+ dodir /usr/lib/sysctl.d/
+ echo "fs.inotify.max_user_watches = 524288" > "${D}/usr/lib/sysctl.d/30-clion-inotify-watches.conf" || die
+}