summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen L Arnold <nerdboy@gentoo.org>2015-11-09 13:01:04 -0800
committerStephen L Arnold <nerdboy@gentoo.org>2015-11-09 13:05:50 -0800
commitf45619d86ce8a00a2bb6e8ec3ac91206456adb1e (patch)
tree248822be56a3ec7076287b1cc1a7a97645739761 /dev-util/cloc/cloc-1.64.ebuild
parentdev-libs/libxml2: re-add missing call to eprefixify (diff)
downloadgentoo-f45619d86ce8a00a2bb6e8ec3ac91206456adb1e.tar.gz
gentoo-f45619d86ce8a00a2bb6e8ec3ac91206456adb1e.tar.bz2
gentoo-f45619d86ce8a00a2bb6e8ec3ac91206456adb1e.zip
dev-util/cloc: add patch for perl 5.22 array error
Pretty much just what it says; this will keep cropping up in more packages. Package-Manager: portage-2.2.24
Diffstat (limited to 'dev-util/cloc/cloc-1.64.ebuild')
-rw-r--r--dev-util/cloc/cloc-1.64.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/dev-util/cloc/cloc-1.64.ebuild b/dev-util/cloc/cloc-1.64.ebuild
index 066490bc9b57..6d8b4d959673 100644
--- a/dev-util/cloc/cloc-1.64.ebuild
+++ b/dev-util/cloc/cloc-1.64.ebuild
@@ -4,6 +4,8 @@
EAPI=5
+inherit eutils
+
DESCRIPTION="Count Lines of Code"
HOMEPAGE="http://cloc.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.pl mirror://sourceforge/${PN}/${PN}.1.pod"
@@ -27,9 +29,17 @@ src_unpack() { :; }
src_prepare() {
pod2man "${DISTDIR}"/${PN}.1.pod > ${PN}.1 || die
+
+ # hacky, but otherwise we only get a symlink in distdir...
+ cp -L "${DISTDIR}"/${P}.pl "${WORKDIR}"/
+
+ # fix stuoid perl array error... again...
+ if has_version '>=dev-lang/perl-5.22.0' ; then
+ epatch "${FILESDIR}"/${PN}-fix_stupid_perl_array_error_again.patch
+ fi
}
src_install() {
doman ${PN}.1
- newbin "${DISTDIR}"/${P}.pl ${PN}
+ newbin "${WORKDIR}"/${P}.pl ${PN}
}