summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-03-09 21:18:26 +0100
committerLars Wendler <polynomial-c@gentoo.org>2016-03-09 21:20:25 +0100
commitff0d55b9c06d21de48664968b368490471a5d428 (patch)
tree3615eb86293f497bbd803d9180401c629540039d /dev-util/cmake
parentsys-fs/lvm2: bump per bug #572352. (diff)
downloadgentoo-ff0d55b9c06d21de48664968b368490471a5d428.tar.gz
gentoo-ff0d55b9c06d21de48664968b368490471a5d428.tar.bz2
gentoo-ff0d55b9c06d21de48664968b368490471a5d428.zip
dev-util/cmake: Bump to version 3.5.0
Package-Manager: portage-2.2.27 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'dev-util/cmake')
-rw-r--r--dev-util/cmake/Manifest1
-rw-r--r--dev-util/cmake/cmake-3.5.0.ebuild198
-rw-r--r--dev-util/cmake/files/cmake-2.8.12.1-FindImageMagick.patch4
-rw-r--r--dev-util/cmake/files/cmake-3.0.0-FindBLAS.patch4
-rw-r--r--dev-util/cmake/files/cmake-3.0.2-FindLAPACK.patch4
-rw-r--r--dev-util/cmake/files/cmake-3.1.0-FindPythonInterp.patch4
-rw-r--r--dev-util/cmake/files/cmake-3.1.0-darwin-isysroot.patch4
-rw-r--r--dev-util/cmake/files/cmake-3.3.2-FindQt4.patch4
8 files changed, 211 insertions, 12 deletions
diff --git a/dev-util/cmake/Manifest b/dev-util/cmake/Manifest
index 2e48950c0acd..d079502e380b 100644
--- a/dev-util/cmake/Manifest
+++ b/dev-util/cmake/Manifest
@@ -5,3 +5,4 @@ DIST cmake-3.3.1.tar.gz 6577869 SHA256 cd65022c6a0707f1c7112f99e9c981677fdd5518f
DIST cmake-3.3.2.tar.gz 6578184 SHA256 e75a178d6ebf182b048ebfe6e0657c49f0dc109779170bad7ffcb17463f2fc22 SHA512 01bc0e6ca52a6836ef57360fb38dd92a4575bfa37bfe9625645db77fefd0c170383cfb07b61c6283bde96738ce1a5e18cb7569e7e0b7c98d4b99e86305c50180 WHIRLPOOL 7951dc18d695ca4554b287f91becd8ecb05324e10f9e2c9e34427d26db0d664ee7ab8a226eabed87d93087e41635059f96b1aaea503480f46a555cf3baae3ce7
DIST cmake-3.4.2.tar.gz 6722152 SHA256 da7cc34e1ce1d82e67a32ab081c02c2845534cd8bf2e09d88077a1b282e97392 SHA512 a06a3f1d2d2dcbc3c1d432bd7416632393b4f5219b89dc0ba000acefe6f0d713c35878344884ea9d9e595a6387b362c97a2432acd92c385cbddb4e7b916723bb WHIRLPOOL 42f66e4273367e821b4b06b630f84919a68bc0d4a2be2085a0f24fb79e1b20fb208abe78a1806570401ba6ca24ad1077b1be27c3e7a774491c8beb63f7d501af
DIST cmake-3.4.3.tar.gz 6722311 SHA256 b73f8c1029611df7ed81796bf5ca8ba0ef41c6761132340c73ffe42704f980fa SHA512 a326c39cfe9f5408b4586ddd291cabfa400a2442947fb46d94dd6c44db3087c48c84a9a22ca5ed38707467448150383935ed59c669fbbfb20a968d4031eaaa11 WHIRLPOOL fdb3b47a242523919a56a63bf8e778e875f5721c997cdc1a6098f24eec57dadecc44d13b35d74ef1276aebf6f5299c89d4c91ce03c282d081b03ebba29c1ddad
+DIST cmake-3.5.0.tar.gz 6861686 SHA256 92c83ad8a4fd6224cf6319a60b399854f55b38ebe9d297c942408b792b1a9efa SHA512 4fef712560f1975f8d19e897c7b1903811f7bad9314602961b5b32ac58f367bf1308f96cc5edaceb99ac9084b1e0517e4ecb4b5996d2ad53b6aec305ae879b09 WHIRLPOOL bd7f8adfd91cfa0a240e1d3935163d3c978ebdb83f54a3c6c7bcab3b2ad2ad7ac175c247a896511b0736de13f93e19dc89ef68766498ace4163177a4d0aab442
diff --git a/dev-util/cmake/cmake-3.5.0.ebuild b/dev-util/cmake/cmake-3.5.0.ebuild
new file mode 100644
index 000000000000..f3eb642dc142
--- /dev/null
+++ b/dev-util/cmake/cmake-3.5.0.ebuild
@@ -0,0 +1,198 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+CMAKE_REMOVE_MODULES="no"
+inherit bash-completion-r1 elisp-common toolchain-funcs eutils versionator cmake-utils virtualx
+
+MY_P="${P/_/-}"
+
+DESCRIPTION="Cross platform Make"
+HOMEPAGE="http://www.cmake.org/"
+SRC_URI="http://www.cmake.org/files/v$(get_version_component_range 1-2)/${MY_P}.tar.gz"
+
+LICENSE="CMake"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc emacs system-jsoncpp ncurses qt4 qt5"
+
+RDEPEND="
+ >=app-arch/libarchive-3.0.0:=
+ >=dev-libs/expat-2.0.1
+ >=net-misc/curl-7.20.0-r1[ssl]
+ sys-libs/zlib
+ virtual/pkgconfig
+ emacs? ( virtual/emacs )
+ ncurses? ( sys-libs/ncurses:0= )
+ qt4? (
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ )
+ system-jsoncpp? ( >=dev-libs/jsoncpp-0.6.0_rc2:0= )
+"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+SITEFILE="50${PN}-gentoo.el"
+
+CMAKE_BINARY="${S}/Bootstrap.cmk/cmake"
+
+PATCHES=(
+ # prefix
+ "${FILESDIR}"/${PN}-3.4.0_rc1-darwin-bundle.patch
+ "${FILESDIR}"/${PN}-3.0.0-prefix-dirs.patch
+ "${FILESDIR}"/${PN}-3.1.0-darwin-isysroot.patch
+
+ # handle gentoo packaging in find modules
+ "${FILESDIR}"/${PN}-2.8.12.1-FindImageMagick.patch
+ "${FILESDIR}"/${PN}-3.0.0-FindBLAS.patch
+ "${FILESDIR}"/${PN}-3.0.0-FindBoost-python.patch
+ "${FILESDIR}"/${PN}-3.0.2-FindLAPACK.patch
+ "${FILESDIR}"/${PN}-3.3.2-FindQt4.patch
+
+ # respect python eclasses
+ "${FILESDIR}"/${PN}-2.8.10.2-FindPythonLibs.patch
+ "${FILESDIR}"/${PN}-3.1.0-FindPythonInterp.patch
+
+ # upstream fixes (can usually be removed with a version bump)
+)
+
+cmake_src_bootstrap() {
+ # Cleanup args to extract only JOBS.
+ # Because bootstrap does not know anything else.
+ echo ${MAKEOPTS} | egrep -o '(\-j|\-\-jobs)(=?|[[:space:]]*)[[:digit:]]+' > /dev/null
+ if [ $? -eq 0 ]; then
+ par_arg=$(echo ${MAKEOPTS} | egrep -o '(\-j|\-\-jobs)(=?|[[:space:]]*)[[:digit:]]+' | tail -n1 | egrep -o '[[:digit:]]+')
+ par_arg="--parallel=${par_arg}"
+ else
+ par_arg="--parallel=1"
+ fi
+
+ # execinfo.h on Solaris isn't quite what it is on Darwin
+ if [[ ${CHOST} == *-solaris* ]] ; then
+ sed -i -e 's/execinfo\.h/blablabla.h/' Source/kwsys/CMakeLists.txt || die
+ fi
+
+ tc-export CC CXX LD
+
+ # bootstrap script isn't exactly /bin/sh compatible
+ ${CONFIG_SHELL:-sh} ./bootstrap \
+ --prefix="${T}/cmakestrap/" \
+ ${par_arg} \
+ || die "Bootstrap failed"
+}
+
+cmake_src_test() {
+ # fix OutDir and SelectLibraryConfigurations tests
+ # these are altered thanks to our eclass
+ sed -i -e 's:#IGNORE ::g' \
+ "${S}"/Tests/{OutDir,CMakeOnly/SelectLibraryConfigurations}/CMakeLists.txt \
+ || die
+
+ pushd "${BUILD_DIR}" > /dev/null
+
+ local ctestargs
+ [[ -n ${TEST_VERBOSE} ]] && ctestargs="--extra-verbose --output-on-failure"
+
+ # Excluded tests:
+ # BootstrapTest: we actualy bootstrap it every time so why test it.
+ # BundleUtilities: bundle creation broken
+ # CTest.updatecvs: which fails to commit as root
+ # Fortran: requires fortran
+ # Qt4Deploy, which tries to break sandbox and ignores prefix
+ # TestUpload, which requires network access
+ "${BUILD_DIR}"/bin/ctest ${ctestargs} \
+ -E "(BootstrapTest|BundleUtilities|CTest.UpdateCVS|Fortran|Qt4Deploy|TestUpload)" \
+ || die "Tests failed"
+
+ popd > /dev/null
+}
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ # disable running of cmake in boostrap command
+ sed -i \
+ -e '/"${cmake_bootstrap_dir}\/cmake"/s/^/#DONOTRUN /' \
+ bootstrap || die "sed failed"
+
+ # Add gcc libs to the default link paths
+ sed -i \
+ -e "s|@GENTOO_PORTAGE_GCCLIBDIR@|${EPREFIX}/usr/${CHOST}/lib/|g" \
+ -e "s|@GENTOO_PORTAGE_EPREFIX@|${EPREFIX}/|g" \
+ Modules/Platform/{UnixPaths,Darwin}.cmake || die "sed failed"
+
+ cmake_src_bootstrap
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_USE_SYSTEM_LIBRARIES=ON
+ -DCMAKE_USE_SYSTEM_LIBRARY_JSONCPP=$(usex system-jsoncpp)
+ -DCMAKE_INSTALL_PREFIX="${EPREFIX}"/usr
+ -DCMAKE_DOC_DIR=/share/doc/${PF}
+ -DCMAKE_MAN_DIR=/share/man
+ -DCMAKE_DATA_DIR=/share/${PN}
+ -DSPHINX_MAN=$(usex doc)
+ -DSPHINX_HTML=$(usex doc)
+ -DBUILD_CursesDialog="$(usex ncurses)"
+ )
+
+ if use qt4 || use qt5 ; then
+ mycmakeargs+=(
+ -DBUILD_QtDialog=ON
+ $(cmake-utils_use_find_package qt5 Qt5Widgets)
+ )
+ fi
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ use emacs && elisp-compile Auxiliary/cmake-mode.el
+}
+
+src_test() {
+ virtx cmake_src_test
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ if use emacs; then
+ elisp-install ${PN} Auxiliary/cmake-mode.el Auxiliary/cmake-mode.elc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+
+ insinto /usr/share/vim/vimfiles/syntax
+ doins Auxiliary/cmake-syntax.vim
+
+ insinto /usr/share/vim/vimfiles/indent
+ doins Auxiliary/cmake-indent.vim
+
+ insinto /usr/share/vim/vimfiles/ftdetect
+ doins "${FILESDIR}/${PN}.vim"
+
+ dobashcomp Auxiliary/bash-completion/{${PN},ctest,cpack}
+
+ rm -rf "${ED}"/usr/share/cmake/{completions,editors} || die
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/dev-util/cmake/files/cmake-2.8.12.1-FindImageMagick.patch b/dev-util/cmake/files/cmake-2.8.12.1-FindImageMagick.patch
index b094f17938ce..0c42303955af 100644
--- a/dev-util/cmake/files/cmake-2.8.12.1-FindImageMagick.patch
+++ b/dev-util/cmake/files/cmake-2.8.12.1-FindImageMagick.patch
@@ -1,5 +1,5 @@
---- Modules/FindImageMagick.cmake
-+++ Modules/FindImageMagick.cmake
+--- a/Modules/FindImageMagick.cmake
++++ b/Modules/FindImageMagick.cmake
@@ -147,17 +147,17 @@
)
if(component STREQUAL "Magick++")
diff --git a/dev-util/cmake/files/cmake-3.0.0-FindBLAS.patch b/dev-util/cmake/files/cmake-3.0.0-FindBLAS.patch
index 86c5dc7fd54a..342a4319798d 100644
--- a/dev-util/cmake/files/cmake-3.0.0-FindBLAS.patch
+++ b/dev-util/cmake/files/cmake-3.0.0-FindBLAS.patch
@@ -1,5 +1,5 @@
---- Modules/FindBLAS.cmake
-+++ Modules/FindBLAS.cmake
+--- a/Modules/FindBLAS.cmake
++++ b/Modules/FindBLAS.cmake
@@ -4,6 +4,10 @@
#
# Find BLAS library
diff --git a/dev-util/cmake/files/cmake-3.0.2-FindLAPACK.patch b/dev-util/cmake/files/cmake-3.0.2-FindLAPACK.patch
index 57250e453be0..321f05302aa1 100644
--- a/dev-util/cmake/files/cmake-3.0.2-FindLAPACK.patch
+++ b/dev-util/cmake/files/cmake-3.0.2-FindLAPACK.patch
@@ -1,5 +1,5 @@
---- Modules/FindLAPACK.cmake.orig 2014-09-15 23:50:11.377111987 +0200
-+++ Modules/FindLAPACK.cmake 2014-09-15 23:52:54.734388375 +0200
+--- a/Modules/FindLAPACK.cmake
++++ b/Modules/FindLAPACK.cmake
@@ -4,6 +4,10 @@
#
# Find LAPACK library
diff --git a/dev-util/cmake/files/cmake-3.1.0-FindPythonInterp.patch b/dev-util/cmake/files/cmake-3.1.0-FindPythonInterp.patch
index 78f622d886af..3abb2e4065e8 100644
--- a/dev-util/cmake/files/cmake-3.1.0-FindPythonInterp.patch
+++ b/dev-util/cmake/files/cmake-3.1.0-FindPythonInterp.patch
@@ -1,5 +1,5 @@
---- Modules/FindPythonInterp.cmake.orig 2015-01-06 11:50:03.376357898 +0100
-+++ Modules/FindPythonInterp.cmake 2015-01-06 12:25:48.614989290 +0100
+--- a/Modules/FindPythonInterp.cmake
++++ b/Modules/FindPythonInterp.cmake
@@ -75,6 +75,11 @@
else()
set(_PYTHON_FIND_OTHER_VERSIONS ${_PYTHON3_VERSIONS} ${_PYTHON2_VERSIONS} ${_PYTHON1_VERSIONS})
diff --git a/dev-util/cmake/files/cmake-3.1.0-darwin-isysroot.patch b/dev-util/cmake/files/cmake-3.1.0-darwin-isysroot.patch
index 119001aeef31..1f3599bcc828 100644
--- a/dev-util/cmake/files/cmake-3.1.0-darwin-isysroot.patch
+++ b/dev-util/cmake/files/cmake-3.1.0-darwin-isysroot.patch
@@ -1,8 +1,8 @@
Do not detect Xcode and set -isysroot for its SDK, since that messes up
our toolchain, and hence makes any compilation fail, bug #445308
---- Modules/Platform/Darwin-Initialize.cmake
-+++ Modules/Platform/Darwin-Initialize.cmake
+--- a/Modules/Platform/Darwin-Initialize.cmake
++++ b/Modules/Platform/Darwin-Initialize.cmake
@@ -1,16 +1,16 @@
# Ask xcode-select where to find /Developer or fall back to ancient location.
-execute_process(COMMAND xcode-select -print-path
diff --git a/dev-util/cmake/files/cmake-3.3.2-FindQt4.patch b/dev-util/cmake/files/cmake-3.3.2-FindQt4.patch
index 665c3304111f..31e4db3c5bb3 100644
--- a/dev-util/cmake/files/cmake-3.3.2-FindQt4.patch
+++ b/dev-util/cmake/files/cmake-3.3.2-FindQt4.patch
@@ -10,8 +10,8 @@ Once qmake is found, it is queried for the correct location of all other items.
Gentoo-bug: 547222
---- Modules/FindQt4.cmake
-+++ Modules/FindQt4.cmake
+--- a/Modules/FindQt4.cmake
++++ b/Modules/FindQt4.cmake
@@ -482,13 +482,23 @@
get_filename_component(qt_install_version "[HKEY_CURRENT_USER\\Software\\trolltech\\Versions;DefaultQtVersion]" NAME)