summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-07-28 23:07:17 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-07-28 23:20:47 +0200
commit4d84148a84abd331b7645b4de1b31621dec37615 (patch)
treead5e16309d2bd3002731624d725135a82cb90ef4 /dev-util/cmocka
parentdev-libs/libebml: Drop 1.3.6 and 1.3.7 (diff)
downloadgentoo-4d84148a84abd331b7645b4de1b31621dec37615.tar.gz
gentoo-4d84148a84abd331b7645b4de1b31621dec37615.tar.bz2
gentoo-4d84148a84abd331b7645b4de1b31621dec37615.zip
dev-util/cmocka: Drop 1.1.3
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-util/cmocka')
-rw-r--r--dev-util/cmocka/Manifest1
-rw-r--r--dev-util/cmocka/cmocka-1.1.3.ebuild51
-rw-r--r--dev-util/cmocka/files/cmocka-1.1.3-examples.patch45
-rw-r--r--dev-util/cmocka/files/cmocka-1.1.3-fix-doxygen.patch43
4 files changed, 0 insertions, 140 deletions
diff --git a/dev-util/cmocka/Manifest b/dev-util/cmocka/Manifest
index 1709a3dcbbe5..06a150ece922 100644
--- a/dev-util/cmocka/Manifest
+++ b/dev-util/cmocka/Manifest
@@ -1,2 +1 @@
-DIST cmocka-1.1.3.tar.xz 78744 BLAKE2B 5043a496afab08837a73c2e0ff9c9b3c3880a2fd394a768b1f8b51d2fec517a5527e93b7e660f8dcc73af79aaf88e224f4e2869c7e31540f8e54c76481905ff6 SHA512 b1a2ce72234256d653eebf95f8744a34525b9027e1ecf6552e1620c83a4bdda8b5674b748cc5fd14abada1e374829e2e7f0bcab0b1c8d6c3b7d9b7ec474b6ed3
DIST cmocka-1.1.5.tar.xz 81004 BLAKE2B 5625dc293ad481c654848f3de806ef88d1b651192c2461e52b54bf9d443b5e2ea5d2a685ab85b044685f57e5723ade6c4c17e38624f59c4eab240cb4feeaab1e SHA512 cad7f04757183d004f6eaad39036fc0e24c5e0e987f80e85bc43bc66dba22389cb02b08e25531cc28a541d0a24a86b29be134a2d6fc339128e87d66952f502bd
diff --git a/dev-util/cmocka/cmocka-1.1.3.ebuild b/dev-util/cmocka/cmocka-1.1.3.ebuild
deleted file mode 100644
index 59978fb7fdf0..000000000000
--- a/dev-util/cmocka/cmocka-1.1.3.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake-multilib
-
-DESCRIPTION="Unit testing framework for C"
-HOMEPAGE="https://cmocka.org/"
-SRC_URI="https://cmocka.org/files/1.1/${P}.tar.xz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
-IUSE="doc examples static-libs test"
-
-BDEPEND="
- doc? ( app-doc/doxygen[dot] )
-"
-
-DOCS=( AUTHORS ChangeLog README.md )
-
-PATCHES=(
- "${FILESDIR}/${P}-fix-doxygen.patch" # bug 671404
- "${FILESDIR}/${P}-examples.patch"
-)
-
-multilib_src_configure() {
- local mycmakeargs=(
- -DWITH_EXAMPLES=$(usex examples)
- -DWITH_STATIC_LIB=$(usex static-libs)
- -DUNIT_TESTING=$(usex test)
- $(multilib_is_native_abi && cmake-utils_use_find_package doc Doxygen \
- || echo -DCMAKE_DISABLE_FIND_PACKAGE_Doxygen=ON)
- )
-
- cmake-utils_src_configure
-}
-
-multilib_src_compile() {
- cmake-utils_src_compile
- multilib_is_native_abi && use doc && cmake-utils_src_compile docs
-}
-
-multilib_src_install() {
- if multilib_is_native_abi && use doc; then
- local HTML_DOCS=( "${BUILD_DIR}"/doc/html/. )
- fi
-
- cmake-utils_src_install
-}
diff --git a/dev-util/cmocka/files/cmocka-1.1.3-examples.patch b/dev-util/cmocka/files/cmocka-1.1.3-examples.patch
deleted file mode 100644
index 3d5fcc8098f0..000000000000
--- a/dev-util/cmocka/files/cmocka-1.1.3-examples.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-From ee264da1aa222b354cee36184ab48c2072f62243 Mon Sep 17 00:00:00 2001
-From: Andreas Schneider <asn@cryptomilk.org>
-Date: Wed, 23 Jan 2019 11:20:31 +0100
-Subject: [PATCH] cmake: Add WITH_EXAMPLES options
-
-This is turned on by default, but you can disable it, if you just
-package cmocka for an opterating system.
-
-Fixes #14
-
-Signed-off-by: Andreas Schneider <asn@cryptomilk.org>
----
- CMakeLists.txt | 4 +++-
- DefineOptions.cmake | 1 +
- 2 files changed, 4 insertions(+), 1 deletion(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 7778039..702be97 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -60,7 +60,9 @@ if (UNIT_TESTING)
- add_subdirectory(tests)
- endif (UNIT_TESTING)
-
--add_subdirectory(example)
-+if (WITH_EXAMPLES)
-+ add_subdirectory(example)
-+endif ()
-
- # pkg-config file
- configure_file(cmocka.pc.cmake ${CMAKE_CURRENT_BINARY_DIR}/cmocka.pc)
-diff --git a/DefineOptions.cmake b/DefineOptions.cmake
-index 5bc1ef3..911ff1d 100644
---- a/DefineOptions.cmake
-+++ b/DefineOptions.cmake
-@@ -1,5 +1,6 @@
- option(WITH_STATIC_LIB "Build with a static library" OFF)
- option(WITH_CMOCKERY_SUPPORT "Install a cmockery header" OFF)
-+option(WITH_EXAMPLES "Build examples" ON)
- option(UNIT_TESTING "Build with unit testing" OFF)
- option(PICKY_DEVELOPER "Build with picky developer flags" OFF)
-
---
-2.18.1
-
diff --git a/dev-util/cmocka/files/cmocka-1.1.3-fix-doxygen.patch b/dev-util/cmocka/files/cmocka-1.1.3-fix-doxygen.patch
deleted file mode 100644
index c093021aa824..000000000000
--- a/dev-util/cmocka/files/cmocka-1.1.3-fix-doxygen.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-From 1abfea55df24e83c2ea321b5f2b75e1a58963bc6 Mon Sep 17 00:00:00 2001
-From: Andreas Schneider <asn@cryptomilk.org>
-Date: Wed, 24 Oct 2018 16:33:39 +0200
-Subject: cmake: Fix doxygen generation
-
-Fixes #12
-
-Signed-off-by: Andreas Schneider <asn@cryptomilk.org>
----
- CMakeLists.txt | 2 +-
- doc/CMakeLists.txt | 2 +-
- 2 files changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 88408a9..7778039 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -51,9 +51,9 @@ if (MINGW)
- endif (MINGW)
-
- # check subdirectories
--add_subdirectory(doc)
- add_subdirectory(include)
- add_subdirectory(src)
-+add_subdirectory(doc)
-
- include(AddCMockaTest)
- if (UNIT_TESTING)
-diff --git a/doc/CMakeLists.txt b/doc/CMakeLists.txt
-index a7bc65e..6ac7494 100644
---- a/doc/CMakeLists.txt
-+++ b/doc/CMakeLists.txt
-@@ -38,7 +38,7 @@ if (DOXYGEN_FOUND)
-
- doxygen_add_docs(docs
- ${cmocka-library_SOURCE_DIR}
-- ${cmocka-headers_SOURCE_DIR}
-+ ${cmocka-header_SOURCE_DIR}
- ${CMAKE_CURRENT_SOURCE_DIR})
- endif(DOXYGEN_FOUND)
-
---
-cgit v1.2.1