summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <rhill@gentoo.org>2016-06-23 23:47:31 -0600
committerRyan Hill <rhill@gentoo.org>2016-06-23 23:48:22 -0600
commit3ff560ac5cdc3f61690f5bb77e8a5654b9853998 (patch)
tree94337bfb6e92c44495b8751f75a08cbbea71ee0f /dev-util/codeblocks/codeblocks-16.01.ebuild
parentdev-ruby/rubygems: cleanup (diff)
downloadgentoo-3ff560ac5cdc3f61690f5bb77e8a5654b9853998.tar.gz
gentoo-3ff560ac5cdc3f61690f5bb77e8a5654b9853998.tar.bz2
gentoo-3ff560ac5cdc3f61690f5bb77e8a5654b9853998.zip
dev-util/codeblocks: Version bump (bug #576730).
Package-Manager: portage-2.3.0_rc1 Signed-off-by: Ryan Hill <rhill@gentoo.org>
Diffstat (limited to 'dev-util/codeblocks/codeblocks-16.01.ebuild')
-rw-r--r--dev-util/codeblocks/codeblocks-16.01.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-util/codeblocks/codeblocks-16.01.ebuild b/dev-util/codeblocks/codeblocks-16.01.ebuild
new file mode 100644
index 000000000000..0e8814367bf8
--- /dev/null
+++ b/dev-util/codeblocks/codeblocks-16.01.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+WX_GTK_VER="2.8"
+
+inherit eutils wxwidgets
+
+DESCRIPTION="The open source, cross platform, free C++ IDE"
+HOMEPAGE="http://www.codeblocks.org/"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~x86-fbsd"
+SRC_URI="mirror://sourceforge/codeblocks/${P/-/_}.tar.gz"
+
+IUSE="contrib debug pch static-libs"
+
+S="${WORKDIR}/${P}.release"
+
+RDEPEND="app-arch/zip
+ x11-libs/wxGTK:${WX_GTK_VER}[X]
+ contrib? (
+ app-text/hunspell
+ dev-libs/boost:=
+ dev-libs/libgamin
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ touch "${S}"/revision.m4 -r "${S}"/acinclude.m4
+
+ setup-wxwidgets
+ econf \
+ --with-wx-config="${WX_CONFIG}" \
+ $(use_enable debug) \
+ $(use_enable pch) \
+ $(use_enable static-libs static) \
+ $(use_with contrib contrib-plugins all)
+}