summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/codeblocks
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/codeblocks')
-rw-r--r--dev-util/codeblocks/Manifest1
-rw-r--r--dev-util/codeblocks/codeblocks-13.12.ebuild41
-rw-r--r--dev-util/codeblocks/codeblocks-9999.ebuild60
-rw-r--r--dev-util/codeblocks/files/codeblocks-10.05-gcc47.patch91
-rw-r--r--dev-util/codeblocks/files/codeblocks-10.05-wxChartCtrl-crash.patch34
-rw-r--r--dev-util/codeblocks/metadata.xml8
6 files changed, 235 insertions, 0 deletions
diff --git a/dev-util/codeblocks/Manifest b/dev-util/codeblocks/Manifest
new file mode 100644
index 000000000000..ac7ea20c6803
--- /dev/null
+++ b/dev-util/codeblocks/Manifest
@@ -0,0 +1 @@
+DIST codeblocks_13.12-1.tar.gz 17221056 SHA256 772450046e8c8ba2ea0086acf433a46b83e6254fae64df9c8ca132a22f949610 SHA512 f09ab25579a4c9addcebdcc748a23963a52751853f4a1c15da10196d522f94bb17e01b2470b96d4470f5fd98725f7760e3923762c2217bcc48051eb9f7286f58 WHIRLPOOL cdf674bb9febd0d25ccfe84027b0c33f5fe9c5f1d19a1b32650487b71a6f110ee0657eaf67dceb758b192b5e5d3c2dd314f1a696491d7a70d0b334fd31a17ee3
diff --git a/dev-util/codeblocks/codeblocks-13.12.ebuild b/dev-util/codeblocks/codeblocks-13.12.ebuild
new file mode 100644
index 000000000000..bfc98340429e
--- /dev/null
+++ b/dev-util/codeblocks/codeblocks-13.12.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+WX_GTK_VER="2.8"
+
+inherit eutils wxwidgets
+
+DESCRIPTION="The open source, cross platform, free C++ IDE"
+HOMEPAGE="http://www.codeblocks.org/"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~x86-fbsd"
+SRC_URI="mirror://sourceforge/codeblocks/${P/-/_}-1.tar.gz"
+
+IUSE="contrib debug pch static-libs"
+
+RDEPEND="app-arch/zip
+ x11-libs/wxGTK:2.8[X]
+ contrib? (
+ app-text/hunspell
+ dev-libs/boost:=
+ dev-libs/libgamin
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ --with-wx-config="${WX_CONFIG}" \
+ $(use_enable debug) \
+ $(use_enable pch) \
+ $(use_enable static-libs static) \
+ $(use_with contrib contrib-plugins all)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}
diff --git a/dev-util/codeblocks/codeblocks-9999.ebuild b/dev-util/codeblocks/codeblocks-9999.ebuild
new file mode 100644
index 000000000000..878c44ba362d
--- /dev/null
+++ b/dev-util/codeblocks/codeblocks-9999.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+WX_GTK_VER="2.8"
+
+inherit autotools eutils subversion wxwidgets
+
+DESCRIPTION="The open source, cross platform, free C++ IDE"
+HOMEPAGE="http://www.codeblocks.org/"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS=""
+SRC_URI=""
+ESVN_REPO_URI="svn://svn.code.sf.net/p/${PN}/code/trunk"
+
+IUSE="contrib debug pch static-libs"
+
+RDEPEND="app-arch/zip
+ x11-libs/wxGTK:2.8[X]
+ contrib? (
+ app-text/hunspell
+ dev-libs/boost:=
+ dev-libs/libgamin
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_unpack() {
+ subversion_src_unpack
+}
+
+src_prepare() {
+ # Let's make the autorevision work.
+ subversion_wc_info
+ CB_LCD=$(LC_ALL=C svn info "${ESVN_WC_PATH}" | grep "^Last Changed Date:" | cut -d" " -f4,5)
+ echo "m4_define([SVN_REV], ${ESVN_WC_REVISION})" > revision.m4
+ echo "m4_define([SVN_DATE], ${CB_LCD})" >> revision.m4
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-wx-config="${WX_CONFIG}" \
+ $(use_enable debug) \
+ $(use_enable pch) \
+ $(use_enable static-libs static) \
+ $(use_with contrib contrib-plugins all)
+}
+
+src_compile() {
+ emake clean-zipfiles
+ emake
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}
diff --git a/dev-util/codeblocks/files/codeblocks-10.05-gcc47.patch b/dev-util/codeblocks/files/codeblocks-10.05-gcc47.patch
new file mode 100644
index 000000000000..12dfe315e2d0
--- /dev/null
+++ b/dev-util/codeblocks/files/codeblocks-10.05-gcc47.patch
@@ -0,0 +1,91 @@
+--- a/src/include/scripting/bindings/sc_base_types.h
++++ b/src/include/scripting/bindings/sc_base_types.h
+@@ -33,6 +33,7 @@ DECLARE_INSTANCE_TYPE(wxPoint);
+ DECLARE_INSTANCE_TYPE(wxSize);
+ DECLARE_INSTANCE_TYPE(wxString);
+
++using SqPlus::GetTypeName;
+ // C::B primitives and types
+ DECLARE_INSTANCE_TYPE(ConfigManager);
+ DECLARE_INSTANCE_TYPE(EditorManager);
+@@ -59,6 +60,7 @@ namespace SqPlus \
+ inline T Get(TypeWrapper<T>,HSQUIRRELVM v,int idx) { SQInteger i; SQPLUS_CHECK_GET(sq_getinteger(v,idx,&i)); return (T)i; } \
+ }
+
++using SqPlus::Push;
+ DECLARE_ENUM_TYPE(wxPathFormat);
+ DECLARE_ENUM_TYPE(wxPathNormalize);
+ DECLARE_ENUM_TYPE(PrintColourMode);
+--- /dev/null
++++ b/src/include/scripting/squirrel/sqmem.h
+@@ -0,0 +1,8 @@
++/* see copyright notice in squirrel.h */
++#ifndef _SQMEM_H_
++#define _SQMEM_H_
++
++void *sq_vm_malloc(SQUnsignedInteger size);
++void *sq_vm_realloc(void *p,SQUnsignedInteger oldsize,SQUnsignedInteger size);
++void sq_vm_free(void *p,SQUnsignedInteger size);
++#endif //_SQMEM_H_
+--- a/src/include/scripting/squirrel/sqstate.h
++++ b/src/include/scripting/squirrel/sqstate.h
+@@ -136,8 +136,4 @@ extern SQObjectPtr _one_;
+ extern SQObjectPtr _minusone_;
+
+ bool CompileTypemask(SQIntVec &res,const SQChar *typemask);
+-
+-void *sq_vm_malloc(SQUnsignedInteger size);
+-void *sq_vm_realloc(void *p,SQUnsignedInteger oldsize,SQUnsignedInteger size);
+-void sq_vm_free(void *p,SQUnsignedInteger size);
+ #endif //_SQSTATE_H_
+--- a/src/include/scripting/squirrel/squtils.h
++++ b/src/include/scripting/squirrel/squtils.h
+@@ -2,6 +2,7 @@
+ #ifndef _SQUTILS_H_
+ #define _SQUTILS_H_
+
++#include "sqmem.h"
+ #define sq_new(__ptr,__type) {__ptr=(__type *)sq_vm_malloc(sizeof(__type));new (__ptr) __type;}
+ #define sq_delete(__ptr,__type) {__ptr->~__type();sq_vm_free(__ptr,sizeof(__type));}
+ #define SQ_MALLOC(__size) sq_vm_malloc((__size));
+--- a/src/plugins/contrib/help_plugin/defs.h
++++ b/src/plugins/contrib/help_plugin/defs.h
+@@ -289,7 +289,7 @@ class QMap : public std::map<Key, T>
+
+ if (i.second == false && overwrite)
+ {
+- find(k)->second = t;
++ this->find(k)->second = t;
+ }
+
+ return i.first;
+@@ -297,7 +297,7 @@ class QMap : public std::map<Key, T>
+
+ int remove(const Key &k)
+ {
+- return erase(k);
++ return this->erase(k);
+ }
+ };
+
+--- a/src/plugins/contrib/help_plugin/man2html.cpp
++++ b/src/plugins/contrib/help_plugin/man2html.cpp
+@@ -123,7 +123,7 @@
+
+ #include <ctype.h>
+
+-//#include <unistd.h>
++#include <unistd.h>
+ #include <string.h>
+
+ #include <stdio.h>
+--- a/src/plugins/debuggergdb/gdb_driver.cpp
++++ b/src/plugins/debuggergdb/gdb_driver.cpp
+@@ -72,6 +72,7 @@ static wxRegEx reChildPid3(_T("Thread[ \t]+[xA-Fa-f0-9-]+[ \t]+\\(LWP ([0-9]+)\\
+
+
+ // scripting support
++using SqPlus::Push;
+ DECLARE_INSTANCE_TYPE(GDB_driver);
+
+ GDB_driver::GDB_driver(DebuggerGDB* plugin)
diff --git a/dev-util/codeblocks/files/codeblocks-10.05-wxChartCtrl-crash.patch b/dev-util/codeblocks/files/codeblocks-10.05-wxChartCtrl-crash.patch
new file mode 100644
index 000000000000..af95ac2ca2b2
--- /dev/null
+++ b/dev-util/codeblocks/files/codeblocks-10.05-wxChartCtrl-crash.patch
@@ -0,0 +1,34 @@
+codeblocks crashes when a wxChartCtrl is added with wxSmith
+
+https://bugs.gentoo.org/show_bug.cgi?id=372837
+https://developer.berlios.de/bugs/?func=detailbug&bug_id=18182&group_id=5358
+
+
+--- a/src/plugins/contrib/wxSmithContribItems/wxchart/wxchart-1.0/src/chartwindow.cpp
++++ b/src/plugins/contrib/wxSmithContribItems/wxchart/wxchart-1.0/src/chartwindow.cpp
+@@ -156,7 +156,13 @@ void wxChartWindow::DrawHLines(
+ }
+
+ wxChartSizes *sizes = GetSizes();
+-
++
++ // sizes may be NULL, in this case do nothing
++ // not sure if this is the right way to do things
++ // gw.fossdev@gmail.com
++ if (!sizes)
++ return;
++
+ hp->SetPen( *wxBLACK_DASHED_PEN );
+
+ double current = lower;
+@@ -188,6 +194,10 @@ ChartValue wxChartWindow::GetVirtualWidth() const
+ int iNodes = static_cast<int>(ceil( GetVirtualMaxX() ));
+ wxChartSizes *sizes = GetSizes();
+
++ /// sizes may be NULL, in this case return a fixes value
++ if (!sizes)
++ return 1;
++
+ ChartValue x = 0;
+
+ for ( int iNode = 0; iNode <= iNodes; ++ iNode )
diff --git a/dev-util/codeblocks/metadata.xml b/dev-util/codeblocks/metadata.xml
new file mode 100644
index 000000000000..fac9faab5a75
--- /dev/null
+++ b/dev-util/codeblocks/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>wxwidgets</herd>
+ <use>
+ <flag name="contrib">Build additional contrib components</flag>
+ </use>
+</pkgmetadata>