summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorband-a-prend <torokhov-s-a@yandex.ru>2020-01-20 11:31:42 +0300
committerMart Raudsepp <leio@gentoo.org>2020-01-20 12:10:29 +0200
commite81939abcc4b91034596311f7f6944f1dba52256 (patch)
tree33265b993132548b1971c4febf1a70f8ddd98444 /dev-util/codeblocks
parentdev-util/codeblocks: bump 17.12-r302 to migrate to EAPI-7 and to fix RDEPEND (diff)
downloadgentoo-e81939abcc4b91034596311f7f6944f1dba52256.tar.gz
gentoo-e81939abcc4b91034596311f7f6944f1dba52256.tar.bz2
gentoo-e81939abcc4b91034596311f7f6944f1dba52256.zip
dev-util/codeblocks: remove revisions depend on gtk2
Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru> Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'dev-util/codeblocks')
-rw-r--r--dev-util/codeblocks/codeblocks-17.12-r1.ebuild84
-rw-r--r--dev-util/codeblocks/codeblocks-17.12.ebuild80
2 files changed, 0 insertions, 164 deletions
diff --git a/dev-util/codeblocks/codeblocks-17.12-r1.ebuild b/dev-util/codeblocks/codeblocks-17.12-r1.ebuild
deleted file mode 100644
index 07ab74227eac..000000000000
--- a/dev-util/codeblocks/codeblocks-17.12-r1.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-WX_GTK_VER="3.0"
-
-inherit autotools gnome2-utils wxwidgets xdg-utils
-
-DESCRIPTION="The open source, cross platform, free C, C++ and Fortran IDE"
-HOMEPAGE="http://www.codeblocks.org/"
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-SRC_URI="mirror://sourceforge/${PN}/${P/-/_}.tar.xz
-https://dev.gentoo.org/~leio/distfiles/${P}-fortran.tar.xz
-https://dev.gentoo.org/~leio/distfiles/${P}_update_astyle_plugin_to_v3.1.patch.xz"
-
-# USE="fortran" enables FortranProject plugin (v1.5)
-# that is delivered with Code::Blocks 17.12 source code.
-# https://sourceforge.net/projects/fortranproject
-# http://cbfortran.sourceforge.net
-
-IUSE="contrib debug fortran pch"
-
-RDEPEND="app-arch/zip
- x11-libs/wxGTK:${WX_GTK_VER}[X]
- contrib? (
- app-admin/gamin
- app-text/hunspell
- dev-libs/boost:=
- )"
-
-DEPEND="${RDEPEND}
- >=dev-libs/tinyxml-2.6.2-r3
- >=dev-util/astyle-3.0.1-r1:0=
- virtual/pkgconfig"
-
-PATCHES=(
- "${FILESDIR}"/codeblocks-17.12-nodebug.diff
- "${WORKDIR}"/patches/
- )
-
-src_prepare() {
- default
- if has_version ">=dev-util/astyle-3.1" ; then
- epatch "${WORKDIR}"/codeblocks-17.12_update_astyle_plugin_to_v3.1.patch
- fi
- eautoreconf
-}
-
-src_configure() {
- setup-wxwidgets
-
- # USE="contrib -fortran" setup:
- use fortran || CONF_WITH_LST=$(use_with contrib contrib-plugins all,-FortranProject)
- # USE="contrib fortran" setup:
- use fortran && CONF_WITH_LST=$(use_with contrib contrib-plugins all)
- # USE="-contrib fortran" setup:
- use contrib || CONF_WITH_LST=$(use_with fortran contrib-plugins FortranProject)
-
- econf \
- --disable-static \
- $(use_enable debug) \
- $(use_enable pch) \
- ${CONF_WITH_LST}
-}
-
-pkg_postinst() {
- if [[ ${WX_GTK_VER} == "3.0" || ${WX_GTK_VER} == "3.0-gtk3" ]]; then
- elog "The symbols browser is disabled due to it causing crashes."
- elog "For more information see https://sourceforge.net/p/codeblocks/tickets/225/"
- fi
-
- xdg_desktop_database_update
- xdg_mimeinfo_database_update
- gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- xdg_desktop_database_update
- xdg_mimeinfo_database_update
- gnome2_icon_cache_update
-}
diff --git a/dev-util/codeblocks/codeblocks-17.12.ebuild b/dev-util/codeblocks/codeblocks-17.12.ebuild
deleted file mode 100644
index c83617929435..000000000000
--- a/dev-util/codeblocks/codeblocks-17.12.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-WX_GTK_VER="3.0"
-
-inherit autotools flag-o-matic gnome2-utils wxwidgets xdg-utils
-
-DESCRIPTION="The open source, cross platform, free C++ IDE"
-HOMEPAGE="http://www.codeblocks.org/"
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~x86"
-SRC_URI="mirror://sourceforge/${PN}/${P/-/_}.tar.xz https://dev.gentoo.org/~leio/distfiles/${P}-fortran.tar.xz"
-
-# USE="fortran" enables FortranProject plugin (v1.5)
-# that is delivered with Code::Blocks 17.12 source code.
-# https://sourceforge.net/projects/fortranproject
-# http://cbfortran.sourceforge.net
-
-IUSE="contrib debug fortran pch"
-
-RDEPEND="app-arch/zip
- x11-libs/wxGTK:${WX_GTK_VER}[X]
- contrib? (
- app-text/hunspell
- dev-libs/boost:=
- dev-libs/libgamin
- )"
-
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-PATCHES=(
- "${FILESDIR}"/codeblocks-17.12-nodebug.diff
- "${WORKDIR}"/patches/
-)
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- setup-wxwidgets
-
- append-cxxflags $(test-flags-CXX -fno-delete-null-pointer-checks)
-
- # USE="contrib -fortran" setup:
- use fortran || CONF_WITH_LST=$(use_with contrib contrib-plugins all,-FortranProject)
- # USE="contrib fortran" setup:
- use fortran && CONF_WITH_LST=$(use_with contrib contrib-plugins all)
- # USE="-contrib fortran" setup:
- use contrib || CONF_WITH_LST=$(use_with fortran contrib-plugins FortranProject)
-
- econf \
- --with-wx-config="${WX_CONFIG}" \
- --disable-static \
- $(use_enable debug) \
- $(use_enable pch) \
- ${CONF_WITH_LST}
-}
-
-pkg_postinst() {
- if [[ ${WX_GTK_VER} == "3.0" || ${WX_GTK_VER} == "3.0-gtk3" ]]; then
- elog "The symbols browser is disabled due to it causing crashes."
- elog "For more information see https://sourceforge.net/p/codeblocks/tickets/225/"
- fi
-
- xdg_desktop_database_update
- xdg_mimeinfo_database_update
- gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- xdg_desktop_database_update
- xdg_mimeinfo_database_update
- gnome2_icon_cache_update
-}