summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2015-11-12 15:38:30 -0700
committerChristoph Junghans <ottxor@gentoo.org>2015-11-12 15:38:42 -0700
commita1a0dae742c6a8010aef4cc116dcef8d2b09992d (patch)
tree67ad3af146bee4fe168c274eabb0c0296f842224 /dev-util/cwdiff/cwdiff-0.4.0.ebuild
parentdev-lang/python: Copy the 2.7 EPYTHON fix to older versions (diff)
downloadgentoo-a1a0dae742c6a8010aef4cc116dcef8d2b09992d.tar.gz
gentoo-a1a0dae742c6a8010aef4cc116dcef8d2b09992d.tar.bz2
gentoo-a1a0dae742c6a8010aef4cc116dcef8d2b09992d.zip
dev-util/cwdiff: version bump
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-util/cwdiff/cwdiff-0.4.0.ebuild')
-rw-r--r--dev-util/cwdiff/cwdiff-0.4.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-util/cwdiff/cwdiff-0.4.0.ebuild b/dev-util/cwdiff/cwdiff-0.4.0.ebuild
new file mode 100644
index 000000000000..70d032f2d042
--- /dev/null
+++ b/dev-util/cwdiff/cwdiff-0.4.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="git://github.com/junghans/${PN}.git https://github.com/junghans/${PN}.git"
+ inherit git-r3
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/junghans/cwdiff/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x64-macos ~x86-macos"
+fi
+
+DESCRIPTION="A script that wraps wdiff to support directories and colorize the output"
+HOMEPAGE="https://github.com/junghans/cwdiff"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="mercurial"
+
+DEPEND="sys-apps/help2man
+ sys-apps/coreutils"
+RDEPEND="
+ sys-apps/sed
+ app-shells/bash
+ app-text/wdiff
+ sys-apps/diffutils
+ mercurial? ( dev-vcs/mercurial )
+ "
+
+src_install() {
+ emake DESTDIR="${ED}" $(usex mercurial '' 'HGRCDIR=') install
+ dodoc README.md
+}