summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-10-01 04:24:35 +0200
committerJeroen Roovers <jer@gentoo.org>2019-10-01 04:24:58 +0200
commit487b78b65718c9a08b0ed4fdf82ba33f5635d0ee (patch)
treeeb1df8d9b1ddd1be942c6d9ac47192872270d7e4 /dev-util/debootstrap
parentapp-emulation/faudio: Sync with ::wine (diff)
downloadgentoo-487b78b65718c9a08b0ed4fdf82ba33f5635d0ee.tar.gz
gentoo-487b78b65718c9a08b0ed4fdf82ba33f5635d0ee.tar.bz2
gentoo-487b78b65718c9a08b0ed4fdf82ba33f5635d0ee.zip
dev-util/debootstrap: Version 1.0.116
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'dev-util/debootstrap')
-rw-r--r--dev-util/debootstrap/Manifest1
-rw-r--r--dev-util/debootstrap/debootstrap-1.0.116.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-util/debootstrap/Manifest b/dev-util/debootstrap/Manifest
index e67c4049bb3f..04f1046e4378 100644
--- a/dev-util/debootstrap/Manifest
+++ b/dev-util/debootstrap/Manifest
@@ -1,2 +1,3 @@
DIST debootstrap_1.0.115.tar.gz 75691 BLAKE2B ef2ddd8b76d7eafdf5be50e3cbb99725066562bc4a717ab42b436dcab3e5e3a2148c9e6eeaf7b6135e4bde836ee01101e7158ebc0472c08329ae0152d0845b8b SHA512 635e4feb1fb2bc247968127dc86bf0956243c8058f99e66ede177da84f0258cfc2de51873f347c099217b07e679527aeac08e7263d31b4112fb0708edb3deeb9
+DIST debootstrap_1.0.116.tar.gz 75723 BLAKE2B 3a48e0a51dcd6066af26d036df17e36bb901d7099dfa9521ca86cc1d2d70b8326ad068dd86130de1a2b686a44391d8fd0bcfb78f24cd558777b487f8bdbde699 SHA512 59ba44ecfa7c6bc3d81a814fe66a87223fa4bde24bd986f75875fe9077355a5f4268d822347f99402d4146e81b270a06f21111fb977729f4326bb5b8e017583c
DIST devices.tar.gz 47835 BLAKE2B 03bfe097fda12a7a0aa19d3308c0d44382ad945defea05a63b17a72e4051ef94f0e60e75bde35baeace81da59d9f04126f6e463163609475b9c0fdf518f533ef SHA512 994ec8d72e3d52d2d872f7ff0da2336e4cbd3a5fa73bb6cdb9e06f5e7f5b8c69cea639c738fdba1186f382d6dcf62e7746fface664bfbd744aac24b16f034432
diff --git a/dev-util/debootstrap/debootstrap-1.0.116.ebuild b/dev-util/debootstrap/debootstrap-1.0.116.ebuild
new file mode 100644
index 000000000000..8214beb8d505
--- /dev/null
+++ b/dev-util/debootstrap/debootstrap-1.0.116.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit eutils
+
+DESCRIPTION="Debian/Ubuntu bootstrap scripts"
+HOMEPAGE="https://packages.qa.debian.org/d/debootstrap.html"
+SRC_URI="mirror://debian/pool/main/d/${PN}/${PN}_${PV}.tar.gz
+ mirror://gentoo/devices.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ app-arch/dpkg
+ net-misc/wget
+ sys-devel/binutils
+"
+DOCS=( TODO debian/changelog )
+
+src_unpack() {
+ unpack ${PN}_${PV}.tar.gz
+ cp "${DISTDIR}"/devices.tar.gz "${S}"
+}
+
+src_compile() {
+ return
+}
+
+src_install() {
+ default
+ doman debootstrap.8
+}
+
+pkg_postinst() {
+ if ! has_version ${CATEGORY}/${PN} && ! has_version app-crypt/gnupg; then
+ elog "To check Release files against a keyring (--keyring=K), please"
+ elog "install app-crypt/gnupg"
+ fi
+
+ if ! has_version app-crypt/debian-archive-keyring || ! has_version app-crypt/ubuntu-keyring; then
+ elog "To check Release files from Debian or Ubuntu, please install"
+ elog " app-crypt/debian-archive-keyring or"
+ elog " app-crypt/ubuntu-keyring as required"
+ fi
+}