summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-01-26 18:33:22 +0200
committerMart Raudsepp <leio@gentoo.org>2020-01-26 20:00:28 +0200
commitfb8422391bb91a27a37c1373a9cf78729df258cd (patch)
treefa54ed85a5b16c7174e6bda4db54e42c0549b831 /dev-util/devhelp
parentdev-util/gnome-builder: bump to 3.32.4 (diff)
downloadgentoo-fb8422391bb91a27a37c1373a9cf78729df258cd.tar.gz
gentoo-fb8422391bb91a27a37c1373a9cf78729df258cd.tar.bz2
gentoo-fb8422391bb91a27a37c1373a9cf78729df258cd.zip
dev-util/devhelp: add py3.7 support, use python_gen_cond_dep
Closes: https://bugs.gentoo.org/702438 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'dev-util/devhelp')
-rw-r--r--dev-util/devhelp/devhelp-3.30.1.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/dev-util/devhelp/devhelp-3.30.1.ebuild b/dev-util/devhelp/devhelp-3.30.1.ebuild
index e00885f4d8ee..014be70449d8 100644
--- a/dev-util/devhelp/devhelp-3.30.1.ebuild
+++ b/dev-util/devhelp/devhelp-3.30.1.ebuild
@@ -2,9 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-# gedit-3.8 is python3 only, this also per:
-# https://bugzilla.redhat.com/show_bug.cgi?id=979450
-PYTHON_COMPAT=( python3_6 )
+PYTHON_COMPAT=( python3_{6,7} )
inherit gnome.org gnome2-utils meson python-single-r1 xdg
@@ -28,8 +26,11 @@ COMMON_DEPEND="
RDEPEND="${COMMON_DEPEND}
gedit? (
${PYTHON_DEPS}
- app-editors/gedit[introspection,python,${PYTHON_USEDEP}]
- dev-python/pygobject:3[${PYTHON_USEDEP}] )
+ $(python_gen_cond_dep '
+ app-editors/gedit[introspection,python,${PYTHON_SINGLE_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]
+ ')
+ )
"
# libxml2 required for glib-compile-resources
DEPEND="${COMMON_DEPEND}