summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/difffilter
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/difffilter')
-rw-r--r--dev-util/difffilter/Manifest2
-rw-r--r--dev-util/difffilter/difffilter-0.3.1.ebuild30
-rw-r--r--dev-util/difffilter/difffilter-0.3.3.ebuild30
-rw-r--r--dev-util/difffilter/metadata.xml9
4 files changed, 71 insertions, 0 deletions
diff --git a/dev-util/difffilter/Manifest b/dev-util/difffilter/Manifest
new file mode 100644
index 000000000000..1923a459352e
--- /dev/null
+++ b/dev-util/difffilter/Manifest
@@ -0,0 +1,2 @@
+DIST difffilter-0.3.1.tar.bz2 273674 SHA256 e9bcb74fb6aa3ec6c917a1a98c9e2e6023aa5c0bed5d4605787b3392f6340ded SHA512 eaadbdb3e215501461e46905066dc9c9adead54549f78727b5ffd3aff540aa81141d5853cb459932d695c25521f74f0c30c214df4693a3abaf141e0aad294a82 WHIRLPOOL 27f578d56e0a6222749f2d5ca8717233393183926afe14793f2358671ba1ea69a26fb4519f316df894d2ee37c2ad7f5ae0156eb1ebc643e71b7182c062c9f499
+DIST difffilter-0.3.3.tar.bz2 291226 SHA256 2f14af2a3535a52322ae77d805c2a4ae1e8301eee0905406845cea3c2ae0bcd3 SHA512 ac9aa95dd7e41b6c49c1416be9d1929a41b629587ecb90f3dcadd3982a46d8eb49d181f8f1b1645322113becd9a4b708d0df1e27f6fb9064ffb06b37e5f101f8 WHIRLPOOL 06f50da86ab174e974e9f88f522ed4b18a4c93e783b3691840be2fb419f20da8b823c41c2daff4ca8f78377463dc63de5741da5b1d8efe14fd6686fa8a34f299
diff --git a/dev-util/difffilter/difffilter-0.3.1.ebuild b/dev-util/difffilter/difffilter-0.3.1.ebuild
new file mode 100644
index 000000000000..de81ad35df7a
--- /dev/null
+++ b/dev-util/difffilter/difffilter-0.3.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+inherit autotools-utils
+
+DESCRIPTION="Filter files out of unified diffs using POSIX extended regular expressions"
+HOMEPAGE="http://ohnopub.net/~ohnobinki/difffilter/"
+SRC_URI="ftp://ohnopub.net/mirror/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux"
+IUSE="doc"
+
+RDEPEND=">=dev-libs/liblist-2.3.1
+ dev-libs/libstrl
+ dev-libs/tre"
+DEPEND="doc? ( app-text/txt2man )
+ ${RDEPEND}"
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable doc)
+ )
+
+ autotools-utils_src_configure
+}
diff --git a/dev-util/difffilter/difffilter-0.3.3.ebuild b/dev-util/difffilter/difffilter-0.3.3.ebuild
new file mode 100644
index 000000000000..e13939ddd58d
--- /dev/null
+++ b/dev-util/difffilter/difffilter-0.3.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit autotools-utils
+
+DESCRIPTION="Filter files out of unified diffs using POSIX extended regular expressions"
+HOMEPAGE="http://ohnopub.net/~ohnobinki/difffilter/"
+SRC_URI="ftp://mirror.ohnopub.net/mirror/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux"
+IUSE="doc"
+
+RDEPEND=">=dev-libs/liblist-2.3.1
+ dev-libs/libstrl
+ dev-libs/tre"
+DEPEND="doc? ( app-text/txt2man )
+ ${RDEPEND}"
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable doc)
+ )
+
+ autotools-utils_src_configure
+}
diff --git a/dev-util/difffilter/metadata.xml b/dev-util/difffilter/metadata.xml
new file mode 100644
index 000000000000..43866671d490
--- /dev/null
+++ b/dev-util/difffilter/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>binki@gentoo.org</email>
+ <name>Nathan Phillip Brink</name>
+ <description>Upstream and maintainer. Assign bugs to him</description>
+ </maintainer>
+</pkgmetadata>