summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/dropwatch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/dropwatch')
-rw-r--r--dev-util/dropwatch/Manifest1
-rw-r--r--dev-util/dropwatch/dropwatch-1.4.ebuild47
-rw-r--r--dev-util/dropwatch/files/dropwatch-1.4-binutils-2.23.patch68
-rw-r--r--dev-util/dropwatch/files/dropwatch-1.4-makefile.patch21
-rw-r--r--dev-util/dropwatch/metadata.xml8
5 files changed, 145 insertions, 0 deletions
diff --git a/dev-util/dropwatch/Manifest b/dev-util/dropwatch/Manifest
new file mode 100644
index 000000000000..e4cc3b5420e3
--- /dev/null
+++ b/dev-util/dropwatch/Manifest
@@ -0,0 +1 @@
+DIST dropwatch-1.4.tbz2 32199 SHA256 ede45fd3b4a847a9befa73e9e8f6336aee5418fc3e041648c684e5085113a3b4 SHA512 a5744ea156464c53d31d5b54bcaf9bd61f2035285059bc05a3eec20be71d1451a6191237f194dc5d8e6fb6fcbb81d9ef87adf5ac2d878cc1f159191c47118e29 WHIRLPOOL 3d8661ab85da0a7485e8f6312eeb99e1ed14f6af38d119093c835e94f518918908e596d3e5744be5f529d280b6644b459106eb503112df58b63865737f8eecc1
diff --git a/dev-util/dropwatch/dropwatch-1.4.ebuild b/dev-util/dropwatch/dropwatch-1.4.ebuild
new file mode 100644
index 000000000000..59e63c1f04df
--- /dev/null
+++ b/dev-util/dropwatch/dropwatch-1.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit linux-info toolchain-funcs
+
+DESCRIPTION="A utility to interface to the kernel to monitor for dropped network packets"
+HOMEPAGE="https://fedorahosted.org/dropwatch/"
+SRC_URI="https://fedorahosted.org/releases/d/r/dropwatch/${P}.tbz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-libs/libnl:3
+ sys-libs/readline
+ sys-devel/binutils"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+CONFIG_CHECK="~NET_DROP_MONITOR"
+
+PATCHES=(
+ "${FILESDIR}/${P}-makefile.patch"
+ "${FILESDIR}/${P}-binutils-2.23.patch"
+)
+
+src_prepare() {
+ epatch ${PATCHES[@]}
+ epatch_user
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" -C src
+}
+
+src_install() {
+ dobin "src/${PN}"
+ doman "doc/${PN}.1"
+ dodoc README
+}
+
+pkg_postinst() {
+ einfo "Ensure that 'drop_monitor' kernel module is loaded before running ${PN}"
+}
diff --git a/dev-util/dropwatch/files/dropwatch-1.4-binutils-2.23.patch b/dev-util/dropwatch/files/dropwatch-1.4-binutils-2.23.patch
new file mode 100644
index 000000000000..43702c4ff385
--- /dev/null
+++ b/dev-util/dropwatch/files/dropwatch-1.4-binutils-2.23.patch
@@ -0,0 +1,68 @@
+diff -aurd src.orig/lookup.c src/lookup.c
+--- src.orig/lookup.c 2011-10-03 22:51:38.000000000 +0400
++++ src/lookup.c 2013-02-18 09:13:56.683214438 +0400
+@@ -27,13 +27,13 @@
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <sys/utsname.h>
+-#include <bfd.h>
+ #include <string.h>
+ #include <unistd.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+
+ #include "lookup.h"
++#include <bfd.h>
+
+ extern struct lookup_methods bfd_methods;
+ extern struct lookup_methods kallsym_methods;
+diff -aurd src.orig/lookup.h src/lookup.h
+--- src.orig/lookup.h 2011-10-03 22:51:38.000000000 +0400
++++ src/lookup.h 2013-02-18 09:11:00.506895026 +0400
+@@ -28,6 +28,9 @@
+ #include <stdlib.h>
+ #include <asm/types.h>
+
++// satisfy PR 14072 in bfd.h
++#define PACKAGE 1
++#define PACKAGE_VERSION 1
+
+ /*
+ * Initalization routine
+diff -aurd src.orig/lookup_bfd.c src/lookup_bfd.c
+--- src.orig/lookup_bfd.c 2012-01-16 22:34:11.000000000 +0400
++++ src/lookup_bfd.c 2013-02-18 09:14:02.472984310 +0400
+@@ -25,13 +25,13 @@
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <sys/utsname.h>
+-#include <bfd.h>
+ #include <string.h>
+ #include <unistd.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+
+ #include "lookup.h"
++#include <bfd.h>
+
+
+ static int lookup_bfd_init(void)
+diff -aurd src.orig/lookup_kas.c src/lookup_kas.c
+--- src.orig/lookup_kas.c 2012-05-31 02:43:23.000000000 +0400
++++ src/lookup_kas.c 2013-02-18 09:14:07.906101713 +0400
+@@ -25,7 +25,6 @@
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <sys/utsname.h>
+-#include <bfd.h>
+ #include <string.h>
+ #include <unistd.h>
+ #include <sys/types.h>
+@@ -33,6 +32,7 @@
+ #include <sys/queue.h>
+
+ #include "lookup.h"
++#include <bfd.h>
+
+ struct symbol_entry {
+ char *sym_name;
diff --git a/dev-util/dropwatch/files/dropwatch-1.4-makefile.patch b/dev-util/dropwatch/files/dropwatch-1.4-makefile.patch
new file mode 100644
index 000000000000..14ffcc83513e
--- /dev/null
+++ b/dev-util/dropwatch/files/dropwatch-1.4-makefile.patch
@@ -0,0 +1,21 @@
+--- src/Makefile.orig 2012-10-24 13:27:12.000000000 +0400
++++ src/Makefile 2012-10-24 13:27:47.000000000 +0400
+@@ -1,14 +1,14 @@
+ all: dropwatch
+-CFLAGS+=-c -g -D_GNU_SOURCE -Wall -Werror `pkg-config --cflags libnl-3.0`
+-LDFLAGS=-lbfd -lreadline -lnl-3 -lnl-genl-3
++CFLAGS+=-c -D_GNU_SOURCE -Wall `pkg-config --cflags libnl-3.0`
++LIBS=-lbfd -lreadline -lnl-3 -lnl-genl-3
+ OBJFILES := main.o lookup.o\
+ lookup_bfd.o lookup_kas.o
+
+ dropwatch: $(OBJFILES)
+- gcc -g -o dropwatch $(OBJFILES) $(LDFLAGS)
++ $(CC) -o dropwatch $(LDFLAGS) $(OBJFILES) $(LIBS)
+
+ %.o: %.c
+- gcc $(CFLAGS) $<
++ $(CC) $(CFLAGS) $<
+ clean:
+ rm -f dropwatch *.o
+
diff --git a/dev-util/dropwatch/metadata.xml b/dev-util/dropwatch/metadata.xml
new file mode 100644
index 000000000000..ee2fca9fb255
--- /dev/null
+++ b/dev-util/dropwatch/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>bircoph@gentoo.org</email>
+ <name>Andrew Savchenko</name>
+ </maintainer>
+</pkgmetadata>