summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/duma/duma-2.5.13.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/duma/duma-2.5.13.ebuild')
-rw-r--r--dev-util/duma/duma-2.5.13.ebuild85
1 files changed, 85 insertions, 0 deletions
diff --git a/dev-util/duma/duma-2.5.13.ebuild b/dev-util/duma/duma-2.5.13.ebuild
new file mode 100644
index 000000000000..0c3c41620aaa
--- /dev/null
+++ b/dev-util/duma/duma-2.5.13.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils flag-o-matic multilib toolchain-funcs versionator
+
+MY_P="${PN}_$(replace_all_version_separators '_')"
+
+DESCRIPTION="DUMA (Detect Unintended Memory Access) is a memory debugging library"
+HOMEPAGE="http://duma.sourceforge.net/"
+
+SRC_URI="mirror://sourceforge/duma/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="examples"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ app-shells/bash"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ #DUMA_OPTIONS="-DDUMA_LIB_NO_LEAKDETECTION"
+ DUMA_OPTIONS="-DDUMA_USE_FRAMENO"
+ if [ -n "${DUMA_OPTIONS}" ]; then
+ ewarn ""
+ elog "Custom build options are ${DUMA_OPTIONS}."
+ else
+ ewarn ""
+ elog "Custom build options are not set!"
+ fi
+ elog "See the package Makefile for for more options (also installed"
+ elog "with package docs as Makefile.duma)."
+ ewarn ""
+}
+
+src_unpack(){
+ unpack ${A}
+ cd "${S}"
+ sed -i -e "s:(prefix)/lib:(prefix)/$(get_libdir):g" Makefile
+ sed -i -e "s:share/doc/duma:share/doc/${P}:g" Makefile
+}
+
+src_compile(){
+ replace-flags O? O0
+ append-flags -Wall -Wextra -U_FORTIFY_SOURCE
+ tc-export AR CC CXX LD RANLIB
+
+ use amd64 && export DUMA_ALIGNMENT=16
+
+ make CPPFLAGS="${DUMA_OPTIONS}" reconfig || die "make reconfig failed"
+ emake CFLAGS="${CFLAGS}" CC=$(tc-getCC) || die "make failed"
+}
+
+src_test() {
+ ewarn "Control-C now if you want to disable tests..."
+ epause 5
+
+ cd "${S}"
+ use amd64 && export DUMA_ALIGNMENT=16
+ make CFLAGS="${DUMA_OPTIONS} ${CFLAGS}" \
+ CC=$(tc-getCC) test || die "make test failed"
+
+ elog ""
+ ewarn "Check output above to verify all tests have passed. Both"
+ ewarn "static and dynamic confidence tests should say PASSED."
+ elog ""
+}
+
+src_install(){
+ # make install fails nicely here on the first file...
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc CHANGELOG TODO
+ # All the good comments on duma build options are in the Makefile
+ newdoc Makefile Makefile.duma
+
+ if use examples; then
+ insinto /usr/share/doc/${P}/examples
+ doins example[1-6].cpp
+ doins example_makes/ex6/Makefile
+ fi
+}