summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2021-05-07 10:34:24 +0300
committerJoonas Niilola <juippis@gentoo.org>2021-05-07 10:35:26 +0300
commit8640f87789c2395ddf4f004bcfc1aee6691c100a (patch)
treed1793cc3dd3a4cfaa5dc9e836af15cf941b50aae /dev-util/edi
parentdev-util/edi: stabilize 0.8.0-r1 on x86 (diff)
downloadgentoo-8640f87789c2395ddf4f004bcfc1aee6691c100a.tar.gz
gentoo-8640f87789c2395ddf4f004bcfc1aee6691c100a.tar.bz2
gentoo-8640f87789c2395ddf4f004bcfc1aee6691c100a.zip
dev-util/edi: remove old
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-util/edi')
-rw-r--r--dev-util/edi/edi-0.8.0.ebuild59
1 files changed, 0 insertions, 59 deletions
diff --git a/dev-util/edi/edi-0.8.0.ebuild b/dev-util/edi/edi-0.8.0.ebuild
deleted file mode 100644
index 7d927fc23d22..000000000000
--- a/dev-util/edi/edi-0.8.0.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit llvm meson xdg
-
-DESCRIPTION="An EFL-based IDE"
-HOMEPAGE="http://edi-ide.com/
- https://www.enlightenment.org/about-edi
- https://phab.enlightenment.org/w/projects/edi/
- https://github.com/Enlightenment/edi"
-SRC_URI="https://github.com/Enlightenment/edi/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2 GPL-3 LGPL-2.1-with-linking-exception"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="clang"
-
-RDEPEND="|| ( dev-libs/efl[X] dev-libs/efl[wayland] )
- >=dev-libs/efl-1.22.0[eet]
- clang? ( sys-devel/clang:= )"
-DEPEND="${RDEPEND}
- dev-libs/check"
-BDEPEND="virtual/pkgconfig"
-
-llvm_check_deps() {
- has_version "sys-devel/clang:${LLVM_SLOT}"
-}
-
-pkg_setup() {
- use clang && llvm_pkg_setup
-}
-
-src_prepare() {
- default
-
- # fix a QA issue with .desktop file, https://phab.enlightenment.org/T7368
- sed -i '/Version=/d' data/desktop/edi.desktop* || die
-
- # fix 'unexpected path' QA warning
- sed -i 's|share/doc/edi/|share/doc/'${PF}'/|g' doc/meson.build || die
-}
-
-src_configure() {
- local emesonargs=(
- -D bear=false
- $(meson_use clang libclang)
- )
-
- if use clang; then
- emesonargs+=(
- -D libclang-headerdir="$(llvm-config --includedir)"
- -D libclang-libdir="$(llvm-config --libdir)"
- )
- fi
-
- meson_src_configure
-}