summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Mayo <aklhfex@gmail.com>2020-10-26 19:20:35 +0000
committerJoonas Niilola <juippis@gentoo.org>2020-10-28 09:51:08 +0200
commit0f1ad151249a7f8f098a3c021c3b666ee70cf547 (patch)
tree033ed02efd0cdab4e62eb67f83c629524eb14088 /dev-util/geany-plugins
parentgames-simulation/simutrans: fix desktop file (diff)
downloadgentoo-0f1ad151249a7f8f098a3c021c3b666ee70cf547.tar.gz
gentoo-0f1ad151249a7f8f098a3c021c3b666ee70cf547.tar.bz2
gentoo-0f1ad151249a7f8f098a3c021c3b666ee70cf547.zip
dev-util/geany-plugins: version bump to 1.37
gtk3 USE flag replaced with gtk2 to align with dev-util/geany-1.37. Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Chris Mayo <aklhfex@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/18043 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-util/geany-plugins')
-rw-r--r--dev-util/geany-plugins/Manifest1
-rw-r--r--dev-util/geany-plugins/geany-plugins-1.37.ebuild124
-rw-r--r--dev-util/geany-plugins/metadata.xml1
3 files changed, 126 insertions, 0 deletions
diff --git a/dev-util/geany-plugins/Manifest b/dev-util/geany-plugins/Manifest
index 5343c304284a..1b5562574dca 100644
--- a/dev-util/geany-plugins/Manifest
+++ b/dev-util/geany-plugins/Manifest
@@ -1 +1,2 @@
DIST geany-plugins-1.36.tar.gz 4693634 BLAKE2B a7c319a77cb92a55a0a53063ab75d9375f7d2a0e419eb3e0acd063b8fda4b4d9798c103ce53b80090c73bd86804c58f815aaf8d0eecc0d7fbf7ad1c8470cb9b5 SHA512 b3e58b42432d17c27289fa20d10b833a2d7f5d8c72b51abe5b1ebdabcb952b18e0984b15ef6ac9753102d839f3174f28798269e1e94bf032bdaa189e98d72b2d
+DIST geany-plugins-1.37.tar.gz 4711239 BLAKE2B 7f4fd121f6f0784aecf2dcc04d208c89e502b23debcbc40889f93c1421e414c33c8634376cfe01e91c370f70818d33b373b88698f5cb0ee23dff5edee9d781cf SHA512 47f8d7170593114c773067a8132c724471cbf881582a0a739da578ca42533783d8ecbccb04e039f2990ceed440bbd2d94e4be4a28e336c7f74b8e11a15ba4ce9
diff --git a/dev-util/geany-plugins/geany-plugins-1.37.ebuild b/dev-util/geany-plugins/geany-plugins-1.37.ebuild
new file mode 100644
index 000000000000..a1018068f128
--- /dev/null
+++ b/dev-util/geany-plugins/geany-plugins-1.37.ebuild
@@ -0,0 +1,124 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A collection of different plugins for Geany"
+HOMEPAGE="https://plugins.geany.org"
+SRC_URI="https://plugins.geany.org/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="gtk2 ctags debugger enchant git gpg gtkspell lua markdown nls pretty-printer scope soup workbench"
+REQUIRED_USE="gtk2? ( !markdown )"
+
+DEPEND="
+ dev-libs/glib:2
+ >=dev-util/geany-1.37[gtk2=]
+ !gtk2? ( x11-libs/gtk+:3 )
+ gtk2? ( x11-libs/gtk+:2 )
+ ctags? ( dev-util/ctags )
+ debugger? (
+ !gtk2? ( x11-libs/vte:2.91 )
+ gtk2? ( x11-libs/vte:0 )
+ )
+ enchant? ( app-text/enchant:= )
+ git? ( dev-libs/libgit2:= )
+ gpg? ( app-crypt/gpgme:1= )
+ gtkspell? (
+ !gtk2? ( app-text/gtkspell:3= )
+ gtk2? ( app-text/gtkspell:2 )
+ )
+ lua? ( dev-lang/lua:0= )
+ markdown? (
+ app-text/discount
+ net-libs/webkit-gtk:4
+ )
+ pretty-printer? ( dev-libs/libxml2:2 )
+ scope? (
+ !gtk2? ( x11-libs/vte:2.91 )
+ gtk2? ( x11-libs/vte:0 )
+ )
+ soup? ( net-libs/libsoup:2.4 )
+ workbench? ( dev-libs/libgit2:= )
+"
+RDEPEND="${DEPEND}
+ scope? ( sys-devel/gdb )
+"
+BDEPEND="virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+"
+
+src_configure() {
+ local myeconfargs=(
+ --disable-cppcheck
+ --disable-extra-c-warnings
+ $(use_enable nls)
+ --enable-utilslib
+ # Plugins
+ --enable-addons
+ --enable-autoclose
+ --enable-automark
+ --enable-codenav
+ --enable-commander
+ --enable-defineformat
+ --enable-geanyextrasel
+ --enable-geanyinsertnum
+ --enable-geanymacro
+ --enable-geanyminiscript
+ --enable-geanynumberedbookmarks
+ --enable-geanyprj
+ --enable-geanyvc $(use_enable gtkspell)
+ --enable-keyrecord
+ --enable-latex
+ --enable-lineoperations
+ --enable-lipsum
+ --enable-overview
+ --enable-pairtaghighlighter
+ --enable-pohelper
+ --enable-projectorganizer
+ --enable-sendmail
+ --enable-shiftcolumn
+ --enable-tableconvert
+ --enable-treebrowser
+ --enable-vimode
+ --enable-xmlsnippets
+ $(use_enable debugger)
+ $(use_enable ctags geanyctags)
+ $(use_enable gtk2 geanydoc)
+ $(use_enable lua geanylua)
+ $(use_enable gpg geanypg)
+ $(use_enable soup geniuspaste)
+ $(use_enable git gitchangebar)
+ $(use_enable markdown) --disable-peg-markdown # using app-text/discount instead
+ $(use_enable pretty-printer)
+ $(use_enable scope)
+ $(use_enable enchant spellcheck)
+ # Having updatechecker… when you’re using a package manager?
+ $(use_enable soup updatechecker)
+ $(use_enable workbench)
+ # GeanyGenDoc requires ctpl which isn’t yet in portage
+ --disable-geanygendoc
+ # Require obsolete and vulnerable webkit-gtk versions
+ --disable-devhelp
+ --disable-webhelper
+ # GTK 2 only
+ --disable-geanypy
+ --disable-multiterm
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+
+ # make installs all translations if LINGUAS is empty
+ if [[ -z "${LINGUAS-x}" ]]; then
+ rm -r "${ED}/usr/share/locale/" || die
+ fi
+}
diff --git a/dev-util/geany-plugins/metadata.xml b/dev-util/geany-plugins/metadata.xml
index 6a11d0ae3243..db5b9d2b0d41 100644
--- a/dev-util/geany-plugins/metadata.xml
+++ b/dev-util/geany-plugins/metadata.xml
@@ -10,6 +10,7 @@
<name>Gentoo Proxy Maintainers Project</name>
</maintainer>
<use>
+ <flag name="gtk2">Use GTK+2 instead of GTK+3</flag>
<flag name="gtk3">Use GTK+3 instead of GTK+2</flag>
<flag name="ctags">Enable ctags plugin</flag>
<flag name="debugger">Enable the debugger plugin which interfaces with <pkg>sys-devel/gdb</pkg></flag>