summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-10-27 06:37:24 +0100
committerSam James <sam@gentoo.org>2021-10-27 06:37:24 +0100
commit77615d7b99d8048194e82df0103e69756b0ca864 (patch)
treed0c7b8694e1e7363ca73ac00874df096dae64a37 /dev-util/google-perftools
parentdev-util/google-perftools: drop 2.8, 2.9.1 (diff)
downloadgentoo-77615d7b99d8048194e82df0103e69756b0ca864.tar.gz
gentoo-77615d7b99d8048194e82df0103e69756b0ca864.tar.bz2
gentoo-77615d7b99d8048194e82df0103e69756b0ca864.zip
dev-util/google-perftools: minor ebuild tidying, fix typo in 2.9.1-r1 too
Bug: https://bugs.gentoo.org/818871 Bug: https://bugs.gentoo.org/820449 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/google-perftools')
-rw-r--r--dev-util/google-perftools/google-perftools-2.9.1-r2.ebuild (renamed from dev-util/google-perftools/google-perftools-2.9.1-r1.ebuild)13
1 files changed, 9 insertions, 4 deletions
diff --git a/dev-util/google-perftools/google-perftools-2.9.1-r1.ebuild b/dev-util/google-perftools/google-perftools-2.9.1-r2.ebuild
index ed4a219b335d..0ac7aaf851de 100644
--- a/dev-util/google-perftools/google-perftools-2.9.1-r1.ebuild
+++ b/dev-util/google-perftools/google-perftools-2.9.1-r2.ebuild
@@ -4,7 +4,7 @@
EAPI=7
MY_P="gperftools-${PV}"
-inherit toolchain-funcs flag-o-matic autotools vcs-snapshot multilib-minimal
+inherit flag-o-matic autotools vcs-snapshot multilib-minimal
DESCRIPTION="Fast, multi-threaded malloc() and nifty performance analysis tools"
HOMEPAGE="https://github.com/gperftools/gperftools"
@@ -64,13 +64,18 @@ multilib_src_configure() {
use optimisememory && append-cppflags -DTCMALLOC_SMALL_BUT_SLOW
append-flags -fno-strict-aliasing -fno-omit-frame-pointer
- local myconfargs=(
+ local myeconfargs=(
--enable-shared
$(use_enable static-libs static)
$(use_enable debug debugalloc)
- $(if [[ ${ABI} == x32 ]]; then printf "--enable-minimal\n" else use_enable minimal; fi)
)
+ if [[ ${ABI} == x32 ]]; then
+ myeconfargs+=( --enable-minimal )
+ else
+ myeconfargs+=( $(use_enable minimal) )
+ fi
+
if use arm64 || use s390; then
# Use the same arches for disabling TLS (thread local storage)
# as Fedora, but we might need to expand this list if we get
@@ -78,7 +83,7 @@ multilib_src_configure() {
myeconfargs+=( --disable-general-dynamic-tls )
fi
- econf "${myconfargs[@]}"
+ econf "${myeconfargs[@]}"
}
src_test() {