summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-06-15 12:21:07 -0700
committerMatt Turner <mattst88@gentoo.org>2021-06-15 12:32:39 -0700
commit6b64f48aac48404d70194ce0216876451abe6877 (patch)
tree3a4428ec74c2679215bb58af7b1dcf380cdc748d /dev-util/gtk-builder-convert
parentapp-text/enchant: Version bump to 2.3.0 (diff)
downloadgentoo-6b64f48aac48404d70194ce0216876451abe6877.tar.gz
gentoo-6b64f48aac48404d70194ce0216876451abe6877.tar.bz2
gentoo-6b64f48aac48404d70194ce0216876451abe6877.zip
dev-util/gtk-builder-convert: Version bump to 2.24.33
Closes: https://bugs.gentoo.org/796218 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-util/gtk-builder-convert')
-rw-r--r--dev-util/gtk-builder-convert/Manifest1
-rw-r--r--dev-util/gtk-builder-convert/gtk-builder-convert-2.24.33.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-util/gtk-builder-convert/Manifest b/dev-util/gtk-builder-convert/Manifest
index f4efda5ce38f..4fc2843baf91 100644
--- a/dev-util/gtk-builder-convert/Manifest
+++ b/dev-util/gtk-builder-convert/Manifest
@@ -1 +1,2 @@
DIST gtk+-2.24.32.tar.xz 12620860 BLAKE2B 03f4c0a8be98473f62bc8c86859937969c4169960a5f93d37ff6dcde00413215fa6c7125b15781bf50d67b40aa0056cb71b83fb50acb2c3467b5deb3c8d938f0 SHA512 8e8fd9ae32f1d6fb544da260f00599f0f05090d910d767b06ef086ab4f1f8373a29bb0da9767761c9b5f4cfd51b5c45d0fa5d39b0428c839ddf0a579df806696
+DIST gtk+-2.24.33.tar.xz 12661828 BLAKE2B f3488b220aaee54bf36fa77e2112d060152e57938845d240014a7d43a5743b1d4de19cc09c683d9d238fd1967cd67cc3c493f2475e4e481f6709f5cdc652c65c SHA512 71b588797c81f727dfac8dcb1be193f7436f717d30ecf18eae2d3aeb0f445b3be4743400acac16435490db8f564f01032065d3f42d27871317f80c98aef929d5
diff --git a/dev-util/gtk-builder-convert/gtk-builder-convert-2.24.33.ebuild b/dev-util/gtk-builder-convert/gtk-builder-convert-2.24.33.ebuild
new file mode 100644
index 000000000000..e8b9d84780ba
--- /dev/null
+++ b/dev-util/gtk-builder-convert/gtk-builder-convert-2.24.33.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+GNOME_ORG_MODULE="gtk+"
+PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_REQ_USE="xml"
+
+inherit gnome.org python-single-r1
+
+DESCRIPTION="Converts Glade files to GtkBuilder XML format"
+HOMEPAGE="https://www.gtk.org/"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"
+BDEPEND="${PYTHON_DEPS}
+ app-text/docbook-xml-dtd:4.3
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+"
+
+src_configure() { :; }
+
+src_compile() {
+ xsltproc -nonet http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl docs/reference/gtk/gtk-builder-convert.xml || die
+}
+
+src_install() {
+ doman gtk-builder-convert.1
+ python_doscript gtk/gtk-builder-convert
+}