summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2020-05-11 20:11:07 +0300
committerJoonas Niilola <juippis@gentoo.org>2020-05-11 20:12:16 +0300
commit25c7f1b7a4eb8bd35dcf7e1c991ac5476a2ec3ae (patch)
treee8d99f66916c69d11f005890dafaa9aaa9c72e6f /dev-util/hfstospell
parentwww-client/seamonkey: Security cleanup (diff)
downloadgentoo-25c7f1b7a4eb8bd35dcf7e1c991ac5476a2ec3ae.tar.gz
gentoo-25c7f1b7a4eb8bd35dcf7e1c991ac5476a2ec3ae.tar.bz2
gentoo-25c7f1b7a4eb8bd35dcf7e1c991ac5476a2ec3ae.zip
dev-util/hfstospell: gcc-10 fix
Closes: https://bugs.gentoo.org/721894 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-util/hfstospell')
-rw-r--r--dev-util/hfstospell/files/hfstospell-0.5.1-gcc-10-fix.patch24
-rw-r--r--dev-util/hfstospell/hfstospell-0.5.1.ebuild4
2 files changed, 27 insertions, 1 deletions
diff --git a/dev-util/hfstospell/files/hfstospell-0.5.1-gcc-10-fix.patch b/dev-util/hfstospell/files/hfstospell-0.5.1-gcc-10-fix.patch
new file mode 100644
index 000000000000..0998beebe7d7
--- /dev/null
+++ b/dev-util/hfstospell/files/hfstospell-0.5.1-gcc-10-fix.patch
@@ -0,0 +1,24 @@
+From a9d5afb14aa71893f142dfd3ae735e8930aa0f8a Mon Sep 17 00:00:00 2001
+From: Martin Liska <mliska@suse.cz>
+Date: Mon, 16 Mar 2020 11:32:10 +0100
+Subject: [PATCH] Fix a typo in wide string conversion function (#49).
+
+Revert a hunk from:
+04e4843e4c66beb61b756f3ceb2ac94628142185.
+---
+ main.cc | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/main.cc b/main.cc
+index abecf46..e4fd676 100644
+--- a/main.cc
++++ b/main.cc
+@@ -61,7 +61,7 @@ static bool suggest_reals = false;
+ #ifdef WINDOWS
+ static std::string wide_string_to_string(const std::wstring & wstr)
+ {
+- int size_needed = WideCharToMultiByte(CP_UTF8, 0, &wstr[0], (int)§wstr.size(), NULL, 0, NULL, NULL);
++ int size_needed = WideCharToMultiByte(CP_UTF8, 0, &wstr[0], (int)wstr.size(), NULL, 0, NULL, NULL);
+ std::string str( size_needed, 0 );
+ WideCharToMultiByte(CP_UTF8, 0, &wstr[0], (int)wstr.size(), &str[0], size_needed, NULL, NULL);
+ return str;
diff --git a/dev-util/hfstospell/hfstospell-0.5.1.ebuild b/dev-util/hfstospell/hfstospell-0.5.1.ebuild
index 84452334ab9f..bf47865439b9 100644
--- a/dev-util/hfstospell/hfstospell-0.5.1.ebuild
+++ b/dev-util/hfstospell/hfstospell-0.5.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -22,6 +22,8 @@ BDEPEND="virtual/pkgconfig"
S="${WORKDIR}/hfst-ospell-${PV}"
+PATCHES=( "${FILESDIR}/hfstospell-0.5.1-gcc-10-fix.patch" )
+
src_prepare() {
default
eautoreconf