summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlice Ferrazzi <alicef@gentoo.org>2017-01-26 18:33:32 +0900
committerAlice Ferrazzi <alicef@gentoo.org>2017-01-26 18:34:01 +0900
commitf597b363a994a5f8a3065db11ca4ba06279380e8 (patch)
treef208875503ff6d08e03846d31febff69757fae2a /dev-util/idea-community
parentdev-libs/libuv-1.10.2-r0: stable on alpha (diff)
downloadgentoo-f597b363a994a5f8a3065db11ca4ba06279380e8.tar.gz
gentoo-f597b363a994a5f8a3065db11ca4ba06279380e8.tar.bz2
gentoo-f597b363a994a5f8a3065db11ca4ba06279380e8.zip
dev-util/idea-community: init
Package-Manager: portage-2.3.3
Diffstat (limited to 'dev-util/idea-community')
-rw-r--r--dev-util/idea-community/Manifest1
-rw-r--r--dev-util/idea-community/idea-community-2016.3.3.163.11103.6.ebuild71
-rw-r--r--dev-util/idea-community/metadata.xml14
3 files changed, 86 insertions, 0 deletions
diff --git a/dev-util/idea-community/Manifest b/dev-util/idea-community/Manifest
new file mode 100644
index 000000000000..0f52e053e471
--- /dev/null
+++ b/dev-util/idea-community/Manifest
@@ -0,0 +1 @@
+DIST ideaIC-163.11103.6.tar.gz 410586563 SHA256 c80c6e32190555d48182ae22876ca29171a4ad2c042eb3461ddf3b82a4fb39ed SHA512 ce7190cd8c4c63c3cf9e68ea415afb66214f71f1886ad16ec8d56513208824f86c902b2f886a208b73f45528600531b471972766e163378a1fd957065e89dd0f WHIRLPOOL 00610c467f81b19566413710b575162ae90f516a1366a5d60b870875e7dcde96b23090ca20dd77a635b7306fab27a4694ee30c5eca26196f2418ccc4e7146e08
diff --git a/dev-util/idea-community/idea-community-2016.3.3.163.11103.6.ebuild b/dev-util/idea-community/idea-community-2016.3.3.163.11103.6.ebuild
new file mode 100644
index 000000000000..4654bc6b9f39
--- /dev/null
+++ b/dev-util/idea-community/idea-community-2016.3.3.163.11103.6.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils versionator
+
+SLOT="0"
+PV_STRING="$(get_version_component_range 4-6)"
+MY_PV="$(get_version_component_range 1-3)"
+MY_PN="idea"
+
+# distinguish settings for official stable releases and EAP-version releases
+if [[ "$(get_version_component_range 7)x" = "prex" ]]
+then
+ # upstream EAP
+ KEYWORDS=""
+ SRC_URI="https://download.jetbrains.com/idea/${MY_PN}IC-${PV_STRING}.tar.gz"
+else
+ # upstream stable
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://download.jetbrains.com/idea/${MY_PN}IC-${MY_PV}.tar.gz -> ${MY_PN}IC-${PV_STRING}.tar.gz"
+fi
+
+DESCRIPTION="A complete toolset for web, mobile and enterprise development"
+HOMEPAGE="https://www.jetbrains.com/idea"
+
+LICENSE="IDEA
+ || ( IDEA_Academic IDEA_Classroom IDEA_OpenSource IDEA_Personal )"
+IUSE="-custom-jdk"
+
+DEPEND="!dev-util/${PN}:14
+ !dev-util/${PN}:15"
+RDEPEND="${DEPEND}
+ >=virtual/jdk-1.7:*"
+S="${WORKDIR}/${MY_PN}-IC-${PV_STRING}"
+
+QA_PREBUILT="opt/${PN}-${MY_PV}/*"
+
+src_prepare() {
+ if ! use arm; then
+ rm bin/fsnotifier-arm || die
+ fi
+ if ! use custom-jdk; then
+ if [[ -d jre ]]; then
+ rm -r jre || die
+ fi
+ fi
+}
+
+src_install() {
+ local dir="/opt/${PN}-${MY_PV}"
+
+ insinto "${dir}"
+ doins -r *
+ fperms 755 "${dir}"/bin/{idea.sh,fsnotifier{,64}}
+
+ if use custom-jdk; then
+ if [[ -d jre ]]; then
+ fperms 755 "${dir}"/jre/jre/bin/{java,jjs,keytool,orbd,pack200,policytool,rmid,rmiregistry,servertool,tnameserv,unpack200}
+ fi
+ fi
+
+ make_wrapper "${PN}" "${dir}/bin/${MY_PN}.sh"
+ newicon "bin/${MY_PN}.png" "${PN}.png"
+ make_desktop_entry "${PN}" "IntelliJ Idea Ultimate" "${PN}" "Development;IDE;"
+
+ # recommended by: https://confluence.jetbrains.com/display/IDEADEV/Inotify+Watches+Limit
+ mkdir -p "${D}/etc/sysctl.d/" || die
+ echo "fs.inotify.max_user_watches = 524288" > "${D}/etc/sysctl.d/30-idea-inotify-watches.conf" || die
+}
diff --git a/dev-util/idea-community/metadata.xml b/dev-util/idea-community/metadata.xml
new file mode 100644
index 000000000000..695fd92bb182
--- /dev/null
+++ b/dev-util/idea-community/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+ <email>alicef@gentoo.org</email>
+ <name>Ferrazzi Alice</name>
+</maintainer>
+<longdescription lang="en">
+ Excel at enterprise, mobile and web development with Java, Scala and Groovy, with all the latest modern technologies and frameworks available out of the box.
+</longdescription>
+<use>
+ <flag name="custom-jdk">Install and use IntelliJ's custom JRE.</flag>
+</use>
+</pkgmetadata>