summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2018-12-08 16:37:57 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2018-12-08 16:45:25 +0000
commit42bd04eecd2904866aa45567601ae0ade3d744dc (patch)
tree4a96136259d83a80e19102e3b76ed9a9244fc286 /dev-util/include-what-you-use
parentnet-print/hplip: Version bump to hplip-3.18.12. (diff)
downloadgentoo-42bd04eecd2904866aa45567601ae0ade3d744dc.tar.gz
gentoo-42bd04eecd2904866aa45567601ae0ade3d744dc.tar.bz2
gentoo-42bd04eecd2904866aa45567601ae0ade3d744dc.zip
dev-util/include-what-you-use: bump up to 7.0
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-util/include-what-you-use')
-rw-r--r--dev-util/include-what-you-use/Manifest1
-rw-r--r--dev-util/include-what-you-use/include-what-you-use-7.0.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-util/include-what-you-use/Manifest b/dev-util/include-what-you-use/Manifest
index 44c429cc6c90..109f68dafceb 100644
--- a/dev-util/include-what-you-use/Manifest
+++ b/dev-util/include-what-you-use/Manifest
@@ -1,3 +1,4 @@
DIST include-what-you-use-4.0.src.tar.gz 437340 BLAKE2B 744f7893169a637636107e23cae356db7f12aa01fefd39626600b3fa3dbd77688503e7332a2dbc673339145692625fd8fa3f10e0d405a77e2d5586e6bfeb0378 SHA512 c96b78ec8f8289bfd7830acaf533aea0077bb36311d3b8bb7f31464c1b3a5b3f353b24e81ffc581811b4083d3b5959e4e947e3a3d16cb7c77de00b05b9972a90
DIST include-what-you-use-5.0.src.tar.gz 439081 BLAKE2B 85246aa5333a073bb195b873d7bfe084a56c343cece92322706717ce699bcd75b737203858277202791ec0eb91f560b06a371e902cb175cdb2858562a4830e74 SHA512 9d4a9717a3a3f6752f8bdd1392b6d7a5e8b8dc277ef46a50f24185a089360380e1da92a61fd150598843f5c24cff03e74bc674e57579960d977acde755e34c52
DIST include-what-you-use-6.0.src.tar.gz 440406 BLAKE2B 485a61dd4f72c158ad9c798c8121d7af9134d79b94c9c30c14674a62007e9fc05acc7e2341cc3282288611beb9138768bf11cd2d73efed372adab83e90b268db SHA512 2bf2593dba252d870074125f976a237e901e969323969f2c8fb030e8376bb230f1d5c2baecc8cd8fad7099e83589c7666c44cd178d2094f6e883cace1e53ad90
+DIST include-what-you-use-7.0.src.tar.gz 541840 BLAKE2B bf20a5598f02f03e5f714582653b8062eab6e414967ef2374c28bb6c1cdce8f73f80e3b2f4953fd943587ce17dc657cf6ab2a9db4208a59030d432f6a40532e5 SHA512 50d186b2e09c3595cc2dc7513e5db74da0038987158c2c45ef4279c67c50de621ca6499b07894ee203f25566aafaddde4b05840946f921678499d2efc131575a
diff --git a/dev-util/include-what-you-use/include-what-you-use-7.0.ebuild b/dev-util/include-what-you-use/include-what-you-use-7.0.ebuild
new file mode 100644
index 000000000000..0defc992f95a
--- /dev/null
+++ b/dev-util/include-what-you-use/include-what-you-use-7.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit cmake-utils flag-o-matic llvm python-single-r1
+
+DESCRIPTION="Find unused include directives in C/C++ programs"
+HOMEPAGE="https://include-what-you-use.org/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/clang_${PV}.tar.gz -> ${P}.src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+LLVM_MAX_SLOT=7
+
+RDEPEND="sys-devel/llvm:${LLVM_MAX_SLOT}
+ sys-devel/clang:${LLVM_MAX_SLOT}
+ ${PYTHON_DEPS}
+"
+DEPEND="${RDEPEND}"
+
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+S=${WORKDIR}/${PN}-clang_${PV}
+
+pkg_setup() {
+ llvm_pkg_setup
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ cmake-utils_src_prepare
+ python_fix_shebang .
+}
+
+src_configure() {
+ local mycmakeargs=(
+ # Note [llvm install path]
+ # Unfortunately all binaries using clang driver
+ # have to reside at the same path depth as
+ # 'clang' binary itself. See bug #625972
+ # Thus as a hack we install it to the same directory
+ # as llvm/clang itself.
+ -DCMAKE_INSTALL_PREFIX="$(get_llvm_prefix "${LLVM_MAX_SLOT}")"
+ )
+ cmake-utils_src_configure
+}
+
+src_test() {
+ "${EPYTHON}" run_iwyu_tests.py
+}