summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2019-10-01 22:51:25 +0100
committerMarek Szuba <marecki@gentoo.org>2019-10-01 22:54:09 +0100
commit75cf44e0275b5562410a19bf4383da157aefaee9 (patch)
tree94997a5f9456f4c84d3e4c5c4573f67fa03009f2 /dev-util/intel-graphics-compiler
parentdev-libs/opencl-clang: bump to 8.0.1_p20191001 (diff)
downloadgentoo-75cf44e0275b5562410a19bf4383da157aefaee9.tar.gz
gentoo-75cf44e0275b5562410a19bf4383da157aefaee9.tar.bz2
gentoo-75cf44e0275b5562410a19bf4383da157aefaee9.zip
dev-util/intel-graphics-compiler: bump to 1.0.11
Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-util/intel-graphics-compiler')
-rw-r--r--dev-util/intel-graphics-compiler/Manifest1
-rw-r--r--dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.11.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-util/intel-graphics-compiler/Manifest b/dev-util/intel-graphics-compiler/Manifest
index 606121b059a4..398ef3ea56d9 100644
--- a/dev-util/intel-graphics-compiler/Manifest
+++ b/dev-util/intel-graphics-compiler/Manifest
@@ -1,2 +1,3 @@
+DIST intel-graphics-compiler-1.0.11.tar.gz 5720630 BLAKE2B 1539de7aec3d0c357159a5be6c446ee4e3c98857fb666ab09ceefdb9ae93b430bc164de2f17848f25aeef1a95ce2066441aa0584354c14ed06fbb9179a17ba58 SHA512 2b4b43b152014329e2d9dcba1a5b832fb8c641a3bd004345ddc8d36a237bc15f112ef007894b5adbe175bf08584093adcee655b5e61a9da81d6956974e03248f
DIST intel-graphics-compiler-1.0.8.tar.gz 6428984 BLAKE2B 1835f86da24162af0f568794fd084c12cf8950601a74d3aaef928739d7ef942a23b2309713976b2fd67684d7360706155610ee7a80db0dbc217ff5b502b254d2 SHA512 43c54858fcc5ec5941d79ed34774077bcd5ece80d6d2bb28526b15ffe5237dddbcef2c13e4cc21faf35851174ed5a5b1af65db9bdd3281657e1e09456b761c18
DIST intel-graphics-compiler-1.0.9.tar.gz 5684971 BLAKE2B c3a07773f1ee4ef53bae4af61a85e8ac60f3ddde3573fa853c12c887f94191b344b905bfb0d6ef7e489b2bbb05c01719981199fa85397c87f4ef74b0338bfffe SHA512 67c9efafab1cce4c34fb00cf9b20660c2107daeff27e3837a52c9f24405cb5c11c46366662692d47b4490584890cc5a5791de358196dcabc6e566e22b1aafd53
diff --git a/dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.11.ebuild b/dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.11.ebuild
new file mode 100644
index 000000000000..54d2ad4034cd
--- /dev/null
+++ b/dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.11.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-multilib llvm
+
+DESCRIPTION="LLVM-based OpenCL compiler targetting Intel Gen graphics hardware"
+HOMEPAGE="https://github.com/intel/intel-graphics-compiler"
+SRC_URI="https://github.com/intel/${PN}/archive/igc-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+COMMON="sys-devel/llvm:8=[${MULTILIB_USEDEP}]
+ >=dev-libs/opencl-clang-8.0.1:8=[${MULTILIB_USEDEP}]"
+DEPEND="${COMMON}"
+RDEPEND="${COMMON}"
+
+LLVM_MAX_SLOT=8
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0.9-no_Werror.patch
+)
+
+S="${WORKDIR}"/${PN}-igc-${PV}
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_LIBRARY_PATH=$(get_llvm_prefix)/$(get_libdir)
+ -DIGC_OPTION__FORCE_SYSTEM_LLVM=ON
+ -DIGC_PREFERRED_LLVM_VERSION=8
+ )
+ cmake-utils_src_configure
+}