summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-04-23 20:06:00 +0200
committerConrad Kostecki <conikost@gentoo.org>2022-04-23 20:33:30 +0200
commit5544964357eb32cb9797dd61aceee25a7fc14a8a (patch)
treeb4d553f05174b16bde82fa3512d285cd73e9124f /dev-util/intel-graphics-system-controller
parentdev-util/intel-graphics-compiler: drop 1.0.10713-r1, 1.0.10840-r1 (diff)
downloadgentoo-5544964357eb32cb9797dd61aceee25a7fc14a8a.tar.gz
gentoo-5544964357eb32cb9797dd61aceee25a7fc14a8a.tar.bz2
gentoo-5544964357eb32cb9797dd61aceee25a7fc14a8a.zip
dev-util/intel-graphics-system-controller: add 0.6.0
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-util/intel-graphics-system-controller')
-rw-r--r--dev-util/intel-graphics-system-controller/Manifest1
-rw-r--r--dev-util/intel-graphics-system-controller/intel-graphics-system-controller-0.6.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-util/intel-graphics-system-controller/Manifest b/dev-util/intel-graphics-system-controller/Manifest
index 48ed33424220..5e9d90f83059 100644
--- a/dev-util/intel-graphics-system-controller/Manifest
+++ b/dev-util/intel-graphics-system-controller/Manifest
@@ -1 +1,2 @@
DIST intel-graphics-system-controller-0.2.4.tar.gz 125476 BLAKE2B 82c803dc654240a364416dcca6c1104ec96eca6a0ffec058394ec2594d87bdd6854a3b0143ad6e114b5b4359b15f787679c995fa60fcbbcf5097467c15252217 SHA512 57b0aa1f5cfb6c103903be590d94f4a07c33c90180e688b62b2434baddf16637a6fb6c160c225fa08cf2d0efc80a42c6b86de48b71fb6aa08bd3f9fe2ff79fa6
+DIST intel-graphics-system-controller-0.6.0.tar.gz 146082 BLAKE2B e67b6d5064aece983d047e1f64e0477c613fb7bc0912c5173cc1c1588151703098e0429c790f25d78a76caab8663b80e9fc20f313be2318c2be2b30aa6ca06f5 SHA512 265716648b1c2a2e8164643eaf8a6cdac57953493d67c805ecfb9077b834e17b13693c56958c219083fc8e4f5fb3e9cafb64d6b3dd40d510434d4517ec945fc3
diff --git a/dev-util/intel-graphics-system-controller/intel-graphics-system-controller-0.6.0.ebuild b/dev-util/intel-graphics-system-controller/intel-graphics-system-controller-0.6.0.ebuild
new file mode 100644
index 000000000000..7afb2e41ab53
--- /dev/null
+++ b/dev-util/intel-graphics-system-controller/intel-graphics-system-controller-0.6.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="igsc"
+MY_P="${MY_PN}-${PV}"
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit cmake python-any-r1
+
+DESCRIPTION="Intel graphics system controller firmware update library"
+HOMEPAGE="https://github.com/intel/igsc"
+SRC_URI="https://github.com/intel/${MY_PN}/archive/refs/tags/V${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="Apache-2.0"
+SLOT="0/0.6.0"
+KEYWORDS="~amd64"
+IUSE="+cli doc"
+
+RDEPEND="dev-libs/metee:="
+DEPEND="${RDEPEND}"
+BDEPEND="
+ doc? (
+ ${PYTHON_DEPS}
+ app-doc/doxygen
+ $(python_gen_any_dep 'dev-python/sphinx[${PYTHON_USEDEP}]')
+ )
+"
+
+pkg_setup() {
+ use doc && python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_CLI="$(usex cli)"
+ -DENABLE_DOCS="$(usex doc)"
+ -DENABLE_ENUM="ON"
+ -DENABLE_PERF="OFF"
+ -DENABLE_WERROR="OFF"
+
+ # If enabled, tests are automatically run during
+ # the compile phase and we cannot run them because
+ # they require permissions to access the hardware.
+ -DENABLE_TESTS="OFF"
+ )
+
+ cmake_src_configure
+}