summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2017-01-26 12:57:05 -0600
committerAustin English <wizardedit@gentoo.org>2017-01-26 13:01:19 -0600
commitecabd5fedb55fabbed1ce071bdba30f4abb27d39 (patch)
treecbdc7b308a9efb7735a1a797de6f3617abd48555 /dev-util/kcov/kcov-9999.ebuild
parentdev-util/kcov: add missing dependencies (diff)
downloadgentoo-ecabd5fedb55fabbed1ce071bdba30f4abb27d39.tar.gz
gentoo-ecabd5fedb55fabbed1ce071bdba30f4abb27d39.tar.bz2
gentoo-ecabd5fedb55fabbed1ce071bdba30f4abb27d39.zip
dev-util/kcov: add 9999 ebuild
Package-Manager: Portage-2.3.2, Repoman-2.3.1
Diffstat (limited to 'dev-util/kcov/kcov-9999.ebuild')
-rw-r--r--dev-util/kcov/kcov-9999.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-util/kcov/kcov-9999.ebuild b/dev-util/kcov/kcov-9999.ebuild
new file mode 100644
index 000000000000..b4cf68c4d7c2
--- /dev/null
+++ b/dev-util/kcov/kcov-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Kcov is a code coverage tester for compiled languages, Python and Bash"
+HOMEPAGE="https://github.com/SimonKagstrom/kcov"
+LICENSE="GPL-2"
+SLOT="0"
+
+if [ "${PV}" -eq 9999 ]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/SimonKagstrom/${PN}.git"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/SimonKagstrom/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+RDEPEND="
+ dev-libs/elfutils
+ net-misc/curl
+ sys-devel/binutils:*
+ sys-libs/zlib"
+DEPEND="${RDEPEND}"