summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-01 09:34:38 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-01 14:15:45 +0100
commit6478051c65ace998185314a4bc041628c0030466 (patch)
tree137cb1619d911c05b45496ba3581e101168502d7 /dev-util/lldb
parentdev-python/lit: Switch live to monorepo (diff)
downloadgentoo-6478051c65ace998185314a4bc041628c0030466.tar.gz
gentoo-6478051c65ace998185314a4bc041628c0030466.tar.bz2
gentoo-6478051c65ace998185314a4bc041628c0030466.zip
dev-util/lldb: Switch live to monorepo
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-util/lldb')
-rw-r--r--dev-util/lldb/lldb-10.0.0.9999.ebuild20
-rw-r--r--dev-util/lldb/lldb-9.0.1.9999.ebuild22
2 files changed, 13 insertions, 29 deletions
diff --git a/dev-util/lldb/lldb-10.0.0.9999.ebuild b/dev-util/lldb/lldb-10.0.0.9999.ebuild
index 81f32e23229d..63bc879c8b92 100644
--- a/dev-util/lldb/lldb-10.0.0.9999.ebuild
+++ b/dev-util/lldb/lldb-10.0.0.9999.ebuild
@@ -14,8 +14,8 @@ inherit cmake-utils git-r3 llvm multiprocessing python-single-r1 \
DESCRIPTION="The LLVM debugger"
HOMEPAGE="https://llvm.org/"
SRC_URI=""
-EGIT_REPO_URI="https://git.llvm.org/git/lldb.git
- https://github.com/llvm-mirror/lldb.git"
+EGIT_REPO_URI="https://github.com/llvm/llvm-project.git"
+S=${WORKDIR}/${P}/lldb
LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
SLOT="0"
@@ -49,18 +49,10 @@ pkg_setup() {
}
src_unpack() {
- if use test; then
- # needed for patched gtest
- git-r3_fetch "https://git.llvm.org/git/llvm.git
- https://github.com/llvm-mirror/llvm.git"
- fi
+ local dirs=( lldb )
+ use test && dirs+=( llvm/lib/Testing/Support llvm/utils/unittest )
git-r3_fetch
-
- if use test; then
- git-r3_checkout https://llvm.org/git/llvm.git \
- "${WORKDIR}"/llvm '' lib/Testing/Support utils/unittest
- fi
- git-r3_checkout
+ git-r3_checkout '' '' '' "${dirs[@]}"
}
src_configure() {
@@ -90,7 +82,7 @@ src_configure() {
-DLLDB_TEST_C_COMPILER="$(type -P clang)"
-DLLDB_TEST_CXX_COMPILER="$(type -P clang++)"
- -DLLVM_MAIN_SRC_DIR="${WORKDIR}/llvm"
+ -DLLVM_MAIN_SRC_DIR="${WORKDIR}/${P}/llvm"
-DLLVM_EXTERNAL_LIT="${EPREFIX}/usr/bin/lit"
-DLLVM_LIT_ARGS="-vv;-j;${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}"
)
diff --git a/dev-util/lldb/lldb-9.0.1.9999.ebuild b/dev-util/lldb/lldb-9.0.1.9999.ebuild
index 9389776f49b5..2b8872f4261c 100644
--- a/dev-util/lldb/lldb-9.0.1.9999.ebuild
+++ b/dev-util/lldb/lldb-9.0.1.9999.ebuild
@@ -14,9 +14,9 @@ inherit cmake-utils git-r3 llvm multiprocessing python-single-r1 \
DESCRIPTION="The LLVM debugger"
HOMEPAGE="https://llvm.org/"
SRC_URI=""
-EGIT_REPO_URI="https://git.llvm.org/git/lldb.git
- https://github.com/llvm-mirror/lldb.git"
-EGIT_BRANCH="release_90"
+EGIT_REPO_URI="https://github.com/llvm/llvm-project.git"
+EGIT_BRANCH="release/9.x"
+S=${WORKDIR}/${P}/lldb
LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
SLOT="0"
@@ -50,18 +50,10 @@ pkg_setup() {
}
src_unpack() {
- if use test; then
- # needed for patched gtest
- git-r3_fetch "https://git.llvm.org/git/llvm.git
- https://github.com/llvm-mirror/llvm.git"
- fi
+ local dirs=( lldb )
+ use test && dirs+=( llvm/lib/Testing/Support llvm/utils/unittest )
git-r3_fetch
-
- if use test; then
- git-r3_checkout https://llvm.org/git/llvm.git \
- "${WORKDIR}"/llvm '' lib/Testing/Support utils/unittest
- fi
- git-r3_checkout
+ git-r3_checkout '' '' '' "${dirs[@]}"
}
src_configure() {
@@ -90,7 +82,7 @@ src_configure() {
-DLLDB_TEST_C_COMPILER="$(type -P clang)"
-DLLDB_TEST_CXX_COMPILER="$(type -P clang++)"
- -DLLVM_MAIN_SRC_DIR="${WORKDIR}/llvm"
+ -DLLVM_MAIN_SRC_DIR="${WORKDIR}/${P}/llvm"
-DLLVM_EXTERNAL_LIT="${EPREFIX}/usr/bin/lit"
-DLLVM_LIT_ARGS="-vv;-j;${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}"
)