summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-07-31 00:40:19 +0200
committerThomas Deutschmann <whissi@gentoo.org>2019-07-31 01:02:44 +0200
commitea0be994cbef99a3a442c987a0a00d84e5063c67 (patch)
treec45a923a20deb9f9750b95ebbc87842309472b0d /dev-util/makepp
parentdev-util/checkbashisms: drop old (diff)
downloadgentoo-ea0be994cbef99a3a442c987a0a00d84e5063c67.tar.gz
gentoo-ea0be994cbef99a3a442c987a0a00d84e5063c67.tar.bz2
gentoo-ea0be994cbef99a3a442c987a0a00d84e5063c67.zip
dev-util/makepp: bump to v2.0.99.2
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-util/makepp')
-rw-r--r--dev-util/makepp/Manifest1
-rw-r--r--dev-util/makepp/makepp-2.0.99.2.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-util/makepp/Manifest b/dev-util/makepp/Manifest
index 3ddd5d4dff38..2c8e625c9eb7 100644
--- a/dev-util/makepp/Manifest
+++ b/dev-util/makepp/Manifest
@@ -1,2 +1,3 @@
DIST makepp-1.18.tar.gz 236990 BLAKE2B 4f2c894a706fd188eeeae4422ac828cd99cccb2e8f6b7280a2be55363b99f4fff011932f3dfd550062e932f5c90ddc7f41fd56cb5e765c694b7296ac7f7beb1c SHA512 e6d4fe2d8136bbbbec00401761bf5a4bf5ff15357e75080b942188a613b8156c67eac63f46ce89f1e521997ca620f22924dd0b9055dcb66e30801142dab4e0a9
DIST makepp-2.0.99.1.txz 532784 BLAKE2B e69495f0ffece81e7b15b668eea8bf4f9a26a36332bd1644594d697dd2301bea4bb2340fcd2805a33c44824113149fc617db610e6624900ec9d0d77054658d8c SHA512 457d64a2e9d2860dc2f7ad1bd4ef7df9fcd1563878dcd7b63e6f1d3fd6c03cdb89aab68faa018b3ef6b3009733a365fadbb49ad6c8a03ffe6eafcf867b765213
+DIST makepp-2.0.99.2.txz 528968 BLAKE2B e39c5fa515a1579ef5a568385550e8baf9176eac4a1871cdb7971ca8d3f92bfda73e5f27f4cf00c148a2c5c9622dd8253ebba0f555c6d46ce8c3581678bf8e68 SHA512 5aa8d255e545705802fec6ca304b2c672dfb9c59f7a064a5e9c4ef98f52d7dd5628023fe2a2449126ac1f9cc6ba7bac98233e3e4f07dd8a0559fd8aea7fd24a4
diff --git a/dev-util/makepp/makepp-2.0.99.2.ebuild b/dev-util/makepp/makepp-2.0.99.2.ebuild
new file mode 100644
index 000000000000..38db184f93fb
--- /dev/null
+++ b/dev-util/makepp/makepp-2.0.99.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PV=${PV/_}
+MY_P="${PN}-${MY_PV}"
+DESCRIPTION="GNU make replacement"
+HOMEPAGE="http://makepp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/2.1/${MY_P}.txz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~x86-linux ~ppc-macos"
+IUSE=""
+
+DEPEND="dev-lang/perl:="
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ # default "all" rule is to run tests :x
+ sed -i '/^all:/s:test::' config.pl || die
+ sed -i 's/^ my $gzip =.*/ my $gzip = "";/' install.pl || die
+ default
+}
+
+src_configure() {
+ # not an autoconf configure script
+ ./configure \
+ --prefix="${EPREFIX}"/usr \
+ --bindir="${EPREFIX}"/usr/bin \
+ --htmldir="${EPREFIX}"/usr/share/doc/${PF}/html \
+ --mandir="${EPREFIX}"/usr/share/man \
+ --datadir="${EPREFIX}"/usr/share/makepp \
+ || die "configure failed"
+}
+
+src_test() {
+ # work around https://bugzilla.samba.org/show_bug.cgi?id=8728
+ export CCACHE_UNIFY=1
+ ROOT= default
+}