summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/meld
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/meld')
-rw-r--r--dev-util/meld/Manifest2
-rw-r--r--dev-util/meld/meld-3.12.3.ebuild39
-rw-r--r--dev-util/meld/meld-3.14.0.ebuild38
-rw-r--r--dev-util/meld/metadata.xml5
4 files changed, 84 insertions, 0 deletions
diff --git a/dev-util/meld/Manifest b/dev-util/meld/Manifest
new file mode 100644
index 000000000000..868489a9a8ed
--- /dev/null
+++ b/dev-util/meld/Manifest
@@ -0,0 +1,2 @@
+DIST meld-3.12.3.tar.xz 462856 SHA256 db3572c5c6905b09f4fc28415a7f6f223014391492dd2165ed1bc8512ac4e6fd SHA512 ea462ece2dcc1a6843ac6ce557aa0ed09c320078b1945d40f2436bbd9f953bf2d826043fc5ee18e4840210cb1da8dd6031f2922109f457400b292d044fd3d27e WHIRLPOOL e1a84aafc16b0cdf4f64f524abd4972b32a37504b9810252161e03feb27a975f29f6d3926d66a99cd9e005613fdb77dabb7367243a1d3d137585c8829e2ec28e
+DIST meld-3.14.0.tar.xz 495168 SHA256 430e2936b787c90ffa0999d3c94611fcaa64ca1920933f31550d5b931b4f103c SHA512 3d64ad5e9c7b1a061b7ffd3b41343e521533a507aa90063499ab314339f541fc2099d17e570dd4c8f3d52e59a62d39e7b5e19c9a4d98dac5182c5080fbb43325 WHIRLPOOL 8cac08b5f3b8a577cb68148c0654d2e1dbd01a97f9768a5801e0e5ffc577af5535c3306972ada300d3dd7bb93e9528802e55dd0f11ae48490298b6e2efd63a6d
diff --git a/dev-util/meld/meld-3.12.3.ebuild b/dev-util/meld/meld-3.12.3.ebuild
new file mode 100644
index 000000000000..bcd495f1e7eb
--- /dev/null
+++ b/dev-util/meld/meld-3.12.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+PYTHON_REQ_USE="xml"
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit gnome2 distutils-r1
+
+DESCRIPTION="A graphical diff and merge tool"
+HOMEPAGE="http://meldmerge.org/"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-libs/glib-2.36:2
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-3.8:3[cairo,${PYTHON_USEDEP}]
+ gnome-base/gsettings-desktop-schemas
+ >=x11-libs/gtk+-3.6:3[introspection]
+ >=x11-libs/gtksourceview-3.6:3.0[introspection]
+ x11-themes/hicolor-icon-theme
+"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ dev-util/itstool
+ sys-devel/gettext
+"
+
+python_compile_all() {
+ mydistutilsargs=( --no-update-icon-cache --no-compile-schemas )
+}
diff --git a/dev-util/meld/meld-3.14.0.ebuild b/dev-util/meld/meld-3.14.0.ebuild
new file mode 100644
index 000000000000..3ed56a0e0aff
--- /dev/null
+++ b/dev-util/meld/meld-3.14.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+PYTHON_REQ_USE="xml"
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit gnome2 distutils-r1
+
+DESCRIPTION="A graphical diff and merge tool"
+HOMEPAGE="http://meldmerge.org/"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="${PYTHON_DEPS}
+ >=dev-libs/glib-2.36:2[dbus]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-3.8:3[cairo,${PYTHON_USEDEP}]
+ gnome-base/gsettings-desktop-schemas
+ >=x11-libs/gtk+-3.12:3[introspection]
+ >=x11-libs/gtksourceview-3.10:3.0[introspection]
+ x11-themes/hicolor-icon-theme
+"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ dev-util/itstool
+ sys-devel/gettext
+"
+
+python_compile_all() {
+ mydistutilsargs=( --no-update-icon-cache --no-compile-schemas )
+}
diff --git a/dev-util/meld/metadata.xml b/dev-util/meld/metadata.xml
new file mode 100644
index 000000000000..da6fd63d0085
--- /dev/null
+++ b/dev-util/meld/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+</pkgmetadata>