summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2018-03-24 13:47:42 -0500
committerWilliam Hubbs <williamh@gentoo.org>2018-03-24 13:48:24 -0500
commita2ebde67912bfb7df95a03ee21ef8740aaf47a71 (patch)
tree1082756f6bfc77e6de88e072bb7087cd953a4df6 /dev-util/meson
parentsys-kernel/dracut: fix html doc installation path (diff)
downloadgentoo-a2ebde67912bfb7df95a03ee21ef8740aaf47a71.tar.gz
gentoo-a2ebde67912bfb7df95a03ee21ef8740aaf47a71.tar.bz2
gentoo-a2ebde67912bfb7df95a03ee21ef8740aaf47a71.zip
dev-util/meson: 0.45.1 version bump
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-util/meson')
-rw-r--r--dev-util/meson/Manifest1
-rw-r--r--dev-util/meson/meson-0.45.1.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-util/meson/Manifest b/dev-util/meson/Manifest
index e0104e27f760..2c2c83f7eab1 100644
--- a/dev-util/meson/Manifest
+++ b/dev-util/meson/Manifest
@@ -1,2 +1,3 @@
DIST meson-0.44.1.tar.gz 1136337 BLAKE2B 7391776d2f480f43c6cf0bfae3665c16a61c4a28fc4310dc8659ab4165ef76ad1729a9daf645330ea213aeb59e5ba9d991d021d1ad620f6673cebfd64b085d93 SHA512 3c350d1752ae4463ec47060e051d79cc0855385e9552deff34fad8431175fb5d0f04b51a242f8f8f737726d06e504339d6b02a5aa9558ee673fb867dbb4e5b2d
DIST meson-0.45.0.tar.gz 1161584 BLAKE2B 4344d2eaa9f6242c69fa94603b948a43bb32143791aa9ebcb1e8ec4504af76696bca5b6da903551b4511ab498c4b5a8df4d231c965b304396224c646323d18f9 SHA512 9bc08655e113dc09857a71fe17bb3101d7aea625b65ae73054b0119069af71028d3b46ceee9f3a4eba02f5d21dbfab533c7c113c416881f213fdf01d452037e3
+DIST meson-0.45.1.tar.gz 1163287 BLAKE2B 820ab763193322c75ebf3a79cd38f49f9fa06f9645f382961eddab9bb088263f5ecc603d3ba6db9e038db1ea150d6897dc202bad24ff985ab1ef2dea3f08b724 SHA512 704731aae28ba5fe4c2040464d42489cfc1946c95c39e28eef170ba5ab929b8672c782ed18798528b59aeb38abd23e4930f38e38f1e8c45f1ccf96071b097731
diff --git a/dev-util/meson/meson-0.45.1.ebuild b/dev-util/meson/meson-0.45.1.ebuild
new file mode 100644
index 000000000000..37aab5a3b433
--- /dev/null
+++ b/dev-util/meson/meson-0.45.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{5,6} )
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/mesonbuild/meson"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x64-solaris"
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="Open source build system"
+HOMEPAGE="http://mesonbuild.com/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+RESTRICT="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+python_test() {
+ ${EPYTHON} run_tests.py || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ insinto /usr/share/vim/vimfiles
+ doins -r data/syntax-highlighting/vim/{ftdetect,indent,syntax}
+ insinto /usr/share/zsh/site-functions
+ doins data/shell-completions/zsh/_meson
+}