summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEttore Di Giacinto <mudler@gentoo.org>2016-11-09 16:18:11 +0100
committerEttore Di Giacinto <mudler@gentoo.org>2016-11-09 16:19:05 +0100
commita881ea37f6edc5c7840b8b69315e5fc26bcebed6 (patch)
tree6bcad71a0020a1d811940ee378f5c74708b351ef /dev-util/molecule-plugins/molecule-plugins-1.0.2-r1.ebuild
parentdev-util/molecule-core: revision bump (diff)
downloadgentoo-a881ea37f6edc5c7840b8b69315e5fc26bcebed6.tar.gz
gentoo-a881ea37f6edc5c7840b8b69315e5fc26bcebed6.tar.bz2
gentoo-a881ea37f6edc5c7840b8b69315e5fc26bcebed6.zip
dev-util/molecule-plugins: revision bump
* migrate to python-r1 eclass and EAPI=6 Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=599308 Package-Manager: portage-2.3.1
Diffstat (limited to 'dev-util/molecule-plugins/molecule-plugins-1.0.2-r1.ebuild')
-rw-r--r--dev-util/molecule-plugins/molecule-plugins-1.0.2-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-util/molecule-plugins/molecule-plugins-1.0.2-r1.ebuild b/dev-util/molecule-plugins/molecule-plugins-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..6dde2b7c17a1
--- /dev/null
+++ b/dev-util/molecule-plugins/molecule-plugins-1.0.2-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit python-r1
+
+DESCRIPTION="A set fo base plugins for Molecule"
+HOMEPAGE="http://www.sabayon.org"
+SRC_URI="mirror://sabayon/${CATEGORY}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+COMMON_DEPEND=">=dev-util/molecule-core-1.0.1 !<dev-util/molecule-1"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}
+ net-misc/rsync
+ sys-fs/squashfs-tools
+ sys-process/lsof
+ virtual/cdrtools"
+
+src_install() {
+ emake DESTDIR="${D}" LIBDIR="/usr/lib" \
+ PREFIX="/usr" SYSCONFDIR="/etc" install
+}