summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2018-11-13 11:09:03 -0500
committerVirgil Dupras <vdupras@gentoo.org>2018-11-13 13:04:19 -0500
commit05d5e71256665ca40897df0fc459cecdd08123e5 (patch)
treed184fcb4bbac9418b3218ff0ea238e7e25665e97 /dev-util/netsurf-buildsystem/netsurf-buildsystem-1.7.ebuild
parentdev-util/trace-cmd: Add -9999 live version (diff)
downloadgentoo-05d5e71256665ca40897df0fc459cecdd08123e5.tar.gz
gentoo-05d5e71256665ca40897df0fc459cecdd08123e5.tar.bz2
gentoo-05d5e71256665ca40897df0fc459cecdd08123e5.zip
dev-util/netsurf-buildsystem: new package
This replaces the netsurf eclass which not necessary and too complex for its own need. Being an eclass makes modifying it too heavy a process. Most of netsurf.eclass' purpose was to wrap netsurf's build system, which is now what we do in this package. In addition to installing it as a normal package, we add a helper shell script that can then be loaded in consumer ebuilds. Signed-off-by: Virgil Dupras <vdupras@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-util/netsurf-buildsystem/netsurf-buildsystem-1.7.ebuild')
-rw-r--r--dev-util/netsurf-buildsystem/netsurf-buildsystem-1.7.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-util/netsurf-buildsystem/netsurf-buildsystem-1.7.ebuild b/dev-util/netsurf-buildsystem/netsurf-buildsystem-1.7.ebuild
new file mode 100644
index 000000000000..f8dd03f986a9
--- /dev/null
+++ b/dev-util/netsurf-buildsystem/netsurf-buildsystem-1.7.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_P="buildsystem-${PV}"
+DESCRIPTION="Build system used for netsurf and its libs"
+HOMEPAGE="https://www.netsurf-browser.org"
+SRC_URI="https://download.netsurf-browser.org/libs/releases/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~m68k-mint"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+ sed -e 's:/bin/which:which:' -i "makefiles/Makefile.tools" || die
+}
+
+src_install() {
+ emake DESTDIR="${ED}" PREFIX=/usr install
+ insinto /usr/share/netsurf-buildsystem
+ doins "${FILESDIR}/gentoo-helpers.sh"
+}