summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2020-06-17 07:37:50 -0400
committerMichael Orlitzky <mjo@gentoo.org>2020-06-17 09:38:16 -0400
commiteee8e638bf1559af6f93fe2995d69e2b0b9f176c (patch)
tree828660a79062d261802a9371b02c009ba9c2104d /dev-util/netsurf-buildsystem/netsurf-buildsystem-1.9.ebuild
parentdev-util/bitcoin-tx-0.20.0: Remove reference to unnecessary/missing patch (diff)
downloadgentoo-eee8e638bf1559af6f93fe2995d69e2b0b9f176c.tar.gz
gentoo-eee8e638bf1559af6f93fe2995d69e2b0b9f176c.tar.bz2
gentoo-eee8e638bf1559af6f93fe2995d69e2b0b9f176c.zip
dev-util/netsurf-buildsystem: new version 1.9.
This version comes with a gentoo-helpers-r2.sh that contains the correct Gentoo-prefix paths for PREFIX and NSSHARED. The problem was originally reported against netsurf.eclass, but it has migrated to this script in the meantime. Bug: https://bugs.gentoo.org/489542 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'dev-util/netsurf-buildsystem/netsurf-buildsystem-1.9.ebuild')
-rw-r--r--dev-util/netsurf-buildsystem/netsurf-buildsystem-1.9.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-util/netsurf-buildsystem/netsurf-buildsystem-1.9.ebuild b/dev-util/netsurf-buildsystem/netsurf-buildsystem-1.9.ebuild
new file mode 100644
index 000000000000..70b4b63fad4f
--- /dev/null
+++ b/dev-util/netsurf-buildsystem/netsurf-buildsystem-1.9.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_P="buildsystem-${PV}"
+DESCRIPTION="Build system used for netsurf and its libs"
+HOMEPAGE="https://www.netsurf-browser.org"
+SRC_URI="https://download.netsurf-browser.org/libs/releases/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~m68k-mint"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+ sed -e 's:/bin/which:which:' -i "makefiles/Makefile.tools" || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+ insinto /usr/share/netsurf-buildsystem
+ newins "${FILESDIR}/gentoo-helpers-r2.sh" gentoo-helpers.sh
+}