summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/ninja-ide/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/ninja-ide/files')
-rw-r--r--dev-util/ninja-ide/files/ninja-ide-2.1.1-lang.patch26
-rw-r--r--dev-util/ninja-ide/files/ninja-ide-2.1.1-syntaxhighlighting.patch43
-rw-r--r--dev-util/ninja-ide/files/ninja-ide-2.2-python2_6.patch27
-rw-r--r--dev-util/ninja-ide/files/ninja-ide-2.2-syntax.patch9
-rw-r--r--dev-util/ninja-ide/files/ninja-ide-2.2-version.patch9
-rw-r--r--dev-util/ninja-ide/files/ninja-ide-2.3-python2_6.patch27
-rw-r--r--dev-util/ninja-ide/files/ninja-ide-2.3-syntax.patch9
7 files changed, 150 insertions, 0 deletions
diff --git a/dev-util/ninja-ide/files/ninja-ide-2.1.1-lang.patch b/dev-util/ninja-ide/files/ninja-ide-2.1.1-lang.patch
new file mode 100644
index 000000000000..a374dedde1f3
--- /dev/null
+++ b/dev-util/ninja-ide/files/ninja-ide-2.1.1-lang.patch
@@ -0,0 +1,26 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Tue Oct 9 20:22:45 UTC 2012
+Subject: build system
+
+add install rules for translations
+
+--- setup.py
++++ setup.py
+@@ -95,14 +95,15 @@
+
+ # include all resources
+ "include_package_data": True,
+- "package_data": {'': ['*.png', '*.json', '*.qss',
+- '*.js', '*.html', '*.css']},
++ "package_data": {'': ['*.png', '*.gif', '*.jpg', '*.json', '*.qss',
++ '*.js', '*.html', '*.css', '*.qm']},
+
+ # include ninja pkg and setup the run script
+ "packages": find_packages() + [
+ 'ninja_ide/addins',
+ 'ninja_ide/addins/syntax',
+ 'ninja_ide/addins/theme',
++ 'ninja_ide/addins/lang',
+ 'ninja_ide/doc',
+ 'ninja_ide/doc/css',
+ 'ninja_ide/doc/img',
diff --git a/dev-util/ninja-ide/files/ninja-ide-2.1.1-syntaxhighlighting.patch b/dev-util/ninja-ide/files/ninja-ide-2.1.1-syntaxhighlighting.patch
new file mode 100644
index 000000000000..f3eb64bf315a
--- /dev/null
+++ b/dev-util/ninja-ide/files/ninja-ide-2.1.1-syntaxhighlighting.patch
@@ -0,0 +1,43 @@
+https://github.com/ninja-ide/ninja-ide/commit/f19cffa29646f1f9bc015597080b8ebc0ed83530.patch
+https://github.com/ninja-ide/ninja-ide/commit/c722e86c4e497efac56de674c47d5e094ea4c5c5.patch
+
+backported by hasufell@gentoo.org for 2.1.1
+
+--- ninja_ide/gui/editor/highlighter.py
++++ ninja_ide/gui/editor/highlighter.py
+@@ -276,7 +276,7 @@
+ hls = []
+ block = self.currentBlock()
+ user_data = block.userData()
+- if user_data is None:
++ if user_data is None or not isinstance(user_data, SyntaxUserData):
+ user_data = SyntaxUserData(False)
+ user_data.clear_data()
+ block_number = block.blockNumber()
+@@ -321,7 +321,7 @@
+ hls = []
+ block = self.currentBlock()
+ user_data = block.userData()
+- if user_data is None:
++ if user_data is None or not isinstance(user_data, SyntaxUserData):
+ user_data = SyntaxUserData(False)
+ user_data.clear_data()
+ block_number = block.blockNumber()
+@@ -409,7 +409,7 @@
+ block = self.document().begin()
+ while block.isValid():
+ user_data = block.userData()
+- if (user_data is not None) and (user_data.error == True):
++ if (user_data is not None) and isinstance(user_data, SyntaxUserData) and (user_data.error == True):
+ errors_lines.append(block.blockNumber())
+ block = block.next()
+ return errors_lines
+@@ -462,7 +462,7 @@
+ ((st_fmt == STYLES['comment']) and
+ (self.previousBlockState() != 0))) and \
+ (len(start_collides) == 0):
+- if user_data is not None:
++ if user_data is not None and isinstance(user_data, SyntaxUserData):
+ style = highlight_errors(style, user_data)
+ self.setFormat(start, length, style)
+ else:
diff --git a/dev-util/ninja-ide/files/ninja-ide-2.2-python2_6.patch b/dev-util/ninja-ide/files/ninja-ide-2.2-python2_6.patch
new file mode 100644
index 000000000000..c01465dd9140
--- /dev/null
+++ b/dev-util/ninja-ide/files/ninja-ide-2.2-python2_6.patch
@@ -0,0 +1,27 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Wed Apr 24 21:05:44 UTC 2013
+Subject: fix compatibility with python:2.6
+
+--- ninja_ide/core/file_manager.py
++++ ninja_ide/core/file_manager.py
+@@ -26,7 +26,7 @@
+
+ from ninja_ide.core import settings
+
+-if sys.version_info.major == 3:
++if sys.version_info[0] == 3:
+ python3 = True
+ else:
+ python3 = False
+
+--- ninja_ide/gui/editor/editor.py
++++ ninja_ide/gui/editor/editor.py
+@@ -68,7 +68,7 @@
+ logger = NinjaLogger('ninja_ide.gui.editor.editor')
+
+
+-if sys.version_info.major == 3:
++if sys.version_info[0] == 3:
+ python3 = True
+ else:
+ python3 = False
diff --git a/dev-util/ninja-ide/files/ninja-ide-2.2-syntax.patch b/dev-util/ninja-ide/files/ninja-ide-2.2-syntax.patch
new file mode 100644
index 000000000000..0430b6448983
--- /dev/null
+++ b/dev-util/ninja-ide/files/ninja-ide-2.2-syntax.patch
@@ -0,0 +1,9 @@
+--- ninja_tests/core/examples/file_for_tests.py
++++ ninja_tests/core/examples/file_for_tests.py
+@@ -1,4 +1,4 @@
+ # -*- coding: utf-8 -*-
+
+-print 'testing'
+-print 'ñandú testing'
++print('testing')
++print('ñandú testing')
diff --git a/dev-util/ninja-ide/files/ninja-ide-2.2-version.patch b/dev-util/ninja-ide/files/ninja-ide-2.2-version.patch
new file mode 100644
index 000000000000..a060b2bf48d6
--- /dev/null
+++ b/dev-util/ninja-ide/files/ninja-ide-2.2-version.patch
@@ -0,0 +1,9 @@
+Correct package version.
+
+Patch by Aaron Burnett <awol.lordofthepants@gmail.com>
+
+--- ninja_ide/__init__.py
++++ ninja_ide/__init__.py
+@@ -29,1 +29,1 @@
+-__version__ = "2.2-dev"
++__version__ = "2.2"
diff --git a/dev-util/ninja-ide/files/ninja-ide-2.3-python2_6.patch b/dev-util/ninja-ide/files/ninja-ide-2.3-python2_6.patch
new file mode 100644
index 000000000000..c01465dd9140
--- /dev/null
+++ b/dev-util/ninja-ide/files/ninja-ide-2.3-python2_6.patch
@@ -0,0 +1,27 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Wed Apr 24 21:05:44 UTC 2013
+Subject: fix compatibility with python:2.6
+
+--- ninja_ide/core/file_manager.py
++++ ninja_ide/core/file_manager.py
+@@ -26,7 +26,7 @@
+
+ from ninja_ide.core import settings
+
+-if sys.version_info.major == 3:
++if sys.version_info[0] == 3:
+ python3 = True
+ else:
+ python3 = False
+
+--- ninja_ide/gui/editor/editor.py
++++ ninja_ide/gui/editor/editor.py
+@@ -68,7 +68,7 @@
+ logger = NinjaLogger('ninja_ide.gui.editor.editor')
+
+
+-if sys.version_info.major == 3:
++if sys.version_info[0] == 3:
+ python3 = True
+ else:
+ python3 = False
diff --git a/dev-util/ninja-ide/files/ninja-ide-2.3-syntax.patch b/dev-util/ninja-ide/files/ninja-ide-2.3-syntax.patch
new file mode 100644
index 000000000000..0430b6448983
--- /dev/null
+++ b/dev-util/ninja-ide/files/ninja-ide-2.3-syntax.patch
@@ -0,0 +1,9 @@
+--- ninja_tests/core/examples/file_for_tests.py
++++ ninja_tests/core/examples/file_for_tests.py
+@@ -1,4 +1,4 @@
+ # -*- coding: utf-8 -*-
+
+-print 'testing'
+-print 'ñandú testing'
++print('testing')
++print('ñandú testing')