summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViktar Patotski <xp.vit.blr@gmail.com>2020-11-09 22:45:24 +0100
committerPatrice Clement <monsieurp@gentoo.org>2020-11-12 22:28:34 +0100
commit257c52f40239f5b5bae0d81928a600867794936f (patch)
treeed01031ec8b65ede2a0d9026ec856051ed71e0b2 /dev-util/packer
parentx11-wm/i3-gaps: drop old unstable. (diff)
downloadgentoo-257c52f40239f5b5bae0d81928a600867794936f.tar.gz
gentoo-257c52f40239f5b5bae0d81928a600867794936f.tar.bz2
gentoo-257c52f40239f5b5bae0d81928a600867794936f.zip
dev-util/packer: bump version to 1.6.5.
This bumps dev-util/packer to latest version 1.6.5. Signed-off-by: Viktar Patotski <xp.vit.blr@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/18205 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-util/packer')
-rw-r--r--dev-util/packer/Manifest1
-rw-r--r--dev-util/packer/packer-1.6.5.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-util/packer/Manifest b/dev-util/packer/Manifest
index 191666f26938..ad37d1bb3945 100644
--- a/dev-util/packer/Manifest
+++ b/dev-util/packer/Manifest
@@ -2,3 +2,4 @@ DIST packer-1.4.0.tar.gz 9794922 BLAKE2B 2e1d817e0a3f549255ecd8693d6d99b2e45df2e
DIST packer-1.4.5.tar.gz 13705057 BLAKE2B d23527e8bb0104e3f0206f5a82eb93fbe15a9542409bcce13cefd49fa83a47c0262f48e74ff951990211de9f85fc32efd41bbd4ed286b3462aed86df68afebc8 SHA512 b2a3ae27612c78fcfcb2ac655437faf2cff6e587fd10033b39ddaca8b92b634b93ecd0ae7e3ee43253ee716a2c0f7da532b3ae0ce33c59d1d3896f9187d9a657
DIST packer-1.5.6.tar.gz 16037500 BLAKE2B 9409aad981b3494a442fc6854481853494b12b74532ed3ac8d210d4e275a8f4f18bfb6dcfd7c36c4e97b3d5ba0263155fc8f08592b0123705c5d341d9183e6eb SHA512 993f54a1bf98abd5bc450bafaf202fbbfbad009b661d49783ff82cba9891b8556340801680c0fdc33b90396a3101a2ed93a11798ad51c10d7bd5f81fef4f5a31
DIST packer-1.6.1.tar.gz 17334870 BLAKE2B c6db96de6a96c337ca2b2e7f273be21b4410e272817622af849346f38fab7212119aec1fcfd71b0c67bb00e8aad879485fd21cd42d7054eab4a37251fccc3ae7 SHA512 3b4b21eac425fec44a47a5799dcb5387099de06b777906a4b7c5bf169c71d8b82ab4296a21c8b60daefa4546d5a814b8d9f23e4d2afcf0eb91c3338d8f327ce7
+DIST packer-1.6.5.tar.gz 17900733 BLAKE2B b267f5b861de9eb4fc88ab747560aef30825897e1f42038ff443185c6591afec039e12a4639ca22598704a7ada68b8af373c67f7391f9884566fd0f431b3c0ee SHA512 17df612ccac44f6ee987cfee0f5b0422768302a40e7e4177c47e427fd0aa09be136ceda40272e6a1cbdeb52587b5c93f2fe7158f787e19399149ee514fec001d
diff --git a/dev-util/packer/packer-1.6.5.ebuild b/dev-util/packer/packer-1.6.5.ebuild
new file mode 100644
index 000000000000..f7b69386e57d
--- /dev/null
+++ b/dev-util/packer/packer-1.6.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit go-module
+
+DESCRIPTION="A tool to create identical machine images for multiple platforms"
+HOMEPAGE="https://www.packer.io"
+SRC_URI="https://github.com/hashicorp/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD-2 BSD-4 MIT MPL-2.0 unicode"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DOCS=( {README,CHANGELOG}.md )
+
+RESTRICT+=" test"
+
+src_compile() {
+ go build \
+ -ldflags "${go_ldflags}" \
+ -mod=vendor \
+ -work -o "bin/${PN}" ./ || die
+}
+
+src_install() {
+ dobin bin/packer
+
+ einstalldocs
+
+ insinto /usr/share/zsh/site-functions
+ doins contrib/zsh-completion/_packer
+}