summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2019-05-03 21:44:09 +0100
committerJames Le Cuirot <chewi@gentoo.org>2019-05-03 21:45:01 +0100
commit856213bc1a54ef26fb82b1b796f6247c1e8f11bb (patch)
treed7eac523d41d236f4cb861ca6b93fa87f36635eb /dev-util/patchelf
parentprofiles/arch/{ia64,sparc}/package.use.stable.mask: mask dev-util/geany-plugi... (diff)
downloadgentoo-856213bc1a54ef26fb82b1b796f6247c1e8f11bb.tar.gz
gentoo-856213bc1a54ef26fb82b1b796f6247c1e8f11bb.tar.bz2
gentoo-856213bc1a54ef26fb82b1b796f6247c1e8f11bb.zip
dev-util/patchelf: Reduce test fails by building tests with -no-pie
Now 0.8 passes and 0.10 has one 1 failure. Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'dev-util/patchelf')
-rw-r--r--dev-util/patchelf/patchelf-0.10.ebuild6
-rw-r--r--dev-util/patchelf/patchelf-0.8.ebuild6
2 files changed, 10 insertions, 2 deletions
diff --git a/dev-util/patchelf/patchelf-0.10.ebuild b/dev-util/patchelf/patchelf-0.10.ebuild
index dfc0d88d15f9..36271cd5f471 100644
--- a/dev-util/patchelf/patchelf-0.10.ebuild
+++ b/dev-util/patchelf/patchelf-0.10.ebuild
@@ -22,3 +22,9 @@ src_prepare() {
eautoreconf
}
+
+src_test() {
+ emake check \
+ CFLAGS+=" -no-pie" \
+ CXXFLAGS+=" -no-pie"
+}
diff --git a/dev-util/patchelf/patchelf-0.8.ebuild b/dev-util/patchelf/patchelf-0.8.ebuild
index 92c86cecf1a4..369a698a0395 100644
--- a/dev-util/patchelf/patchelf-0.8.ebuild
+++ b/dev-util/patchelf/patchelf-0.8.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -32,5 +32,7 @@ src_configure() {
}
src_test() {
- autotools-utils_src_test -j1
+ autotools-utils_src_test -j1 \
+ CFLAGS+=" -no-pie" \
+ CXXFLAGS+=" -no-pie"
}