summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2020-02-15 16:03:36 +0000
committerYixun Lan <dlan@gentoo.org>2020-02-15 16:04:27 +0000
commit3a2ac76b322629254386cc09adab087a8aa74f24 (patch)
tree24733fd8fc79dbaa7e5a86f2760df42b67b768bc /dev-util/perf
parentdev-util/perf: make perf build with both old and new libbfd (diff)
downloadgentoo-3a2ac76b322629254386cc09adab087a8aa74f24.tar.gz
gentoo-3a2ac76b322629254386cc09adab087a8aa74f24.tar.bz2
gentoo-3a2ac76b322629254386cc09adab087a8aa74f24.zip
dev-util/perf: drop old version
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'dev-util/perf')
-rw-r--r--dev-util/perf/Manifest1
-rw-r--r--dev-util/perf/perf-5.4.7.ebuild245
2 files changed, 0 insertions, 246 deletions
diff --git a/dev-util/perf/Manifest b/dev-util/perf/Manifest
index 38f95eb78e31..2014946c1b6e 100644
--- a/dev-util/perf/Manifest
+++ b/dev-util/perf/Manifest
@@ -6,4 +6,3 @@ DIST patch-4.14.33.xz 905284 BLAKE2B e67bd9a96708aaaf65eb0aa852493b2323c9e237bfc
DIST patch-4.20.3.xz 91732 BLAKE2B bf99271bcb35508df239343fd6c9d57c246f88320b586e44e2d97771d08b249a24db230214d4957015a5ed35261e201f0680101b99d0e92f0f1f69bc53e21458 SHA512 47178b8e3bfe4ba09cb82bb1ce8b0742e6749d4be3412fb57518918f7109e74eac1d3d8eb32a43e21b3837a14f37d5eefd8cab819defd10cc2db61fb0ceddeaf
DIST patch-5.3.7.xz 255616 BLAKE2B 18ec40508fdb2cc17dd927f3ddef07b2b744ff993de75bb7adebe3a3f97c9383ea1845085899aa939ca8a15515420c18a1ac0ae832f9ae52f18cc8ed59a1e75f SHA512 bf2717b721b3acfd423537a6a520388e6a596ae65605ed8c029a67c117a002e9a21c324de0dd41407bfdc8ef95263687764f4f46aa59cbb50f68ab21b96c29d6
DIST patch-5.4.20.xz 776552 BLAKE2B bad2a95ed8521ac5c379fe91e16d60b2a38de19b9239755084621e5230677b232ec4cf9e2e8161c0022daff43fdbb37d5b5b5bfdc9e932ef3a860bcd17f640f8 SHA512 65fbcdbd41e35c17601ff15bbe33933be2ab7a694aa181a0b802cc11c1c653c9b688dbb382076cbad05983a0c07467955c035ae25f5175f7ce5bc24339303d77
-DIST patch-5.4.7.xz 272092 BLAKE2B dc9e1cede993144a4d9cb17cb91d3857b6492fa1a971c743268afdc601edfafb033abc3ac24cb7789d3f171ea7fb6b60ad5197da445ab72f5e9cf2ae00e7f495 SHA512 396eaf9fe88045e6e308cbe8e72217b3334b637bfa7e85f8d27cc4dd8e3d94c6f58d2b7b3e237defcf647d500610b85780ec2e21f1d91ac41c5f4ef3e74dc161
diff --git a/dev-util/perf/perf-5.4.7.ebuild b/dev-util/perf/perf-5.4.7.ebuild
deleted file mode 100644
index bec92bb4af81..000000000000
--- a/dev-util/perf/perf-5.4.7.ebuild
+++ /dev/null
@@ -1,245 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
-inherit bash-completion-r1 estack eutils toolchain-funcs python-r1 linux-info
-
-MY_PV="${PV/_/-}"
-MY_PV="${MY_PV/-pre/-git}"
-
-DESCRIPTION="Userland tools for Linux Performance Counters"
-HOMEPAGE="https://perf.wiki.kernel.org/"
-
-LINUX_V="${PV:0:1}.x"
-if [[ ${PV} == *_rc* ]] ; then
- LINUX_VER=$(ver_cut 1-2).$(($(ver_cut 3)-1))
- PATCH_VERSION=$(ver_cut 1-3)
- LINUX_PATCH=patch-${PV//_/-}.xz
- SRC_URI="https://www.kernel.org/pub/linux/kernel/v${LINUX_V}/testing/${LINUX_PATCH}
- https://www.kernel.org/pub/linux/kernel/v${LINUX_V}/testing/v${PATCH_VERSION}/${LINUX_PATCH}"
-elif [[ ${PV} == *.*.* ]] ; then
- # stable-release series
- LINUX_VER=$(ver_cut 1-2)
- LINUX_PATCH=patch-${PV}.xz
- SRC_URI="https://www.kernel.org/pub/linux/kernel/v${LINUX_V}/${LINUX_PATCH}"
-else
- LINUX_VER=${PV}
- SRC_URI=""
-fi
-
-LINUX_SOURCES="linux-${LINUX_VER}.tar.xz"
-SRC_URI+=" https://www.kernel.org/pub/linux/kernel/v${LINUX_V}/${LINUX_SOURCES}"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="audit clang crypt debug +demangle +doc gtk java lzma numa perl python slang systemtap unwind zlib"
-# TODO babeltrace
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND="audit? ( sys-process/audit )
- crypt? ( dev-libs/openssl:0= )
- clang? (
- sys-devel/clang:*
- sys-devel/llvm:*
- )
- demangle? ( sys-libs/binutils-libs:= )
- gtk? ( x11-libs/gtk+:2 )
- java? ( virtual/jre:* )
- lzma? ( app-arch/xz-utils )
- numa? ( sys-process/numactl )
- perl? ( dev-lang/perl:= )
- python? ( ${PYTHON_DEPS} )
- slang? ( sys-libs/slang )
- systemtap? ( dev-util/systemtap )
- unwind? ( sys-libs/libunwind )
- zlib? ( sys-libs/zlib )
- dev-libs/elfutils"
-DEPEND="${RDEPEND}
- >=sys-kernel/linux-headers-4.19
- ${LINUX_PATCH+dev-util/patchutils}
- sys-devel/bison
- sys-devel/flex
- java? ( virtual/jdk )
- doc? (
- app-text/asciidoc
- app-text/sgml-common
- app-text/xmlto
- sys-process/time
- )"
-
-S_K="${WORKDIR}/linux-${LINUX_VER}"
-S="${S_K}/tools/perf"
-
-CONFIG_CHECK="~PERF_EVENTS ~KALLSYMS"
-
-src_unpack() {
- local paths=(
- tools/arch tools/build tools/include tools/lib tools/perf tools/scripts
- include lib "arch/*/lib"
- )
-
- # We expect the tar implementation to support the -j option (both
- # GNU tar and libarchive's tar support that).
- echo ">>> Unpacking ${LINUX_SOURCES} (${paths[*]}) to ${PWD}"
- tar --wildcards -xpf "${DISTDIR}"/${LINUX_SOURCES} \
- "${paths[@]/#/linux-${LINUX_VER}/}" || die
-
- if [[ -n ${LINUX_PATCH} ]] ; then
- eshopts_push -o noglob
- ebegin "Filtering partial source patch"
- filterdiff -p1 ${paths[@]/#/-i } -z "${DISTDIR}"/${LINUX_PATCH} \
- > ${P}.patch
- eend $? || die "filterdiff failed"
- eshopts_pop
- fi
-
- local a
- for a in ${A}; do
- [[ ${a} == ${LINUX_SOURCES} ]] && continue
- [[ ${a} == ${LINUX_PATCH} ]] && continue
- unpack ${a}
- done
-
- # support clang8
- echo $(clang-major-version)
- if use clang; then
- local old_CC=${CC}
- CC=${CHOST}-clang
- if [[ $(clang-major-version) -ge 8 ]]; then
- pushd "${S_K}" >/dev/null || die
- eapply \
- "${FILESDIR}/perf-5.1.15-fix-clang8.patch" \
- "${FILESDIR}/perf-5.4.6-fix-clang9.patch"
- popd || die
- fi
- CC=${old_CC}
- fi
-
- pushd "${S_K}" >/dev/null || die
- eapply "${FILESDIR}/perf-5.4.7-propagate-cflags.patch"
- popd || die
-}
-
-src_prepare() {
- default
- if [[ -n ${LINUX_PATCH} ]] ; then
- pushd "${S_K}" >/dev/null || die
- eapply "${WORKDIR}"/${P}.patch
- popd || die
- fi
-
- # Drop some upstream too-developer-oriented flags and fix the
- # Makefile in general
- sed -i \
- -e "s:\$(sysconfdir_SQ)/bash_completion.d:$(get_bashcompdir):" \
- "${S}"/Makefile.perf || die
- # A few places still use -Werror w/out $(WERROR) protection.
- sed -i -e 's:-Werror::' \
- "${S}"/Makefile.perf "${S_K}"/tools/lib/bpf/Makefile || die
-
- # Avoid the call to make kernelversion
- echo "#define PERF_VERSION \"${MY_PV}\"" > PERF-VERSION-FILE
-
- # The code likes to compile local assembly files which lack ELF markings.
- find -name '*.S' -exec sed -i '$a.section .note.GNU-stack,"",%progbits' {} +
-}
-
-puse() { usex $1 "" no; }
-perf_make() {
- # The arch parsing is a bit funky. The perf tools package is integrated
- # into the kernel, so it wants an ARCH that looks like the kernel arch,
- # but it also wants to know about the split value -- i386/x86_64 vs just
- # x86. We can get that by telling the func to use an older linux version.
- # It's kind of a hack, but not that bad ...
-
- # LIBDIR sets a search path of perf-gtk.so. Bug 515954
-
- local arch=$(tc-arch-kernel)
- local java_dir
- use java && java_dir="/etc/java-config-2/current-system-vm"
- # FIXME: NO_CORESIGHT
- # FIXME: NO_LIBBABELTRACE
- emake V=1 VF=1 \
- CC="$(tc-getCC)" CXX="$(tc-getCXX)" AR="$(tc-getAR)" LD="$(tc-getLD)" \
- prefix="${EPREFIX}/usr" bindir_relative="bin" \
- EXTRA_CFLAGS="${CFLAGS}" \
- ARCH="${arch}" \
- JDIR="${java_dir}" \
- LIBCLANGLLVM=$(usex clang 1 "") \
- NO_AUXTRACE="" \
- NO_BACKTRACE="" \
- NO_CORESIGHT=1 \
- NO_DEMANGLE=$(puse demangle) \
- NO_GTK2=$(puse gtk) \
- NO_JVMTI=$(puse java) \
- NO_LIBAUDIT=$(puse audit) \
- NO_LIBBABELTRACE=1 \
- NO_LIBBIONIC=1 \
- NO_LIBBPF="" \
- NO_LIBCRYPTO=$(puse crypt) \
- NO_LIBDW_DWARF_UNWIND="" \
- NO_LIBELF="" \
- NO_LIBNUMA=$(puse numa) \
- NO_LIBPERL=$(puse perl) \
- NO_LIBPYTHON=$(puse python) \
- NO_LIBUNWIND=$(puse unwind) \
- NO_SDT=$(puse systemtap) \
- NO_SLANG=$(puse slang) \
- NO_LZMA=$(puse lzma) \
- NO_ZLIB= \
- WERROR=0 \
- LIBDIR="/usr/libexec/perf-core" \
- "$@"
-}
-
-src_compile() {
- # test-clang.bin not build with g++
- if use clang; then
- pushd "${S_K}/tools/build/feature/" || die
- make V=1 CXX=${CHOST}-clang++ test-clang.bin || die
- popd
- fi
- perf_make -f Makefile.perf
- use doc && perf_make -C Documentation
-}
-
-src_test() {
- :
-}
-
-src_install() {
- _install_python_ext() {
- perf_make -f Makefile.perf install-python_ext DESTDIR="${D}"
- }
-
- perf_make -f Makefile.perf install DESTDIR="${D}"
- if use python; then
- python_foreach_impl _install_python_ext
- fi
-
- rm -rv "${ED}"/usr/share/doc/perf-tip || die
-
- if use gtk; then
- mv "${ED}"/usr/$(get_libdir)/libperf-gtk.so \
- "${ED}"/usr/libexec/perf-core || die
- fi
-
- dodoc CREDITS
-
- dodoc *txt Documentation/*.txt
- if use doc ; then
- HTML_DOCS="Documentation/*.html" einstalldocs
- doman Documentation/*.1
- fi
-}
-
-pkg_postinst() {
- if ! use doc ; then
- elog "Without the doc USE flag you won't get any documentation nor man pages."
- elog "And without man pages, you won't get any --help output for perf and its"
- elog "sub-tools."
- fi
-}