summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-12-08 23:29:26 +0800
committerIan Delaney <idella4@gentoo.org>2015-12-08 23:30:36 +0800
commit3994961434cdb8bc57313d4c9feac670cfeac303 (patch)
tree7ad50932aa87c34cac4e4248c15bee3a74e7e262 /dev-util/pkgconf
parentapp-portage/kuroo4: allow any SLOT of kde-apps/kompare (diff)
parentdev-util/pkgconf: set 0.9.12 to testing (diff)
downloadgentoo-3994961434cdb8bc57313d4c9feac670cfeac303.tar.gz
gentoo-3994961434cdb8bc57313d4c9feac670cfeac303.tar.bz2
gentoo-3994961434cdb8bc57313d4c9feac670cfeac303.zip
Merge remote-tracking branch 'remotes/Elizafox/master'
Pull request: https://github.com/gentoo/gentoo/pull/447
Diffstat (limited to 'dev-util/pkgconf')
-rw-r--r--dev-util/pkgconf/Manifest1
-rw-r--r--dev-util/pkgconf/pkgconf-0.9.12.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-util/pkgconf/Manifest b/dev-util/pkgconf/Manifest
index 21abdbf124ea..c86c49e31ab3 100644
--- a/dev-util/pkgconf/Manifest
+++ b/dev-util/pkgconf/Manifest
@@ -1 +1,2 @@
DIST pkgconf-0.9.11.tar.bz2 86489 SHA256 3bdae1b2672133943dc0dda694ed57074f8b03c3fea10efb215d76d3cabe2c3b SHA512 21313ef29afcaa7c49a8cb512ecd3a821693945c22fb1a670ada74f41bca320e1b9ffb64e79adc2c33cb86822b74ddc850fadb16ddcde7eb805b81a50096992f WHIRLPOOL 7442a456af7e959c86f318ee74ec89883cc4e2ad16c9708f98d8ab30cdcf71ea7ef13f7e0f9bf945717b1dea8a317ffc5322878f88a5084c2dcbdc2aeafaf4d2
+DIST pkgconf-0.9.12.tar.bz2 87109 SHA256 7ec8b516e655e247f4ba976837cee808134785819ab8f538f652fe919cc6c09f SHA512 efe13db7a46992eb44ead493fc12b3fc6a5567e0206f701b6c48d9b5eb0bc90fcc9ae7a7e08ae641bb10df869287e5b68291701d4013d6cf27bd2b1518c29192 WHIRLPOOL 9fa7336e111f29648f5c37310bdeb2266bead1b86ff18183cfb57c06054916d235da20a5723bd364497d20a1f4db399eaf77f38c0bfc1519f2b7b825ab4666d0
diff --git a/dev-util/pkgconf/pkgconf-0.9.12.ebuild b/dev-util/pkgconf/pkgconf-0.9.12.ebuild
new file mode 100644
index 000000000000..ebc4c7f9922a
--- /dev/null
+++ b/dev-util/pkgconf/pkgconf-0.9.12.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://github.com/pkgconf/pkgconf.git"
+ inherit autotools git-2 multilib-minimal
+else
+ inherit eutils multilib-minimal
+ SRC_URI="http://rabbit.dereferenced.org/~nenolod/distfiles/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc64-solaris ~x64-solaris"
+fi
+
+DESCRIPTION="pkg-config compatible replacement with no dependencies other than ANSI C89"
+HOMEPAGE="https://github.com/pkgconf/pkgconf"
+
+LICENSE="BSD-1"
+SLOT="0"
+IUSE="+pkg-config strict"
+
+RESTRICT="test" # at least until 0.9.13
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ pkg-config? (
+ !dev-util/pkgconfig
+ !dev-util/pkg-config-lite
+ !dev-util/pkgconfig-openbsd[pkg-config]
+ )"
+
+MULTILIB_CHOST_TOOLS=(
+ /usr/bin/pkgconf
+)
+
+src_prepare() {
+ [[ -e configure ]] || eautoreconf
+
+ if use pkg-config; then
+ MULTILIB_CHOST_TOOLS+=(
+ /usr/bin/pkg-config
+ )
+ fi
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ econf $(use_enable strict)
+}
+
+multilib_src_install() {
+ default
+ use pkg-config \
+ && dosym pkgconf /usr/bin/pkg-config \
+ || rm "${ED}"/usr/share/aclocal/pkg.m4 \
+ || die
+}