summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/ragel/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/ragel/files')
-rw-r--r--dev-util/ragel/files/ragel-6.7+gcc-4.7.patch178
-rw-r--r--dev-util/ragel/files/ragel-6.7-cross-compile.patch21
2 files changed, 199 insertions, 0 deletions
diff --git a/dev-util/ragel/files/ragel-6.7+gcc-4.7.patch b/dev-util/ragel/files/ragel-6.7+gcc-4.7.patch
new file mode 100644
index 000000000000..80eb29a46f05
--- /dev/null
+++ b/dev-util/ragel/files/ragel-6.7+gcc-4.7.patch
@@ -0,0 +1,178 @@
+From 27454d1e55b2a5cefc3cc1044d036add9ee9a6d3 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Diego=20Elio=20Petten=C3=B2?= <flameeyes@flameeyes.eu>
+Date: Tue, 22 May 2012 16:25:37 -0700
+Subject: [PATCH] aapl: fix building with gcc-4.7.0
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Starting with GCC 4.7, you have to explicit methods inherited from
+base templates, otherwise it will refuse to build.
+
+---
+
+The URL reported in the README is no longer registered, so I couldn't
+find a way to report this to an upstream project.
+
+Signed-off-by: Diego Elio Pettenò <flameeyes@flameeyes.eu>
+---
+ aapl/avlcommon.h | 12 ++++++------
+ aapl/bstcommon.h | 16 ++++++++--------
+ aapl/bubblesort.h | 2 +-
+ aapl/mergesort.h | 2 +-
+ 4 files changed, 16 insertions(+), 16 deletions(-)
+
+diff --git a/aapl/avlcommon.h b/aapl/avlcommon.h
+index 06983bc..2e3c190 100644
+--- a/aapl/avlcommon.h
++++ b/aapl/avlcommon.h
+@@ -881,9 +881,9 @@ template <AVLMEL_TEMPDEF> Element *AvlTree<AVLMEL_TEMPUSE>::
+ }
+
+ #ifdef AVL_BASIC
+- keyRelation = compare( *element, *curEl );
++ keyRelation = this->compare( *element, *curEl );
+ #else
+- keyRelation = compare( element->BASEKEY(getKey()),
++ keyRelation = this->compare( element->BASEKEY(getKey()),
+ curEl->BASEKEY(getKey()) );
+ #endif
+
+@@ -920,7 +920,7 @@ template <AVLMEL_TEMPDEF> Element *AvlTree<AVLMEL_TEMPUSE>::
+ long keyRelation;
+
+ while (curEl) {
+- keyRelation = compare( *element, *curEl );
++ keyRelation = this->compare( *element, *curEl );
+
+ /* Do we go left? */
+ if ( keyRelation < 0 )
+@@ -969,7 +969,7 @@ template <AVLMEL_TEMPDEF> Element *AvlTree<AVLMEL_TEMPUSE>::
+ return element;
+ }
+
+- keyRelation = compare( key, curEl->BASEKEY(getKey()) );
++ keyRelation = this->compare( key, curEl->BASEKEY(getKey()) );
+
+ /* Do we go left? */
+ if ( keyRelation < 0 ) {
+@@ -1023,7 +1023,7 @@ template <AVLMEL_TEMPDEF> Element *AvlTree<AVLMEL_TEMPUSE>::
+ return element;
+ }
+
+- keyRelation = compare(key, curEl->getKey());
++ keyRelation = this->compare(key, curEl->getKey());
+
+ /* Do we go left? */
+ if ( keyRelation < 0 ) {
+@@ -1058,7 +1058,7 @@ template <AVLMEL_TEMPDEF> Element *AvlTree<AVLMEL_TEMPUSE>::
+ long keyRelation;
+
+ while (curEl) {
+- keyRelation = compare( key, curEl->BASEKEY(getKey()) );
++ keyRelation = this->compare( key, curEl->BASEKEY(getKey()) );
+
+ /* Do we go left? */
+ if ( keyRelation < 0 )
+diff --git a/aapl/bstcommon.h b/aapl/bstcommon.h
+index 888717f..7c53ff3 100644
+--- a/aapl/bstcommon.h
++++ b/aapl/bstcommon.h
+@@ -361,7 +361,7 @@ template <BST_TEMPL_DEF> bool BstTable<BST_TEMPL_USE>::
+ }
+
+ mid = lower + ((upper-lower)>>1);
+- keyRelation = compare(key, GET_KEY(*mid));
++ keyRelation = this->compare(key, GET_KEY(*mid));
+
+ if ( keyRelation < 0 )
+ upper = mid - 1;
+@@ -373,12 +373,12 @@ template <BST_TEMPL_DEF> bool BstTable<BST_TEMPL_USE>::
+
+ lower = mid - 1;
+ while ( lower != lowEnd &&
+- compare(key, GET_KEY(*lower)) == 0 )
++ this->compare(key, GET_KEY(*lower)) == 0 )
+ lower--;
+
+ upper = mid + 1;
+ while ( upper != highEnd &&
+- compare(key, GET_KEY(*upper)) == 0 )
++ this->compare(key, GET_KEY(*upper)) == 0 )
+ upper++;
+
+ low = (Element*)lower + 1;
+@@ -419,7 +419,7 @@ template <BST_TEMPL_DEF> Element *BstTable<BST_TEMPL_USE>::
+ }
+
+ mid = lower + ((upper-lower)>>1);
+- keyRelation = compare(key, GET_KEY(*mid));
++ keyRelation = this->compare(key, GET_KEY(*mid));
+
+ if ( keyRelation < 0 )
+ upper = mid - 1;
+@@ -457,7 +457,7 @@ template <BST_TEMPL_DEF> Element *BstTable<BST_TEMPL_USE>::
+ }
+
+ mid = lower + ((upper-lower)>>1);
+- keyRelation = compare(key, GET_KEY(*mid));
++ keyRelation = this->compare(key, GET_KEY(*mid));
+
+ if ( keyRelation < 0 )
+ upper = mid - 1;
+@@ -508,7 +508,7 @@ template <BST_TEMPL_DEF> Element *BstTable<BST_TEMPL_USE>::
+ }
+
+ mid = lower + ((upper-lower)>>1);
+- keyRelation = compare(key, GET_KEY(*mid));
++ keyRelation = this->compare(key, GET_KEY(*mid));
+
+ if ( keyRelation < 0 )
+ upper = mid - 1;
+@@ -603,7 +603,7 @@ template <BST_TEMPL_DEF> Element *BstTable<BST_TEMPL_USE>::
+ }
+
+ mid = lower + ((upper-lower)>>1);
+- keyRelation = compare(GET_KEY(el), GET_KEY(*mid));
++ keyRelation = this->compare(GET_KEY(el), GET_KEY(*mid));
+
+ if ( keyRelation < 0 )
+ upper = mid - 1;
+@@ -662,7 +662,7 @@ template <BST_TEMPL_DEF> Element *BstTable<BST_TEMPL_USE>::
+ }
+
+ mid = lower + ((upper-lower)>>1);
+- keyRelation = compare(GET_KEY(el), GET_KEY(*mid));
++ keyRelation = this->compare(GET_KEY(el), GET_KEY(*mid));
+
+ if ( keyRelation < 0 )
+ upper = mid - 1;
+diff --git a/aapl/bubblesort.h b/aapl/bubblesort.h
+index bcc2fb6..f0f4ce5 100644
+--- a/aapl/bubblesort.h
++++ b/aapl/bubblesort.h
+@@ -72,7 +72,7 @@ template <class T, class Compare> void BubbleSort<T,Compare>::
+ changed = false;
+ for ( long i = 0; i < len-pass; i++ ) {
+ /* Do we swap pos with the next one? */
+- if ( compare( data[i], data[i+1] ) > 0 ) {
++ if ( this->compare( data[i], data[i+1] ) > 0 ) {
+ char tmp[sizeof(T)];
+
+ /* Swap the two items. */
+diff --git a/aapl/mergesort.h b/aapl/mergesort.h
+index 68b8426..8cefa73 100644
+--- a/aapl/mergesort.h
++++ b/aapl/mergesort.h
+@@ -110,7 +110,7 @@ template< class T, class Compare> void MergeSort<T,Compare>::
+ }
+ else {
+ /* Both upper and lower left. */
+- if ( compare(*lower, *upper) <= 0 )
++ if ( this->compare(*lower, *upper) <= 0 )
+ memcpy( dest++, lower++, sizeof(T) );
+ else
+ memcpy( dest++, upper++, sizeof(T) );
+--
+1.7.8.6
+
diff --git a/dev-util/ragel/files/ragel-6.7-cross-compile.patch b/dev-util/ragel/files/ragel-6.7-cross-compile.patch
new file mode 100644
index 000000000000..e953a1aeeeef
--- /dev/null
+++ b/dev-util/ragel/files/ragel-6.7-cross-compile.patch
@@ -0,0 +1,21 @@
+https://bugs.gentoo.org/473970
+
+already sent upstream
+
+patch by Jungshik Shin
+
+--- ragel-6.7/configure.in
++++ ragel-6.7/configure.in
+@@ -27,9 +27,9 @@
+
+ dnl Choose defaults for the build_parsers and build_manual vars. If the dist
+ dnl file is present in the root then default to no, otherwise go for it.
+-AC_CHECK_FILES( $srcdir/DIST,
+- [ . $srcdir/DIST; ],
+- [ build_parsers=yes; build_manual=yes; ] )
++
++AS_IF([test -r $srcdir/DIST], [. $srcdir/DIST], [build_parsers=yes;
++ build_manual=yes])
+
+ dnl
+ dnl Enable arg to explicitly control the building of the manual